Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-26-10, 11:58 PM   #1
Darkstar
Registered User
 
Join Date: Feb 2004
Posts: 7
Unhappy nvidia-settings do not persist clone and panning settings

I am running a tool called nvidia-settings which from the X Server Information dialog within it, I am guessing is NV-CONTROL Version 1.22 Running under openSuSE 11.2, KDE 4.4.2

I have two monitors connected to my GeForce 8500 GT card, one is a large 1920x1080 screen and the other is a 800x600 small monitor. I have set the small monitor up as a clone of the large monitor and configured it's panning size to be 1920x1080. This works fine as expected, but when I reboot the system the panning setting and clone mode are lost (reset back to Absolute) and I have to reset them again every time. A PITA!

How do I persist these settings so that the clone mode and panning is restored on rebooting the system?

Marc..
Darkstar is offline   Reply With Quote
Old 04-27-10, 12:59 AM   #2
Darkstar
Registered User
 
Join Date: Feb 2004
Posts: 7
Exclamation Re: nvidia-settings do not persist clone and panning settings

Ok well I think I figured out the problem.. This tool MUST be ran as root i.e. in superuser mode. It was installed as a menu item reachable via a normal user and is trying to modify the X11 config files. This tool should force the user to su to root before running, just like the Sax2 configuration tool does. IMHO this is a serious oversight and should be remedied as it leads to all kinds of confusion.

Marc..
Darkstar is offline   Reply With Quote
Old 04-27-10, 12:27 PM   #3
luk1don
Registered User
 
luk1don's Avatar
 
Join Date: Nov 2008
Posts: 55
Default Re: nvidia-settings do not persist clone and panning settings

Quote:
Originally Posted by Darkstar View Post
Ok well I think I figured out the problem.. This tool MUST be ran as root i.e. in superuser mode. It was installed as a menu item reachable via a normal user and is trying to modify the X11 config files. This tool should force the user to su to root before running, just like the Sax2 configuration tool does. IMHO this is a serious oversight and should be remedied as it leads to all kinds of confusion.

Marc..
You're right. It's the question for developers - not for NVIDIA team
luk1don is offline   Reply With Quote
Old 04-27-10, 01:06 PM   #4
Darkstar
Registered User
 
Join Date: Feb 2004
Posts: 7
Question Re: nvidia-settings do not persist clone and panning settings

Quote:
Originally Posted by luk1don View Post
You're right. It's the question for developers - not for NVIDIA team
Well now that was a surprising answer! If the developers of Nvidia tools for Linux are not monitoring this forum, how do I reach them and/or submit a bug report?

Marc...
Darkstar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:10 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.