Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-08, 06:11 PM   #1
roalter
Registered User
 
Join Date: Mar 2008
Posts: 21
Default 180.11 & red checkerboard

After installing 180.08, when playing back videos, either from DVD or 720p (I don't have any larger ones lying around) I get short moments, when the output is overlaid with a red/transparent checkerboard pattern.

I made a screenshot of it attached to this post.

playback is done with mplayer, output is xv. With the 177.80 all is well (the last driver I tried).

I'll revert for the moment to the 177.80, but looking forward for any help in decoding h.264 in matroska files, my AMD X2 3800 has 50-80% CPU usage on decoding them and this results in the occasional frame drop. ... seems like the old times, when I was playing back DVDs on my AMD K6-400, when I could playback dvds barely with lots of framedrop. I seriously hoped I would never have to experience this again...
Attached Thumbnails
Click image for larger version

Name:	180.08.jpg
Views:	809
Size:	70.4 KB
ID:	34130  

Last edited by roalter; 12-03-08 at 10:08 AM.
roalter is offline   Reply With Quote
Old 11-24-08, 04:23 AM   #2
roalter
Registered User
 
Join Date: Mar 2008
Posts: 21
Default Re: 180.08 & red checkerboard

*bump*

did anyone encounter this problem besides me? That's very strange...
roalter is offline   Reply With Quote
Old 12-02-08, 06:53 PM   #3
roalter
Registered User
 
Join Date: Mar 2008
Posts: 21
Default Re: 180.08 & red checkerboard

*another bump*

With 180.11 the problem still occurs.

I have a 8600 GTS and a 6200GS in my system (6200 being PCI). On the 6200 I did not encounter the problem, but on the 8600 GTS (where the TV is connected via HDMI) these checkerboard flickerings happen from time to time, both in fullscreen and window mode of mplayer, using XV as video output.
roalter is offline   Reply With Quote
Old 12-02-08, 08:38 PM   #4
CajunArson
Registered User
 
Join Date: Dec 2008
Posts: 1
Default Re: 180.08 & red checkerboard

You are not the only one. I have the red checker board with the 180 series drivers, but with the older 178 series drivers it was a black checkerboard (go figure).
My personal setup is using the new KDE 4.2 beta series under Kubuntu 8.10. I have two possible work-arounds that have worked for me: 1. Disabling the compositing manager has stopped the problem while watching video. 2. I've noticed that either enabling a scaling mode like the Expose' effect or maximizing the video window also helps.
I've noticed the checkerboarding with mplayer and vlc, but I've never seen it with things like Youtube videos in Flash.
I hope this helps, if you are using a desktop with compiz, try falling back to the non-compositing manager while watching video and that may help.
CajunArson is offline   Reply With Quote
Old 12-03-08, 07:37 AM   #5
roalter
Registered User
 
Join Date: Mar 2008
Posts: 21
Default Re: 180.08 & red checkerboard

Hm, no compositing working, since it won't do with both the 8600 and the 6200 in the system. (no GL on the 6200 either, so glxgears only shows an image on the 8600 screens, but remains black on the 6200 screen)

What really strikes me is on what causes this pattern. The size of the squares is 16x16 pixels, but they aren't completely opaque, but slightly translucent, so I reckon it must be something from the driver.
roalter is offline   Reply With Quote
Old 12-03-08, 07:54 AM   #6
mefistostarr
Registered User
 
Join Date: Dec 2008
Posts: 1
Default Re: 180.08 & red checkerboard

I can confirm similar bug - i use ubuntu 8.10, my videocard is mobile nvidia 8600GT.
if i watch video over XV-output (by default i use totem) and use scrolling in other window (for example, Pidgin Buddy List or Firefox), i can see blinking checkboard pattern.
It blinks when I use mouse move scrolling.

BTW: for me, bug present in 177.82 and 180.06 nvidia drivers.i use compiz.

Last edited by mefistostarr; 12-03-08 at 08:01 AM. Reason: add description
mefistostarr is offline   Reply With Quote
Old 12-13-08, 03:47 PM   #7
skarhand
Registered User
 
Join Date: Dec 2008
Posts: 2
Default Re: 180.08 & red checkerboard

I can confirm the red checkerboard when playing videos with mplayer/xv. It only appears for one frame or so once in a while. Video card is a GF 8800 GT with the 180.16 driver. Using compiz as well.
skarhand is offline   Reply With Quote
Old 12-13-08, 09:46 PM   #8
thecheatah
Registered User
 
Join Date: Oct 2008
Posts: 3
Default Re: 180.08 & red checkerboard

I can confirm this on mythtv as well.


http://www.nvnews.net/vbulletin/showthread.php?t=123789
thecheatah is offline   Reply With Quote

Old 12-29-08, 09:22 PM   #9
rdv
Registered User
 
Join Date: Nov 2008
Posts: 5
Default Re: 180.08 & red checkerboard

I am also experiencing this problem starting with the 177 driver when black checks would be displayed.

I installed the first release of the 180.xx series driver and the checks were gone. Now with the 180.18 driver I get red checks as described in previous posts. In addition to the occasional red checks I will also get a full red screen flash during xv video playback. I use both compiz-fusion and smplayer/mplayer.

I have a EVGA 8600 GTS.
rdv is offline   Reply With Quote
Old 01-11-09, 04:14 PM   #10
keyser7777
Registered User
 
Join Date: Dec 2008
Posts: 10
Default Re: 180.08 & red checkerboard

I can confirm too. I have an 8600GT card, and the problem appeared since 180.xx. I'm using KDE4 with kwin compositing enabled
keyser7777 is offline   Reply With Quote
Old 01-11-09, 06:41 PM   #11
theluckyone17
Registered User
 
Join Date: Jan 2009
Posts: 3
Default Re: 180.08 & red checkerboard

Quote:
Originally Posted by rdv View Post
I am also experiencing this problem starting with the 177 driver when black checks would be displayed.

I installed the first release of the 180.xx series driver and the checks were gone. Now with the 180.18 driver I get red checks as described in previous posts. In addition to the occasional red checks I will also get a full red screen flash during xv video playback. I use both compiz-fusion and smplayer/mplayer.

I have a EVGA 8600 GTS.
Same situation here. 177 would show a black checkerboard pattern on any video I was playing:
  • DVD Kaffeine: Xine engine
  • Electric Sheep screensaver

180.22 is giving me a red checkboard pattern, too. I don't get a fullscreen flash. Running KDE3 w/ Compiz-Fusion. Video card is a 9600GT.
theluckyone17 is offline   Reply With Quote
Old 01-19-09, 06:06 PM   #12
theluckyone17
Registered User
 
Join Date: Jan 2009
Posts: 3
Default Re: 180.08 & red checkerboard

A shameless bump, plus some more information:

Oddly enough, the problem seems to occur less the longer it's been since my last reboot.
theluckyone17 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
Saw Red: Frozen Synapse Expands, Gains Co-op News Archived News Items 0 05-30-12 05:26 AM
red hat 7.3 driver problems please help war18 NVIDIA Linux 7 09-16-02 01:25 PM
red hat distros gadido NVIDIA Linux 3 09-02-02 06:17 PM
Nvidia 1.0-2960 and Red Hat 7.3 Kernal 2.4.18-5 Cheetah NVIDIA Linux 30 08-23-02 11:50 AM
Source RPMS for GCC3.2 - Red Hat 8.0? chrisw01 NVIDIA Linux 4 08-21-02 09:17 AM

All times are GMT -5. The time now is 07:59 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.