Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-29-10, 07:00 AM   #1
azenz
Registered User
 
Join Date: Nov 2008
Posts: 15
Default Slow scrolling issues despite performance tweeks!

I am using a 8400GS on Kubuntu Lucid 64 bit with the 195.36.15 proprietary driver. Thanks to glyphcache=1, pixmapcache "1000000" and initialpixmapplacement=2 settings, scrolling with firefox or Openoffice became fairly smooth. Performance is still not great, only 750 FPS with glxgears on 1920x1200 full screen with compiz effects enabled, I would expect more to be honest (I am running a Q6600 quad core system overclocked to 3 Ghz and 6GB ram).

NOW, the issue is that when I have quite a few Firefox browser tabs open, say 15-20, and have a few Openoffice files open, then the scrolling performance in these programs becomes terrible even though the overall system performance is fine and system memory usage is only 50-70%. I would say scrolling gradually gets slower until it becomes totally choppy. That is really a problem. Any ideas?


My xorg.conf file:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@yellow) Fri Apr 9 11:51:21 UTC 2010

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Fri Mar 12 02:12:40 PST 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LEN L220xwC"
HorizSync 30.0 - 75.0
VertRefresh 50.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400 GS"
EndSection

Section "Screen"

# Removed Option "metamodes" "nvidia-auto-select +0+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Coolbits" "1"
Option "RenderAccel" "true"
Option "UseEvents" "false"
Option "TripleBuffer" "1"
Option "DamageEvents" "1"
Option "BackingStore" "1"
Option "UseCompositeWrapper" "True"
# Enables the X server's composite wrapper instead of the builtin one.
Option "AllowSHMPixmaps" "0"
# Option "AllowIndirectPixmaps" "True"
# + Could improve hardware rendering on G80+ cards with more than 256 MB of video memory.
#Option "BackingStore" "True"
# + Cache overlayed areas in case they get redisplayed later
Option "PixmapCacheSize" "3000000"
# + allocate said number of pixels for pixmap caches
Option "OnDemandVBlankInterrupts" "True"
# + only fire VBlank interrupts in modes where they are needed
Option "TwinView" "0"
Option "metamodes" "1920x1200_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Note: I tried setting PixmapCacheSize to 1 million, then even 3million, but no difference.
azenz is offline   Reply With Quote
Old 04-29-10, 06:40 PM   #2
siyuan
Registered User
 
Join Date: Dec 2008
Location: New Zealand
Posts: 6
Default Re: Slow scrolling issues despite performance tweeks!

Does Kubuntu use Oxygen window decoration by default? If it does, there's a suspected(/confirmed?) issue with this window decoration in KDE 4.4.x. Try any others and see if that helps.
siyuan is offline   Reply With Quote
Old 04-29-10, 06:47 PM   #3
damentz
Registered User
 
Join Date: Jan 2009
Posts: 59
Default Re: Slow scrolling issues despite performance tweeks!

First, clean up xorg.conf

Code:
Section "Device"
    Identifier     "Device0"
        Driver  "nvidia"
        Option      "Coolbits"  "1"
EndSection
Then, create a script you can run on login with something like this.

Code:
#!/bin/sh
nvidia-settings -a GlyphCache=1 -a PixmapCacheRoundSizeKB=4096

exit 0
It's important to take note which options are default and which options are, well, optional, and use only those. If you don't do that, you won't know which options make a difference.

Also, try putting your xorg.conf file and other bits of code in the code tags, makes it 100x easier to read.
damentz is offline   Reply With Quote
Old 04-30-10, 05:10 AM   #4
davelaser
Registered User
 
Join Date: Oct 2008
Posts: 86
Default Re: Slow scrolling issues despite performance tweeks!

You shouldn't need any tweaks at all to get decent 2d performance on the new drivers, they work really well with the defaults.
davelaser is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:17 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.