Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-13-10, 07:09 AM   #1
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Finally have correct refresh rate after reboot

Since the dawn of time I was never able to get the refresh rate to stick between reboots. I would have to go into nvidia settings and change it by hand, after every reboot. After reboot, the refresh rate would be set to "auto" which produced a fuzzy picture. Once changed to 60Hz, all was crisp and in focus.

This persisted over 3 different video cards, several versions of Ubuntu and many versions of the nvidia drivers.

many people will suggest using nvidia-settings --load-settings-only, but as far as I can tell, that method does not allow setting the Refresh Rate.

So I did some minor surgery on my xorg.conf. In a nutshell I decided to restrict its choices. In particular, I think the magic was to remove the auto option from the metamodes line. I also remove the 0 and 30 Hz options, leaving only 50 and 60.

Knock wood, but so far its working.

Code:
Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Philips"
    HorizSync       31.0 - 80.0
    VertRefresh     60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 240"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "metamodes" "1920x1080_60 +0+0; 1920x1080_50 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
Hope this can help someone else.

I guess a different question would be why isn't "auto" working?

I do still have to manually set RefreshRate after quitting XBMC (it changes the rate to auto upon exit )
zim2dive is offline   Reply With Quote
Old 05-13-10, 02:45 PM   #2
Arup
Registered User
 
Join Date: May 2009
Posts: 122
Default Re: Finally have correct refresh rate after reboot

Try gksudo nvidia-settings remove auto and select your resolution and refresh rate and save to x

This worked for me when setting 75Hz resolution for my LCD monitor. If you are using DVI connector, you are limited to 60Hz due to interface limitation.
Arup is offline   Reply With Quote
Old 05-13-10, 04:49 PM   #3
zim2dive
Registered User
 
Join Date: Dec 2008
Posts: 145
Default Re: Finally have correct refresh rate after reboot

Quote:
Originally Posted by Arup View Post
Try gksudo nvidia-settings remove auto and select your resolution and refresh rate and save to x

This worked for me when setting 75Hz resolution for my LCD monitor. If you are using DVI connector, you are limited to 60Hz due to interface limitation.
How do you "remove" auto within nvidia-settings?

(I launched ns many times, changed the RR and saved.. it never survived a reboot.)
zim2dive is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:04 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.