Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-30-10, 01:05 PM   #1
jmcgee
Registered User
 
Join Date: May 2010
Posts: 1
Default GLX problem

I can no longer start mythfrontend or mythtv-setup.

mythfrontend says this whens starting up:
2010-05-30 11:56:42.448 Using the OpenGL painter
2010-05-30 11:56:42.472 Failed to create OpenGL painter. Check your OpenGL installation.
QGLContext::makeCurrent(): Cannot make invalid context current.
2010-05-30 11:56:42.472 OpenGL: Deleting OpenGL Resources
QGLContext::makeCurrent(): Cannot make invalid context current.


mythuser@PVR1:~$ glxinfo
name of display: :0.0
Error: couldn't find RGB GLX visual or fbconfig

nvidia-settings says
Cannot query GLX Vendor.

I see some errors in xorg log that kernel driver did not load?

From synaptic I have completely removed all nvidia and reinstalled. I have deleted xorg.conf and rebooted trying to let Ubuntu 10.04 detect everything, same results.

I am using Nvidia drivers from avenard repository.
Attached Files
File Type: gz nvidia-bug-report.log.gz (56.3 KB, 77 views)
jmcgee is offline   Reply With Quote
Old 05-30-10, 09:50 PM   #2
adamk75
Registered User
 
Join Date: Nov 2006
Posts: 228
Default Re: GLX problem

If you're using Ubuntu, you should be using the drivers from the driver manger, not some third party repo. I suggest trying the approved, tested, drivers first.

Adam
adamk75 is offline   Reply With Quote
Old 05-31-10, 12:17 AM   #3
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: GLX problem

The nVidia module looks to load fine from /var/log/Xorg.0.log.

Code:
(**) May 30 11:13:31 NVIDIA(0): Enabling RENDER acceleration
(II) May 30 11:13:31 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) May 30 11:13:31 NVIDIA(0):     enabled.
(II) May 30 11:13:33 NVIDIA(0): NVIDIA GPU GeForce 8400 GS (G98) at PCI:3:0:0 (GPU-0)
(--) May 30 11:13:33 NVIDIA(0): Memory: 524288 kBytes
(--) May 30 11:13:33 NVIDIA(0): VideoBIOS: 62.98.12.00.00
(II) May 30 11:13:33 NVIDIA(0): Detected PCI Express Link width: 1X
(--) May 30 11:13:33 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) May 30 11:13:33 NVIDIA(0): Connected display device(s) on GeForce 8400 GS at PCI:3:0:0:
(--) May 30 11:13:33 NVIDIA(0):     Philips 32 LCD TV (DFP-0)
Problem looks to be here with myth in dmesg hence the segfault for whatever reason. Check around the myth site?

Code:
[   57.922725] mythfrontend.re[1674]: segfault at 35c ip 09ba4f96 sp bff1c38c error 4 in libGL.so.1.2[9ba3000+5000]
Why do you have

Code:
Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 6200"
EndSection
when it's a GeForce 8400 GS.
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Old 05-31-10, 12:51 PM   #4
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: GLX problem

Your Linux distribution is picking up the wrong version of libGL from a nonstandard location:
Code:
ldd /usr/bin/glxinfo

	linux-gate.so.1 =>  (0x00309000)
	libGL.so.1 => /usr/lib/mesa/libGL.so.1 (0x00bd8000)
	libm.so.6 => /lib/tls/i686/cmov/libm.so.6 (0x00383000)
	libX11.so.6 => /usr/lib/libX11.so.6 (0x0095b000)
	libpthread.so.0 => /lib/tls/i686/cmov/libpthread.so.0 (0x004e5000)
	libc.so.6 => /lib/tls/i686/cmov/libc.so.6 (0x0054c000)
	libXext.so.6 => /usr/lib/libXext.so.6 (0x00110000)
	libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x00b1e000)
	libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00813000)
	libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00120000)
	libdrm.so.2 => /lib/libdrm.so.2 (0x006ba000)
	libdl.so.2 => /lib/tls/i686/cmov/libdl.so.2 (0x00414000)
	/lib/ld-linux.so.2 (0x00e61000)
	libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00ea9000)
	librt.so.1 => /lib/tls/i686/cmov/librt.so.1 (0x008fb000)
	libXau.so.6 => /usr/lib/libXau.so.6 (0x00126000)
	libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x002df000)
You'll need to consult your distribution's documentation on how to fix the library search path.
AaronP is offline   Reply With Quote
Old 05-31-10, 12:59 PM   #5
Arup
Registered User
 
Join Date: May 2009
Posts: 122
Default Re: GLX problem

J. Avenard repo is the approved tried and tested ppa for those using Mythbuntu and there is nothing wrong at all with his files there.
Arup is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.