Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-23-10, 10:05 AM   #1
BoscoBearbank
Registered User
 
Join Date: Sep 2009
Posts: 8
Question Failed compile with Fedora kernel-2.6.34-11.fc14.x86_64

Using NVIDIA-Linux-x86_64-256.25.run (but also tried NVIDIA-Linux-x86_64-195.36.24-pkg2.run with the same result) with Fedora Rawhide. No problem compiling with kernel-2.6.34-0.28.rc3.git3.fc14.x86_64; failure with kernel-2.6.34-11.fc14.x86_64 (GPL-incompatible module nvidia.ko uses GPL-only symbol 'debug_lockdep_rcu_enabled'). nvidia-installer.log file is attached.

Can someone point me to a simple way to find the code that needs to be modified to work around GPL-only symbol errors such as these? Otherwise, all I can do is wait for someone else to deal with the problem.

Thanks
Attached Files
File Type: log nvidia-installer.log (24.9 KB, 91 views)

Last edited by BoscoBearbank; 05-23-10 at 10:06 AM. Reason: add attachment
BoscoBearbank is offline   Reply With Quote
Old 05-23-10, 03:14 PM   #2
ledoc
Registered User
 
Join Date: Jan 2008
Posts: 330
Default Re: Failed compile with Fedora kernel-2.6.34-11.fc14.x86_64

Did you compare the kernel configs? IIRC, there used to be some option to allow/disallow some GPL-only symbol export linking stuff..
ledoc is offline   Reply With Quote
Old 05-24-10, 10:08 AM   #3
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Failed compile with Fedora kernel-2.6.34-11.fc14.x86_64

My guess is that the new kernel was built with CONFIG_LOCKDEP, and that this option once again causes third-party modules to implicitly pick up GPL-only symbols (see e.g. http://www.nvnews.net/vbulletin/show...hlight=lockdep) for previous reports of similar problems.
zander is offline   Reply With Quote
Old 05-24-10, 11:25 AM   #4
BoscoBearbank
Registered User
 
Join Date: Sep 2009
Posts: 8
Default Re: Failed compile with Fedora kernel-2.6.34-11.fc14.x86_64

Quote:
Originally Posted by ledoc View Post
Did you compare the kernel configs? IIRC, there used to be some option to allow/disallow some GPL-only symbol export linking stuff..
Code:
/boot$ diff config-2.6.34-0.28.rc3.git3.fc14.x86_64 config-2.6.34-11.fc14.x86_64 
3,4c3,4
< # Linux kernel version: 2.6.34-0.28.rc3.git3.fc14.x86_64
< # Mon Apr  5 17:02:12 2010
---
> # Linux kernel version: 2.6.34-11.fc14.x86_64
> # Sat May 22 01:00:31 2010
1433a1434
> CONFIG_VMWARE_BALLOON=m
1743a1745
> CONFIG_MICREL_PHY=m
1848a1851,1852
> CONFIG_CHELSIO_T4_DEPENDS=y
> CONFIG_CHELSIO_T4=m
2038a2043,2044
> CONFIG_USB_IPHETH=m
> CONFIG_USB_SIERRA_NET=m
2376a2383
> CONFIG_INPUT_APPLEIR=m
2598c2605
< CONFIG_HWMON=m
---
> CONFIG_HWMON=y
2688a2696
> CONFIG_THERMAL_HWMON=y
2696d2703
< # CONFIG_MAX63XX_WATCHDOG is not set
4034a4042
> CONFIG_ACERHDF=m
4136a4145
> CONFIG_QUOTA_DEBUG=y
4529c4538
< # CONFIG_INTEL_TXT is not set
---
> CONFIG_INTEL_TXT=y
Nothing obvious, so I tried
Code:
/boot$ grep -i lockdep config*
config-2.6.34-0.28.rc3.git3.fc14.x86_64:CONFIG_LOCKDEP_SUPPORT=y
config-2.6.34-0.28.rc3.git3.fc14.x86_64:CONFIG_LOCKDEP=y
config-2.6.34-0.28.rc3.git3.fc14.x86_64:# CONFIG_DEBUG_LOCKDEP is not set
config-2.6.34-11.fc14.x86_64:CONFIG_LOCKDEP_SUPPORT=y
config-2.6.34-11.fc14.x86_64:CONFIG_LOCKDEP=y
config-2.6.34-11.fc14.x86_64:# CONFIG_DEBUG_LOCKDEP is not set
Given that I'm running Rawhide, it's not a pressing issue. However, knowing where to look for the fix would be nice.
BoscoBearbank is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:14 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.