Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-30-10, 02:46 PM   #1
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default nvidia-setting and glxgears

I noticed a strange issue with nvidia-settings and glxgears. After logging into gdm, glxgears returns correct results, e.g. 23210 frames in 5.0 seconds = 4641.924 FPS for my 8400M GS with NVIDIA Driver 256.25 and compositing off. Once nvidia-settings has been invoked, the reported frame rate drops enormously, e.g. 300 frames in 5.0 seconds = 59.895 FPS. However, direct rendering is still enabled,

$ glxinfo | grep rendering
direct rendering: Yes

which is puzzling.
stecklum is offline   Reply With Quote
Old 05-30-10, 03:02 PM   #2
jumjum77
Registered User
 
Join Date: Mar 2009
Posts: 13
Default Re: nvidia-setting and glxgears

The settings in nvidia-settings are not applied until the utility is run. Hence, you have different settings in the utility as compared to your xorg.conf.

The reason you get ~60fps is probably that nvidia-settings enables sync-to-vblank, which is a good thing. It removes tearing, and there's no need to render more frames than can be displayed on screen.

Use the -l option to load the settings in a startup script.
jumjum77 is offline   Reply With Quote
Old 05-30-10, 03:25 PM   #3
jeisom
Registered User
 
Join Date: Dec 2005
Location: My own little world
Posts: 117
Default Re: nvidia-setting and glxgears

Another thing is the composite manager may set sync to blank as well
jeisom is offline   Reply With Quote
Old 05-30-10, 11:32 PM   #4
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: nvidia-setting and glxgears

This is not puzzling, it is logical.
There are 2 ways to set the sync to vblank:
1. nvidia-setting's opengl options
2. compiz settings panel

These 2 might have a conflict if only one of them is set. It is not a problem per se, but you wont know when it is enabled and when its not. Launching nvidia-settings probably set it to enabled that is the default setting AFAIK.
Always set both to the same setting to control it.
gradinaruvasile is offline   Reply With Quote
Old 05-31-10, 01:37 AM   #5
stecklum
Registered User
 
Join Date: Feb 2009
Posts: 56
Default Re: nvidia-setting and glxgears

Thanks to all of you for the clarification.
stecklum is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:56 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.