Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-08-10, 06:47 AM   #1
cova
Registered User
 
Join Date: Mar 2005
Posts: 25
Default Intel-VT + 195.36.24 = Blank screen

Hi all,
I'm facing a problem with nvidia driver 195.36.24 on a 64 bit gentoo machine, an HP laptop 8440p with NVS 3100M rev 162.
(Core I5 CPU).

Basically If I turn on virtualization support in bios, the laptop boots but once it tries to fire up nvidia driver, the screen becomes blank and I've to reboot the machine. Turning off the virtualization support all works just fine.

The problem seems pretty similar to this one, reported for windows;

http://forums.nvidia.com/index.php?showtopic=169033

X Server 1.8.1
gcc (Gentoo 4.4.3-r2 p1.2) 4.4.3


I'll provide bug report in a short while.
cova is offline   Reply With Quote
Old 06-08-10, 09:59 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Intel-VT + 195.36.24 = Blank screen

Does the problem persist if you apply the attached patch and reinstall the driver?
# sh /path/to/NVIDIA-Linux-x86_64-195.36.24-pkg2.run \
--apply-patch /path/to/NVIDIA_kernel-195.36.24-6120611.diff.txt
...
# sh ./NVIDIA-Linux-x86_64-195.36.24-pkg2-custom.run
Attached Files
File Type: txt NVIDIA_kernel-195.36.24-6120611.diff.txt (6.7 KB, 419 views)
zander is offline   Reply With Quote
Old 06-09-10, 05:44 PM   #3
cova
Registered User
 
Join Date: Mar 2005
Posts: 25
Default Re: Intel-VT + 195.36.24 = Blank screen

Quote:
Originally Posted by zander View Post
Does the problem persist if you apply the attached patch and reinstall the driver?
No, the problem seems to be disappeared. Now I'm working in graphical environment, cpu is showing vmx flag and virtualbox runs in vt-x mode.

Fixed, I suppose

Many thanks for the quick and effective answer!
cova is offline   Reply With Quote
Old 06-09-10, 06:17 PM   #4
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Intel-VT + 195.36.24 = Blank screen

OK, thanks for giving the patch a try. Upcoming 256.xx driver builds should work out-of-the-box.
zander is offline   Reply With Quote
Old 06-24-10, 02:48 PM   #5
Jizzbug
Registered User
 
Join Date: Jun 2010
Posts: 1
Default Re: Intel-VT + 195.36.24 = Blank screen

RPM Fusion back-ported this patch into their kmod-nvidia RPMs for Fedora 13 x86_64.

Once I had the update my computer started to randomly freeze, with Xorg becoming tainted. Here are some relevant logs from /var/log/messages during a recent lock-up before I downgraded akmod-nvidia:

Jun 24 12:13:24 adbuster kernel: ALSA sound/pci/hda/hda_intel.c:661: spurious response 0x0:0x0, last cmd=0x5f0700
Jun 24 12:13:24 adbuster kernel: ALSA sound/pci/hda/hda_intel.c:661: spurious response 0x0:0x0, last cmd=0x5f0700
Jun 24 12:13:24 adbuster kernel: ALSA sound/pci/hda/hda_intel.c:661: spurious response 0x0:0x0, last cmd=0x5f0700
Jun 24 12:13:24 adbuster kernel: ALSA sound/pci/hda/hda_intel.c:661: spurious response 0x0:0x0, last cmd=0x5f0700
Jun 24 12:13:33 adbuster kernel: NVRM: Xid (0001:00): 16, Head 00000000 Count 00000010
Jun 24 12:13:33 adbuster kernel: NVRM: Xid (0001:00): 16, Head 00000001 Count 00000014
Jun 24 12:14:42 adbuster kernel: BUG: soft lockup - CPU#2 stuck for 61s! [Xorg:1895]
Jun 24 12:14:42 adbuster kernel: Modules linked in: fuse rfcomm sco bridge stp llc bnep l2cap cpufreq_ondemand acpi_cpufreq freq_table nf_conntrack_netbios_ns ip6t_REJECT nf_conntrack_ipv6 ip6table_filter ip6_tables ipv6 uinput nvidia(P) snd_hda_codec_idt snd_hda_intel snd_hda_codec snd_hwdep arc4 snd_seq ecb snd_seq_device iwlagn snd_pcm uvcvideo iwlcore i2c_i801 ppdev videodev v4l1_compat v4l2_compat_ioctl32 mac80211 e1000e snd_timer i2c_core parport_pc cfg80211 snd sdhci_pci sdhci btusb iTCO_wdt soundcore dell_wmi dcdbas bluetooth parport joydev mmc_core iTCO_vendor_support snd_page_alloc wmi rfkill microcode firewire_ohci firewire_core crc_itu_t yenta_socket rsrc_nonstatic video output [last unloaded: scsi_wait_scan]
Jun 24 12:14:42 adbuster kernel: CPU 2
Jun 24 12:14:42 adbuster kernel: Pid: 1895, comm: Xorg Tainted: P 2.6.33.5-124.fc13.x86_64 #1 0N5KHN/Latitude E6510
Jun 24 12:14:42 adbuster kernel: RIP: 0010:[<ffffffffa0658fff>] [<ffffffffa0658fff>] _nv006601rm+0x20/0x22 [nvidia]
Jun 24 12:14:42 adbuster kernel: RSP: 0018:ffff880129d69a20 EFLAGS: 00000206
Jun 24 12:14:42 adbuster kernel: RAX: 00000000ffffffff RBX: ffff880129eaad10 RCX: 000000000010aff0
Jun 24 12:14:42 adbuster kernel: RDX: ffffc90006b80000 RSI: ffff880129808000 RDI: ffff88012ba65800
Jun 24 12:14:42 adbuster kernel: RBP: ffffffff8142b30e R08: ffff8801217d8000 R09: 0000000000000018
Jun 24 12:14:42 adbuster kernel: R10: 0000000000000000 R11: ffff880129810000 R12: ffffffffa0641b47
Jun 24 12:14:42 adbuster kernel: R13: ffff880129d699c8 R14: 0000000000000097 R15: ffff880129d69a14
Jun 24 12:14:42 adbuster kernel: FS: 00007fdd742c2840(0000) GS:ffff880005a80000(0000) knlGS:0000000000000000
Jun 24 12:14:42 adbuster kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Jun 24 12:14:42 adbuster kernel: CR2: 00000000005a0a5c CR3: 0000000127821000 CR4: 00000000000006e0
Jun 24 12:14:42 adbuster kernel: DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jun 24 12:14:42 adbuster kernel: DR3: 0000000000000000 DR6: 00000000ffff0ff0 Jun 24 12:16:00 adbuster kernel: imklog 4.4.2, log source = /proc/kmsg started.
Jun 24 12:16:00 adbuster rsyslogd: [origin software="rsyslogd" swVersion="4.4.2" x-pid="1547" x-info="http://www.rsyslog.com"] (re)start
Jun 24 12:16:00 adbuster kernel: Initializing cgroup subsys cpuset
Jun 24 12:16:00 adbuster kernel: Initializing cgroup subsys cpu
Jun 24 12:16:00 adbuster kernel: Linux version 2.6.33.5-124.fc13.x86_64 (mockbuild@x86-10.phx2.fedoraproject.org) (gcc version 4.4.4 20100503 (Red Hat 4.4.4-2) (GCC) ) #1 SMP Fri Jun 11 09:38:12 UTC 2010
Jun 24 12:16:00 adbuster kernel: Command line: ro root=/dev/mapper/vg_adbuster-lv_root rd_LVM_LV=vg_adbuster/lv_root rd_LVM_LV=vg_adbuster/lv_swap rd_NO_LUKS rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYBOARDTYPE=pc KEYTABLE=us rhgb quiet acpi_oci=Linux rdblacklist=nouveau nomodeset selinux=0
Jizzbug is offline   Reply With Quote
Old 06-25-10, 03:09 AM   #6
igorjeri
Registered User
 
Join Date: Jun 2010
Posts: 1
Default Re: Intel-VT + 195.36.24 = Blank screen

Quote:
Originally Posted by zander View Post
Does the problem persist if you apply the attached patch and reinstall the driver?
# sh /path/to/NVIDIA-Linux-x86_64-195.36.24-pkg2.run \
--apply-patch /path/to/NVIDIA_kernel-195.36.24-6120611.diff.txt
...
# sh ./NVIDIA-Linux-x86_64-195.36.24-pkg2-custom.run

Is there a patch that I could apply for Windows server 2008?

I have the same issue using HyperV
igorjeri is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:02 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.