Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-14-10, 11:30 PM   #1
larophel
Registered User
 
Join Date: Nov 2009
Posts: 29
Default GT230M and 195.36.24: Stuttering when playing video with HDMI

Hi,

I am experiencing a problem when playing any video using my Geforce's GT230M HDMI output for both video and audio. the video skips frames and sound around every 10 seconds.
I have tried using vdpau but the result is the same.
The only thing that seems to help is to play the video in full screen, then hibernate and resume from hibernation (this I just discovered by accident), then the video will not skip anymore.
However, I would prefer not to have to do this workaround.
I am using the 195.36.24 nvidia drivers.
I have attached the nvidia-bugreport output and also the output of

mplayer -vo vdpau -ao alsa:device=plughw=1.7 greys.anatomy.s06e17.hdtv.xvid-2hd.avi

before and after hibernation.
VDPAU_TRACE=1 and VDPAU_NVIDIA_DEBUG=3 were set before running mplayer.

Many thanks in advance for your help.
Attached Files
File Type: gz mplayer_hib_after.log.gz (89.3 KB, 76 views)
File Type: gz mplayer_hib_before.log.gz (66.4 KB, 69 views)
File Type: gz nvidia-bug-report.log.gz (41.4 KB, 65 views)
larophel is offline   Reply With Quote
Old 06-15-10, 12:46 PM   #2
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

larophel, can you please try to isolate the problem a little further. For example, if you use a different output connector, does the problem still occur? What if you disable MPlayer audio output ("-ao none") or video output ("-vo none" I think). Do other media player applications have this same issue? Does the problem affect applications other than video file playback, e.g. an audio CD, or dragging windows around on the screen?

Thanks.
Stephen Warren is offline   Reply With Quote
Old 06-15-10, 01:13 PM   #3
larophel
Registered User
 
Join Date: Nov 2009
Posts: 29
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

Hi Stephen,

I have tested the following scenarios:
- If I do not use "-ao alsa:device=plughw=1.7" the video does not skip.
- Playing music (mp3) with mplayer -ao alsa:device=plughw=1.7 does not skip.
- Dragging windows around the screen does not skip.

I will test another video player (maybe xine?).
I will try the VGA output connector.
larophel is offline   Reply With Quote
Old 06-16-10, 08:16 PM   #4
larophel
Registered User
 
Join Date: Nov 2009
Posts: 29
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

Here are the results of:

VGA output:

It is a bit hard to tell without sound (as I used the same -ao device) but it seems to stutter also.

Another video player:

I installed XBMC and both video and audio play way too fast, it seems as if I was watching a movie at 20x the normal speed.

Should I try yet another video player?
larophel is offline   Reply With Quote
Old 06-17-10, 09:52 AM   #5
larophel
Registered User
 
Join Date: Nov 2009
Posts: 29
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

I forgot to mention:

the video plays only too fast in XBMC if I select HDMI audio output.
If not, then it plays normal.
larophel is offline   Reply With Quote
Old 06-17-10, 10:38 AM   #6
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

The XBMC results are odd. Perhaps the audio clock is simply incorrectly configured, so it's spitting out the audio too fast, and XBMC is trying to keep the video in sync with audio.

Can you try an audio-only application (play back an MP3 or CD rip or something) over HDMI audio. Is that also way too fast? I assume the fast audio is also very high-pitched?

Are you using any special kernel or audio drivers for the HDMI audio? I vaguely recall HDMI audio being supported on that card only very recently. Perhaps you need an updated driver for that.
Stephen Warren is offline   Reply With Quote
Old 06-18-10, 09:33 PM   #7
larophel
Registered User
 
Join Date: Nov 2009
Posts: 29
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

I have tried playing music with mpd / mpc: same result, way to fast
Yes, the fast audio is high pitched.

I was using alsa drivers from git from around May.
I have updated them now but nothing changed.

Do you have any idea what could cause this?

Thanks
larophel is offline   Reply With Quote
Old 06-27-10, 04:11 PM   #8
larophel
Registered User
 
Join Date: Nov 2009
Posts: 29
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

Any idea?

Thanks
larophel is offline   Reply With Quote

Old 06-28-10, 01:02 AM   #9
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: GT230M and 195.36.24: Stuttering when playing video with HDMI

As far as i know using only the -vo vdpau switch mplayer will use software codecs thus leading to high CPU usage in case of HD movies.
you need

mplayer -vo vdpau -vc ffodivxvdpau,ffh264vdpau,ffmpeg12vdpau,ffwmv3vdpau ,ffvc1vdpau

in order to use hardware vdpau decoding - you can use only one argument to -vc, but you must know the exact encoding of the file - this way all (presumably) movies will play through hardware vdpau decoding.

You can use pulseaudio for easy output switching, with -ao pulse (mplayer works well with it). Then you configure the pulse server as you like.
gradinaruvasile is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.