Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-15-10, 02:34 AM   #1
abelurio
Registered User
 
Join Date: Jun 2010
Posts: 3
Default Low resolution with Nvidia drivers

Hello,

I have a Zalman ZM-M220W monitor. The native resolution is 1680x1050 and it was correctly detected by the nv driver (fully updated Debian Lenny, fresh installation, kernel 2.6.26-2-amd64).

However, after installing the Nvidia driver NVIDIA-Linux-x86_64-195.36.31-pkg2, the highest resolution avaliable for that monitor is only 640x480.

In order to be able to use the computer I added a second monitor (DELL U2410, 1920x1200) which is automatically set up by the driver. Both can coexist usign TwinView (the Dell with the correct resolution and the Zalman only with the low resolution). I generated a new xorg.conf file using Nvidia-Settings but it does not solve the problem.

I have tried all kind of solutions such as setting the Zalman monitor refresh rates as per the manual, adding modelines, trying to set the native resolution in the xorg.conf files (which results in the monitor being switched off after gdm restart), disabling EDID, etc., etc., etc.

/var/log/Xorg.0.log does not offer much information on DFP-0 (Zalman), there are no errors. I guess that simply it is not correclty detected by the driver which therefore decides to use the most conservative settings.

This is my current xorg.conf file (DFP-0 is currently set to nvidia-auto-select, but I have tried many different options):

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildmeister@builder62) Thu Jun 3 09:42:34 PDT 2010

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "ZMT ZM-M220W(D)"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 4800"
BusID "PCI:10:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "DFP-4"
Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-4: 1920x1200 +1680+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
abelurio is offline   Reply With Quote
Old 06-15-10, 12:37 PM   #2
abelurio
Registered User
 
Join Date: Jun 2010
Posts: 3
Default Re: Low resolution with Nvidia drivers

Hi again,

I was able to set the correct resolution for the Zalman monitor by using risky options (see xorg.conf file below). The problem now is configuring TwinView for the second monitor to work:

Section "ServerLayout"
Identifier "X.org Configured"
Option "Xinerama" "0"
Option "TwinView" "1"
Screen 0 "Screen0" 0 0
Screen 1 "Screen1" RightOf "Screen0"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "record"
Load "dri2"
Load "dbe"
Load "glx"
Load "extmod"
Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "ZMT ZM-M220W(D)"
Option "DPMS"
Option "UseEdid" "FALSE"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Option "ExactModeTimingsDVI" "True"
HorizSync 30 - 81
VertRefresh 56 - 75
Option "DPI" "90x88"
Modeline "1680x1050@60" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "SWcursor" # [<bool>]
#Option "HWcursor" # [<bool>]
#Option "NoAccel" # [<bool>]
#Option "ShadowFB" # [<bool>]
#Option "VideoKey" # <i>
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GT200GL [Quadro FX 4800]"
BusID "PCI:10:0:0"
EndSection

Section "Device"
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
### [arg]: arg optional
#Option "ShadowFB" # [<bool>]
#Option "Rotate" # <str>
#Option "fbdev" # <str>
#Option "debug" # [<bool>]
Identifier "Card1"
Driver "fbdev"
VendorName "ASPEED Technology, Inc."
BoardName "ASPEED Graphics Family"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1680x1050@60"
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Card0"
Monitor "Monitor1"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 1
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
abelurio is offline   Reply With Quote
Old 06-15-10, 06:21 PM   #3
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: Low resolution with Nvidia drivers

Yes, setting a custom modeline as you have done should allow this to work.

I suspect that your monitor's EDID wasn't getting read for some reason. You can learn more about what exactly was happening by setting 'Option "ModeDebug" "True"' in the "Screen" section, restarting, and looking through the X log. With the ModeDebug option, you'll get verbose logging of the X server's mode validation.
danix is offline   Reply With Quote
Old 06-16-10, 11:05 AM   #4
abelurio
Registered User
 
Join Date: Jun 2010
Posts: 3
Default Re: Low resolution with Nvidia drivers

Below, you will find the working xorg.conf configuration. Now everything is fine. Fonts are maybe a bit blur as compared to the nouveau driver with each individual monitor. I will try to play with the anti-aliasing settings. Any suggestions?

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
FontPath "built-ins"
EndSection

Section "Module"
Load "record"
Load "dri"
Load "dri2"
Load "dbe"
Load "extmod"
Load "glx"

EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "ZMT"
ModelName "ZMT ZM-M220W"
Option "HorizSync" "DFP-0: 30.0-81.0; DFP-4: 30.0-81.0"
Option "VertRefresh" "DFP-0: 56.0-75.0; DFP-4: 56.0-76.0"
Modeline "1680x1050_60" 146.25 1680 1784 1960 2240 1050 1053 1059 1089 -hsync +vsync
Option "DPMS"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "GT200GL [Quadro FX 4800]"
BusID "PCI:10:0:0"
Option "ModeValidation" "NoDFPNativeResolutionCheck"
Option "ExactModeTimingsDVI" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "1"
Option "TwinViewOrientation" "DFP-4 Rightof DFP-0"
Option "Metamodes" "1680x1050_60, 1920x1200_60"
SubSection "Display"
Depth 24
EndSubSection
EndSection
abelurio is offline   Reply With Quote
Old 06-27-10, 02:17 PM   #5
ndy82
Registered User
 
Join Date: Jun 2010
Posts: 1
Default Re: Low resolution with Nvidia drivers

Hi there,

I had the same problem with the 195er nvidia driver and the Zalman ZM-M220W(D) monitor. Updating to the nvidia 256.32 driver solved the problem for me without changing my xorg.conf (that worked with the 185er driver).

Kind regards
andy
ndy82 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:25 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.