Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-23-10, 12:28 AM   #1
Blender3D
Registered User
 
Blender3D's Avatar
 
Join Date: Jun 2010
Posts: 1
Default Screen tinted red?

I know you get a lot of these 1-post newbies here who never use their accounts except for starting a single thread, but I never found a similar problem anywhere else.

I am building a Linux From Scratch system, and was forced to use the 64-bit .run package for the 1GB BFG-Tech 9800 GT. I'm not sure if this is the correct place to post this, as I just finished compiling X, which worked perfectly when I tested it, but here's there errors that I can recall with my driver:

I installed the driver, it compiled with a bunch of warnings about already-existing symlinks (I tried to install the driver without X a while back, which obviously didn't work), but installed successful. I run X, after running the NVIDIA X auto-config thing and rebooting, and recieve a bunch of messages about not being able to load the GLX module. I try to run Blender, which quits with some OpenGL error.

I then checked the installation, via the --sanity switch, and it failed for every single file (as many as I saw scroll down the screen). I then reinstalled the driver (ran the package with --uninstall and then reran it after rebooting). Same thing, same symlink warnings, same sanity check failures.

THEN, I completely uninstall it, reboot, and re-run Blender. It opens fine now, but whenever I rotate the default cube, it flashes red, green, and blue violently, and the X "desktop" is tinted bright red (Blender's colors and GUI is REALLY messed up; it is a mix of random colors with barely readable text).

Has anybody else had this problem? Here's my (current, non-NVIDIA) xorg.conf file if it helps:
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 256.25  (buildmeister@builder101)  Tue May 18 21:03:17 PDT 2010

Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath      "/usr/lib/X11/modules"
    FontPath        "/usr/share/fonts/X11/misc/"
    FontPath        "/usr/share/fonts/X11/TTF/"
    FontPath        "/usr/share/fonts/X11/OTF/"
    FontPath        "/usr/share/fonts/X11/Type1/"
    FontPath        "/usr/share/fonts/X11/100dpi/"
    FontPath        "/usr/share/fonts/X11/75dpi/"
EndSection

Section "Module"
    Load           "extmod"
    Load           "dbe"
    Load           "dri2"
    Load           "record"
    Load           "glx"
EndSection

Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "InputDevice"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/input/mice"
    Option         "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Monitor Vendor"
    ModelName      "Monitor Model"
EndSection

Section "Device"

        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
        ### [arg]: arg optional
        #Option     "SWcursor"           	# [<bool>]
        #Option     "HWcursor"           	# [<bool>]
        #Option     "NoAccel"            	# [<bool>]
        #Option     "ShadowFB"           	# [<bool>]
        #Option     "UseFBDev"           	# [<bool>]
        #Option     "Rotate"             	# [<str>]
        #Option     "VideoKey"           	# <i>
        #Option     "FlatPanel"          	# [<bool>]
        #Option     "FPDither"           	# [<bool>]
        #Option     "CrtcNumber"         	# <i>
        #Option     "FPScale"            	# [<bool>]
        #Option     "FPTweak"            	# <i>
        #Option     "DualHead"           	# [<bool>]
    Identifier     "Card0"
    Driver         "nvidia"
    VendorName     "Unknown Vendor"
    BoardName      "Unknown Board"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Card0"
    Monitor        "Monitor0"
    SubSection     "Display"
        Viewport    0 0
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       4
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       8
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       15
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       16
    EndSubSection
    SubSection     "Display"
        Viewport    0 0
        Depth       24
    EndSubSection
EndSection
Blender3D is offline   Reply With Quote
Old 06-23-10, 01:08 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Screen tinted red?

Please see the forum sticky posts about how to report a problem, including how to generate a bug report log file.
AaronP is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:43 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.