Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-30-10, 12:20 PM   #1
ZKJohan
Registered User
 
Join Date: Jun 2010
Posts: 2
Default Mouse freezes when internal graphic card enabled..

Hello other Nvidia-fans..

I'm using Fedora 13 as desktop system, on my home-made PC with the following specs:

AMD 9950 Quad-core processor (not overclocked or something..)
Asus m3n-78 PRO Motherboard with onboard NVIDIA 8300 chipset
MSI graphics card with NVIDIA 9800GT, 512 MB memory, PCI-express
Logitech Cordless desktop EX110 USB keyboard/mouse

Operating system:
Fedora 13, 64bit
Linux 2.6.33.5-112 kernel
Xorg X11-1.8.0-17

Nvidia driver version: 195.36.24
NV-Control version: 1.22

When I recently discovered that I was able to use a third monitor on the HDMI-output of the motherboard, I hooked it up and fixed my Xorg.conf (with a little help of nvidia-settings ), and my triple-monitor setup was born! Also, the troubles were born.. -.-.

It seems that when I enables my onboard graphical card, the mouse randomly stops working. The strange thing is also that my keyboard always keeps working. Sometimes after two minutes after login but sometimes I can work for 10 minutes.. It always stops working, no matter what I do. The only way to delay it is to not use the mouse. When I disable the onboard graphic card, my third monitor goes to black and the mouse-problem dissapears..

I have tried to use another graphic card, also with my internal graphics card enabled. Same problem.
I have tried to use a new, clean harddisk and install Fedora 11 (64 bit) and OpenSuse 11.2 (64bit), with an old nvidia geforce 7400LE chip and my new geforce 9800gt chip, with both cards the problem still exists.
I have googled a lot, the're are a few things that worked with some people, like adding 'irqpoll' add the load kernel line in the grub menu-list, did not helped.
I have tried to change my BIOS settings in every possible way, these are now:
Hybrid support: Disabled
iGPU Frame buffer control: Manual
iGPU Frame buffer Size: 512 MB
Onboard GPU: always enable (if set to 'auto', Linux doesn't recognize the card..)
iGPU Clock: 1000
iGPU Shader clock: 2000
K8<->NB HT Speed: Auto (no idea what it means , default value )
K8<->NB HT Width: Auto (no idea what it means , default value )
CPU Spread Spectrum: Auto (no idea what it means , default value )
PCIE Spread Spectrum: Auto (no idea what it means , default value )
SATA Spread spectrum: Auto (no idea what it means , default value )
Primary Display adapter: PCI-E

I have tried to unplug my mouse-receiver and replug it, did not work. In fact, my keyboard stopped working too. A reboot is the only possible way to make the mouse working again.
I have checked dmesg and /var/log/messages every time my mouse stops working, nothing strange was added. In fact, nothing was added since my mouse was working (nothing about a mouse or something, ofcourse there messages about networking and hard drive and blah )

My experience is that if something is not working the way you want in Linux, it's most of the time a wrong setting in a conf file or a package missing/wrong version.. But it seems to be that this is not the case..
Even with the graphic card enabled but nog configured and used the mouse freezes.
I have tried working in a fresh w1nd0ws XP installation with the internal graphics card enabled, and there the mouse keeps working.. So it seems to be that it is a linux issue :S

I have attached my xorg.conf for reference..

Does anyone had the same issue and fixed or does anyone have any idea how to fix my issue? Working with 3 monitors is priceless!!! And I refuse to use windows..!!!

Thank you so much.

ZKJohan
Attached Files
File Type: txt xorg_conf-1.txt (4.6 KB, 68 views)
ZKJohan is offline   Reply With Quote
Old 06-30-10, 12:54 PM   #2
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: Mouse freezes when internal graphic card enabled..

read: http://www.nvnews.net/vbulletin/showthread.php?t=46678
Licaon is offline   Reply With Quote
Old 06-30-10, 02:57 PM   #3
ZKJohan
Registered User
 
Join Date: Jun 2010
Posts: 2
Default Re: Mouse freezes when internal graphic card enabled..

I'm sorry, I didn't read it so closely, I was to desperate I guess =).

Booting with the 'idle=poll' line seems to do the trick. I'm able to work for almost one hour on my triple monitor setup without one freeze.!

Thank you for pointing me to the right direction!

Jay.
ZKJohan is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:35 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.