Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-05-10, 10:35 AM   #1
mmontg1
Registered User
 
Join Date: Jun 2007
Posts: 1
Default 2 card 3 monitors - 1 black screen, 2 working screens

Appears to be same issue reported here:

http://www.nvnews.net/vbulletin/showthread.php?t=130940

2 nvidia cards, geforce 7300gt, geforce 210. 7300 has 2 monitors attached, and works fine in twinview. After adding 2nd card, I can get all 3 monitors and 2 cards seen from the Xorg.0.log, but only 2 of the 3 get enabled. [notice the NVIDIA(GPU-1) below]

(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "TwinView" "0"
(**) NVIDIA(0): Option "MetaModes" "DFP: nvidia-auto-select +0+0"
(**) Jul 05 10:13:54 NVIDIA(0): Enabling RENDER acceleration
(II) Jul 05 10:13:54 NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) Jul 05 10:13:54 NVIDIA(0): enabled.
(II) Jul 05 10:13:56 NVIDIA(0): NVIDIA GPU GeForce 7300 GT (G73) at PCI:7:0:0 (GPU-0)
(--) Jul 05 10:13:56 NVIDIA(0): Memory: 262144 kBytes
(--) Jul 05 10:13:56 NVIDIA(0): VideoBIOS: 05.73.22.25.51
(II) Jul 05 10:13:56 NVIDIA(0): Detected PCI Express Link width: 8X
(--) Jul 05 10:13:56 NVIDIA(0): Interlaced video modes are supported on this GPU
(--) Jul 05 10:13:56 NVIDIA(0): Connected display device(s) on GeForce 7300 GT at PCI:7:0:0:
(--) Jul 05 10:13:56 NVIDIA(0): Samsung SyncMaster (CRT-1)
(--) Jul 05 10:13:56 NVIDIA(0): Apple Cinema HD Display (DFP-0)
(--) Jul 05 10:13:56 NVIDIA(0): Samsung SyncMaster (CRT-1): 400.0 MHz maximum pixel clock
(--) Jul 05 10:13:56 NVIDIA(0): Apple Cinema HD Display (DFP-0): 330.0 MHz maximum pixel
(--) Jul 05 10:13:56 NVIDIA(0): clock
(--) Jul 05 10:13:56 NVIDIA(0): Apple Cinema HD Display (DFP-0): Internal Dual Link TMDS
(II) Jul 05 10:13:56 NVIDIA(0): Display Device found referenced in MetaMode: DFP-0
(II) Jul 05 10:13:56 NVIDIA(0): Assigned Display Device: DFP-0
(II) Jul 05 10:13:56 NVIDIA(0): Validated modes:
(II) Jul 05 10:13:56 NVIDIA(0): "DFP:nvidia-auto-select+0+0"
(II) Jul 05 10:13:56 NVIDIA(0): Virtual screen size determined to be 1920 x 1200
(--) Jul 05 10:13:56 NVIDIA(0): DPI set to (99, 98); computed from "UseEdidDpi" X config
(--) Jul 05 10:13:56 NVIDIA(0): option
(==) Jul 05 10:13:56 NVIDIA(0): Enabling 32-bit ARGB GLX visuals.
(**) NVIDIA(1): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(1): RGB weight 888
(==) NVIDIA(1): Default visual is TrueColor
(==) NVIDIA(1): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(1): Option "TwinView" "0"
(**) NVIDIA(1): Option "MetaModes" "CRT: nvidia-auto-select +0+0"
(**) Jul 05 10:13:56 NVIDIA(1): Enabling RENDER acceleration
(II) Jul 05 10:13:56 NVIDIA(1): NVIDIA GPU GeForce 7300 GT (G73) at PCI:7:0:0 (GPU-0)
(--) Jul 05 10:13:56 NVIDIA(1): Memory: 262144 kBytes
(--) Jul 05 10:13:56 NVIDIA(1): VideoBIOS: 05.73.22.25.51
(II) Jul 05 10:13:56 NVIDIA(1): Detected PCI Express Link width: 8X
(--) Jul 05 10:13:56 NVIDIA(1): Interlaced video modes are supported on this GPU
(--) Jul 05 10:13:56 NVIDIA(1): Connected display device(s) on GeForce 7300 GT at PCI:7:0:0:
(--) Jul 05 10:13:56 NVIDIA(1): Samsung SyncMaster (CRT-1)
(--) Jul 05 10:13:56 NVIDIA(1): Apple Cinema HD Display (DFP-0)
(--) Jul 05 10:13:56 NVIDIA(1): Samsung SyncMaster (CRT-1): 400.0 MHz maximum pixel clock
(--) Jul 05 10:13:56 NVIDIA(1): Apple Cinema HD Display (DFP-0): 330.0 MHz maximum pixel
(--) Jul 05 10:13:56 NVIDIA(1): clock
(--) Jul 05 10:13:56 NVIDIA(1): Apple Cinema HD Display (DFP-0): Internal Dual Link TMDS
(II) Jul 05 10:13:56 NVIDIA(1): Display Device found referenced in MetaMode: CRT-1
(II) Jul 05 10:13:56 NVIDIA(1): Assigned Display Device: CRT-1
(II) Jul 05 10:13:56 NVIDIA(1): Validated modes:
(II) Jul 05 10:13:56 NVIDIA(1): "CRT:nvidia-auto-select+0+0"
(II) Jul 05 10:13:56 NVIDIA(1): Virtual screen size determined to be 1680 x 1050
(--) Jul 05 10:13:56 NVIDIA(1): DPI set to (90, 88); computed from "UseEdidDpi" X config
(--) Jul 05 10:13:56 NVIDIA(1): option
(==) Jul 05 10:13:56 NVIDIA(1): Enabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) Jul 05 10:14:00 NVIDIA(GPU-1): NVIDIA GPU GeForce 210 (GT218) at PCI:6:0:0 (GPU-1)
(--) Jul 05 10:14:00 NVIDIA(GPU-1): Memory: 1048576 kBytes
(--) Jul 05 10:14:00 NVIDIA(GPU-1): VideoBIOS: 70.18.2d.00.51
(II) Jul 05 10:14:00 NVIDIA(GPU-1): Detected PCI Express Link width: 8X
(--) Jul 05 10:14:00 NVIDIA(GPU-1): Interlaced video modes are supported on this GPU
(--) Jul 05 10:14:00 NVIDIA(GPU-1): Connected display device(s) on GeForce 210 at PCI:6:0:0:
(--) Jul 05 10:14:00 NVIDIA(GPU-1): Samsung SyncMaster (DFP-0)
(--) Jul 05 10:14:00 NVIDIA(GPU-1): Samsung SyncMaster (DFP-0): 330.0 MHz maximum pixel clock
(--) Jul 05 10:14:00 NVIDIA(GPU-1): Samsung SyncMaster (DFP-0): Internal Dual Link TMDS
(II) Jul 05 10:14:00 NVIDIA(0): Initialized GPU GART.

It stops before outputting this line "Display Device found referenced in MetaMode....." for NVIDIA(GPU-1)

Grub already has these lines:

title Ubuntu 10.04 LTS, kernel 2.6.32-23-generic-pae
root (hd0,0)
uppermem 524288
kernel /vmlinuz-2.6.32-23-generic-pae root=/dev/md2 ro quiet splash vmalloc=512M crashkernel=384M-2G:64M,2G-:128M
initrd /initrd.img-2.6.32-23-generic-pae

Nvidia driver version 256.35.

Any ideas on how I can get this working, or what I've done wrong?
mmontg1 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:38 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.