Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 06-27-10, 03:32 AM   #1
Nilam_AB
Registered User
 
Join Date: Jun 2010
Posts: 2
Default Failing to load module "nvidia" Quadro FX 3800M on OpenSUSE 11.2 x86_64

I have a new Lenovo W701DS laptop that has an Nvidia Quadro FX 3800M graphics card. I am using OpenSUSE 11.2 x86_64 (2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux).

The latest NVIDIA graphics drivers have been manually installed (x86_64 256.35). After installation I have tried initiating sax2 with the following commands "sax2", "sax2 -r", and "sax2 -r -m 0=nvidia". In all cases sax fails to start. The sax log reports that it was unable to load the nvidia module. Or reports that no screens are found.

If I uninstall the Nvidia driver gdm will start using the vesa driver. I have also tried using the Nvidia drivers from the OpenSUSE repositories with out luck (these are working fine on my W700DS with a Quadro FX 3700M).

Attached are the output files from Nvidia bug report, Nvidia Installer, SaX, and Xorg.

Any assistance in getting this up and running would be greatly appreciated.
Attached Files
File Type: gz nvidia-bug-report.log.gz (43.7 KB, 86 views)
File Type: gz nvidia-installer.log.gz (4.1 KB, 82 views)
File Type: gz SaX.log.gz (4.6 KB, 84 views)
File Type: gz Xorg.0.log.gz (2.2 KB, 78 views)
Nilam_AB is offline   Reply With Quote
Old 06-28-10, 08:22 PM   #2
Nilam_AB
Registered User
 
Join Date: Jun 2010
Posts: 2
Default Re: Failing to load module "nvidia" Quadro FX 3800M on OpenSUSE 11.2 x86_64

Still having no luck with this issue. Have reverted to the standard VESA frame buffer driver so that I can use the laptop.

Any ideas?
Nilam_AB is offline   Reply With Quote
Old 07-12-10, 01:28 PM   #3
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: Failing to load module "nvidia" Quadro FX 3800M on OpenSUSE 11.2 x86_64

Hi Nilam,

Could you attach a dump of your ACPI tables? (output of `acpidump -b`)
danix is offline   Reply With Quote
Old 07-14-10, 06:15 AM   #4
rainerklier
Registered User
 
Join Date: Oct 2003
Posts: 45
Default Re: Failing to load module "nvidia" Quadro FX 3800M on OpenSUSE 11.2 x86_64

Quote:
Originally Posted by Nilam_AB View Post
Still having no luck with this issue. Have reverted to the standard VESA frame buffer driver so that I can use the laptop.

Any ideas?
try to boot the kernel with the parameter
Code:
vga=normal
rainerklier is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.