Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-22-10, 04:55 PM   #1
Windseeker
Registered User
 
Join Date: Dec 2006
Posts: 38
Exclamation Xorg 1.8.2 segfault with driver 256.35

Hi there!

I was trying Xorg 1.8.2 from git snapshot 20100705 (using ubuntus xorg-edgers). I know that this is highly unstable but perhaps this points to a problem of nvidia driver, so I thought I better report.

As long as I use vesa or nv driver, everything works (within the limit of these drivers), and as soon as I use nvidia driver 256.35, X is segfaulting at start.

Interestingly: The affected system is 32-bit. Another system running the same ubuntu version on 64-bit does not have this problem and it's running the same X-Server with the same nvidia driver without crash.
Attached Files
File Type: gz nvidia-bug-report.log.gz (34.0 KB, 57 views)
Windseeker is offline   Reply With Quote
Old 07-22-10, 06:48 PM   #2
Vorgus
Registered User
 
Vorgus's Avatar
 
Join Date: Dec 2008
Posts: 107
Default Re: Xorg 1.8.2 segfault with driver 256.35

Is there a difference in video cards used or which port is used between the 32 and 64 bit system. I am using xorg that is used by debain squeeze. My 32 bit works with ether video prot but the x64 segfaults when using CRT-1.

http://www.nvnews.net/vbulletin/showthread.php?t=152528
Vorgus is offline   Reply With Quote
Old 07-23-10, 09:20 AM   #3
Windseeker
Registered User
 
Join Date: Dec 2006
Posts: 38
Default Re: Xorg 1.8.2 segfault with driver 256.35

Quote:
Originally Posted by Vorgus View Post
Is there a difference in video cards used or which port is used between the 32 and 64 bit system. I am using xorg that is used by debain squeeze. My 32 bit works with ether video prot but the x64 segfaults when using CRT-1.

http://www.nvnews.net/vbulletin/showthread.php?t=152528
Thank's alot for this idea. I will try it this evening (swapping whole X back and forth needs some spare time *g*). Tho I have to admit, I don't believe this is the same cause, because your X crashes with nvidia_drv.so involved and mine crashes with libglx.so involved.
Windseeker is offline   Reply With Quote
Old 07-23-10, 09:57 PM   #4
Vorgus
Registered User
 
Vorgus's Avatar
 
Join Date: Dec 2008
Posts: 107
Default Re: Xorg 1.8.2 segfault with driver 256.35

I didn't even install the opengl part because it's not needed for vdpau
Vorgus is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:54 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.