Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-08-10, 12:27 PM   #1
88fingerslukee
Registered User
 
Join Date: Sep 2010
Posts: 8
Default ION and HDMI/Optical Audio

Hi Everybody,

I've read all the threads and none answer my question specifically (either wrong card or wrong problem). I apologize if this has been resolved already but after days and days of trying to fix this problem I am at my wit's end.

I have ASRock ION 330HT with HDMI and Optical audio out. I am trying to run it as an HTPC using Ubuntu. I can get the video working on HDMI with no problems.

My issues start when I try to get audio working. Here's what DOES work:

1.) 2.0-channel audio over front-speaker analog port.
2.) partial audio over optical port

That's it.

What doesn't work:
1.) Multichannel audio, period.
2.) HDMI audio out

Here's what I have tried:

1.) Upgrading to ALSA 1.0.23
2.) Unmuting SPDIF outputs in alsamixer
3.) Changing asound.conf with multiple different things (don't remember them all now)
4.) Upgrading and downgrading NVIDIA drivers
5.) Banging my head.

Can anybody please let me know what I need to post here to help solve my problems?
88fingerslukee is offline   Reply With Quote
Old 09-08-10, 12:58 PM   #2
primerib
Registered User
 
Join Date: Dec 2008
Posts: 128
Default Re: ION and HDMI/Optical Audio

I don't have quite the same setup but FWIW my system has working HDMI audio:

Zotac IONITX-C
Debian testing linux
stable kernel 2.6.34.5 (using in-kernel Nvidia HDMI alsa drivers)
alsa-base 1.0.23+dfsg-1
alsa-utils 1.0.23-2

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0


/etc/asound.conf:
pcm.!default {
type hw
card 0
device 3
}
ctl.!default {
type hw
card 0
}

/etc/default/grub
Since I've compiled the drivers directly into my kernel, I'm setting my driver options in the default grub command line:

GRUB_CMDLINE_LINUX="snd-hda-intel.model=3stack-dig"

After changing /etc/default/grub, update-grub must be ran.

I believe that's it.
primerib is offline   Reply With Quote
Old 09-08-10, 01:01 PM   #3
88fingerslukee
Registered User
 
Join Date: Sep 2010
Posts: 8
Default Re: ION and HDMI/Optical Audio

Quote:
Originally Posted by primerib View Post
I don't have quite the same setup but FWIW my system has working HDMI audio:

Zotac IONITX-C
Debian testing linux
stable kernel 2.6.34.5 (using in-kernel Nvidia HDMI alsa drivers)
alsa-base 1.0.23+dfsg-1
alsa-utils 1.0.23-2

aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: HDA Generic [HDA Generic]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0


/etc/asound.conf:
pcm.!default {
type hw
card 0
device 3
}
ctl.!default {
type hw
card 0
}

/etc/default/grub
Since I've compiled the drivers directly into my kernel, I'm setting my driver options in the default grub command line:

GRUB_CMDLINE_LINUX="snd-hda-intel.model=3stack-dig"

After changing /etc/default/grub, update-grub must be ran.

I believe that's it.
thank you. Is your kernel a custom one then?
88fingerslukee is offline   Reply With Quote
Old 09-08-10, 01:04 PM   #4
primerib
Registered User
 
Join Date: Dec 2008
Posts: 128
Default Re: ION and HDMI/Optical Audio

Yes, I compile my own kernels. Although you should be okay with a pre-made kernel as long as the Nvidia HDMI driver is included (just a guess). If you're using the driver as a module, then you'll need to add options snd-hda-intel model=3stack-dig to your /etc/modprobe.d/alsa-base.conf file. Assuming that model setting is correct for your mainboard. Otherwise you'll need to adjust it accordingly.
primerib is offline   Reply With Quote
Old 09-08-10, 02:20 PM   #5
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: ION and HDMI/Optical Audio

88fingerslukee,

Which display driver version are you using? Providing an nvidia-bug-report would help.

Can you please try each of the following:

speaker-test -c 2 -r 48000 hw:0,3
speaker-test -c 2 -r 48000 hw:0,7
speaker-test -c 2 -r 48000 hw:0,8
speaker-test -c 2 -r 48000 hw:0,9

Do any of those work?

If so, please see my post #7 here:

http://www.nvnews.net/vbulletin/showthread.php?t=154755

In particular, problem (c) in that post.
Stephen Warren is offline   Reply With Quote
Old 09-09-10, 02:59 PM   #6
primerib
Registered User
 
Join Date: Dec 2008
Posts: 128
Default Re: ION and HDMI/Optical Audio

Any luck yet 88fingerslukee?
primerib is offline   Reply With Quote
Old 09-09-10, 06:47 PM   #7
88fingerslukee
Registered User
 
Join Date: Sep 2010
Posts: 8
Default Re: ION and HDMI/Optical Audio

Quote:
Originally Posted by primerib View Post
Any luck yet 88fingerslukee?

Sorry, didn't have time to test until now.

Fresh install Kubuntu 10.04.1
alsa 1.0.23
nVidia drivers 260.19.04

Code:
aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC889A Analog [ALC889A Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC889A Digital [ALC889A Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
speaker-test -c 2 -r 48000 hw:0,3

gives no output (the rest don't work either).

I have added the options snd-hda-intel model=3stack-dig line to my alsa-base.conf but still nothing.
I do not know how to find the correct line for my mainboard. Is there a list somewhere?
Attached Files
File Type: gz nvidia-bug-report.log.gz (41.4 KB, 84 views)
88fingerslukee is offline   Reply With Quote
Old 09-09-10, 10:31 PM   #8
primerib
Registered User
 
Join Date: Dec 2008
Posts: 128
Default Re: ION and HDMI/Optical Audio

And you also did your asound.conf? I'm a bit surprised it's not working to be honest. You also have unmuted the device in alsamixer as well right?
primerib is offline   Reply With Quote

Old 09-09-10, 10:33 PM   #9
88fingerslukee
Registered User
 
Join Date: Sep 2010
Posts: 8
Default Re: ION and HDMI/Optical Audio

Quote:
Originally Posted by primerib View Post
And you also did your asound.conf? I'm a bit surprised it's not working to be honest. You also have unmuted the device in alsamixer as well right?
First thing I did was to unmute the sound in alsamixer. I have read about that already. I did the asound.conf as well, yes.

This is where I am. It makes no sense.
88fingerslukee is offline   Reply With Quote
Old 09-09-10, 11:25 PM   #10
88fingerslukee
Registered User
 
Join Date: Sep 2010
Posts: 8
Default Re: ION and HDMI/Optical Audio

Just in case you were thinking that it's a physical hardware issue:

I had this same computer hooked up to the exact same setup while running windows 7 and it worked flawlessly. So I know for a fact that the HDMI port works and outputs 7.1 audio.

I'm stumped.
88fingerslukee is offline   Reply With Quote
Old 09-10-10, 10:04 AM   #11
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: ION and HDMI/Optical Audio

Ah, you have this in xorg.conf:

Option "UseEDID" "FALSE"

This prevents the display driver from reading the EDID, which in turn prevents it from knowing that the monitor is capable of receiving audio, which in turn prevents it from sending audio infoframes, which prevents the monitor from knowing that audio is being sent. That's why it's not working.
Stephen Warren is offline   Reply With Quote
Old 09-10-10, 10:10 AM   #12
88fingerslukee
Registered User
 
Join Date: Sep 2010
Posts: 8
Default Re: ION and HDMI/Optical Audio

Quote:
Originally Posted by Stephen Warren View Post
Ah, you have this in xorg.conf:

Option "UseEDID" "FALSE"

This prevents the display driver from reading the EDID, which in turn prevents it from knowing that the monitor is capable of receiving audio, which in turn prevents it from sending audio infoframes, which prevents the monitor from knowing that audio is being sent. That's why it's not working.
I have that option set because I am using a custom resolution. See the attached xorg.conf file.

My plasma has significant overscan so in order for the 1920x1080 resolution to work I have to work around the EDID info.

How can I force the audio infoframes to be sent?
Attached Files
File Type: txt xorg.conf.txt (1.7 KB, 133 views)
88fingerslukee is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.