Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-25-09, 08:50 AM   #1
Heros
Registered User
 
Join Date: Jul 2009
Posts: 4
Default Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-settings

Hi!

When running OpenGL-Apps like "glxexcess" or games like "Nexiuz", "openarena" or "alienarena" my Club3D Geforce 9500 GT (CGNX-HG952YI) spontaneously blanks the whole screen (DVI) for ~ 1 sec.
This happens ~ 5 times per minute, without any correlation to mouse movement, keyboard events, network traffic or displayed scene complexity.
Sometimes noting happens for one or two minutes, sometimes the blanks "add up" to a black screen for several seconds. This happens at random...

This seems(!) to be the same blank which occurs when starting nvidia-settings the first time. With my old GF8600GT this blank occurred too - but never when running OpenGL apps.

The same (duration) blank occurs when switching the "Force Full GPU Scaling" options in nvidia-settings.

Things I tried so far:
* Everything with respect to Powermizer one can find in the web
* Kernel settings like SMP, ACPI, APIC, timers...
* Disabling onboard devices (network)
* the latest beta driver (190.18)
* 180.* drivers
* almost all xorg.conf options
* Fullscreen or windowed... no difference


No luck so far...

OpenGL-Apps without problems: Google Earth, glxgears, glxdemo

Interesting questions:
* What happens when nvidia-settings starts the first time? Why the blank?
* Could my problem be caused by a power supply problem?


Best regards,
Michael
Attached Files
File Type: gz nvidia-bug-report.log.gz (41.2 KB, 166 views)

Last edited by Heros; 07-25-09 at 11:31 AM. Reason: more info
Heros is offline   Reply With Quote
Old 07-26-09, 05:32 AM   #2
Heros
Registered User
 
Join Date: Jul 2009
Posts: 4
Default Re: Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-sett

Hi,

some additional info:

The blank seems not to be a black screen. It's a real loss of signal because my Samsung Syncmaster 206BW hides its OSD when the blank happens.

Some more hardware info:
* Mainboard: ASUS P5K pro
* PSU be quiet! Dark Power PRO 430

Best regards,
Michael
Heros is offline   Reply With Quote
Old 07-26-09, 07:23 AM   #3
Heros
Registered User
 
Join Date: Jul 2009
Posts: 4
Default Re: Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-sett

Hi again...

no luck with 173.** drivers nor reduced blanking settings.

Anyway, I think it can't be a framerate/blanking/TMDS-sycn-loss problem because there's no reason why the framerate should change when OpenGL is displayed in a window.

Very strange...
Heros is offline   Reply With Quote
Old 07-26-09, 12:42 PM   #4
Heros
Registered User
 
Join Date: Jul 2009
Posts: 4
Default Re: Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-sett

Hi!

I just tried the analog VGA output: No blank screen but noticeable flicker on screen when running OpenGL apps - including glxgears.

So *something* happens... but what? Looks like a bad card....
Heros is offline   Reply With Quote
Old 08-09-09, 05:44 PM   #5
jmfernandez
Registered User
 
Join Date: Jul 2008
Posts: 8
Default Re: Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-sett

I noticed the same symptoms (flickering, and once a random blank) with the analog output. In my case I'm using a Toshiba Tecra M5 laptop with a NVS 110M chip.
jmfernandez is offline   Reply With Quote
Old 04-17-10, 02:22 PM   #6
superRamrod
Registered User
 
Join Date: Apr 2010
Posts: 1
Default Re: Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-sett

hi!

after alot of searching i found out that i have the same problem.

my 9500GT works via DVI nicely with an old phillips lcd monitor, but on my samsung 226bw i get random black screens while playing openGL games. i also tried win7 and got the same problems. the only workaround is connecting via VGA.

is there any chance to get this working, or is this some weird hardware incompatibility?

i attached my nvidia-bug-report.log
Attached Files
File Type: gz nvidia-bug-report.log.gz (32.3 KB, 122 views)
superRamrod is offline   Reply With Quote
Old 04-17-10, 02:45 PM   #7
Albibek
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-sett

Got the same problem on my 9600GT.
Also tried many settings like scaling, disabling EDID and second DVI scanning without any success.
UPD: Made a small video showing the issue: http://www.youtube.com/watch?v=qLN9dnzWI2U
Attached Files
File Type: gz nvidia-bug-report.log.gz (52.0 KB, 127 views)
Albibek is offline   Reply With Quote
Old 07-28-10, 01:44 AM   #8
Albibek
Registered User
 
Join Date: Nov 2006
Posts: 2
Default Re: Screen flicker (blank, black) with GeForce 9500GT with OpenGL Apps or nvidia-sett

Well, it was bearable some time, while playing WoW, but not when watching Starcraft2 cinematics.
It started happening very often on them or when you see the interface between missions(where they used the engine similar to cinematics). Very annoying .

When you play the mission itself or a network game, the flickering is usual - it happens one time in a few minues or even a few tens of minutes.

Is there a way to track this issue - turn on some debug info in wine or driver or maybe mesa? Currently there is still nothing in dmesg, Xorg.0.log or ~/.xsession_errors.
Albibek is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.