Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-12-10, 10:13 AM   #1
SamSamSam
Registered User
 
Join Date: May 2010
Posts: 7
Default application crashes starting with Nvidia driver > 180

Hi all,

Our application (including an OpenGL 3D viewer) shows graphical errors and seg faults since we are using Nvidia graphic drivers 180 and higher.

The 180s produced graphical errors (weird lines through the 3D viewer) on various geometries paired with crashes when interacting with the GUI.
Since 195.36.15 (maybe even one release earlier) the graphical error could not be reproduced any longer but the crashes persist.

We have been using 173.14.09 for quite a long time and did not have any problem with this driver version. Also the updated 173.14.25 seems to work.

One of our test platforms where the problem is reproducible is a 64bit RedHat Enterprise Linux 5.4 machine with a Nvidia Quadro FX1400 installed but the problem also occured on other operating systems (e.g. RHEL4.4, OpenSuSE11.2) together with different graphic cards (e.g. FX3800, FX3700).

The strange thing is that the problems are not reproducible when starting the application through a debugger and also the stacktrace extracted from a core file does look strange:

#0 0x0000003c4ec732c1 in _int_malloc () from /lib64/libc.so.6
#1 0x0000003c4ec74bee in malloc () from /lib64/libc.so.6
#2 0x0000003004849b11 in ?? () from /usr/lib64/libGL.so.1
#3 0x0000003002800b3d in _nv000006gl () from /usr/lib64/tls/libnvidia-tls.so.1
#4 0x0000003c554bd17d in operator new () from /usr/lib64/libstdc++.so.6
#5 0x0000003c554bd299 in operator new[] () from /usr/lib64/libstdc++.so.6

#6 0x00000000020e45ae in FC_StdMesh::Mirror ()
#7 0x0000000000e20c00 in FC_PreHandler::FameToolsMirror ()
#8 0x000000000261baeb in FC_Command::doit ()
#9 0x000000000260ac09 in FC_CommandProcessor::do_cmd ()
#10 0x0000000002616ff9 in FC_Interpreter:rimary ()
#11 0x00000000026161e0 in FC_Interpreter::unary_expression ()
#12 0x0000000002617487 in FC_Interpreter::expression ()
#13 0x00000000026126b2 in FC_Interpreter::Command ()
#14 0x000000000261a2c1 in FC_Cmd::cexecute ()
#15 0x0000000002619a3d in FC_Cmd::execute ()
#16 0x00000000026199ce in FC_Cmd::execute ()
#17 0x000000000260ae45 in FC_CommandProcessor::executeCmd ()
#18 0x00000000026105fd in FC_MacroController::Command ()
#19 0x000000000260403b in FC_ThreadCommand::executeDetached ()
#20 0x0000000002650fdb in FC_Thread::run ()
#21 0x0000000002651e24 in FXThread::execute ()
#22 0x0000003c4f806617 in start_thread () from /lib64/libpthread.so.0
#23 0x0000003c4ecd3c2d in clone () from /lib64/libc.so.6
#24 0x0000000000000000 in ?? ()

I have run quite a lot of tests but could not find any reason for the problems yet. Of course also a source code error would be a reasonable explanation for the described behaviour but I do not understand why this does not happen with the older drivers.

Maybe somebody has expirienced similar problems with the mentioned Nvidia drivers or has ideas how to narrow the problem area.

Thanks for your help,
br
Armin
Attached Files
File Type: gz nvidia-bug-report.log.gz (37.6 KB, 97 views)
File Type: log nvidia-installer.log (48.0 KB, 99 views)

Last edited by SamSamSam; 05-19-10 at 09:10 AM.
SamSamSam is offline   Reply With Quote
Old 05-18-10, 06:25 PM   #2
SamSamSam
Registered User
 
Join Date: May 2010
Posts: 7
Default Re: application crashes starting with Nvidia driver > 180

It seems the described problems also depend on the used operating system.
E.g. I was not able to reproduce the problem with recent Ubuntu releases.

Any ideas?

br,
Armin
SamSamSam is offline   Reply With Quote
Old 07-05-10, 06:27 AM   #3
SamSamSam
Registered User
 
Join Date: May 2010
Posts: 7
Exclamation Re: application crashes starting with Nvidia driver > 180

Status update of the described problem:

The problem also occurs on recent operating system versions.
After doing some more tests I realized that I cannot reproduce the problem any longer when using a non Quadro FX card (e.g. 9600GT, GT240) but still using the same graphic driver and the same operating system.
I have also tried this with the latest supported driver version 256.35.
So for me it looks like a problem with some Quadro functionality/feature.

To verify this, is it somehow possible to deactivate the Quadro specific features by a driver setting or by some other method?

Does anybody have an idea what else could be problem based these new facts?
Please let me know if you need any further information.

I highly appreciate any hint/help on this!!!

Thanks,
Armin
SamSamSam is offline   Reply With Quote
Old 07-05-10, 02:59 PM   #4
Vorgus
Registered User
 
Vorgus's Avatar
 
Join Date: Dec 2008
Posts: 107
Default Re: application crashes starting with Nvidia driver > 180

You are using x64? I have 2 computers nearly identical except one is 32bit and the other is running 64bit debian squeeze. I can send video to CRT-1 on the 32 bit fine, but on the 64bit, the nvidia driver causes xorg to segfault. I asked in #xorg on irc and they just say it's an nvidia problem. nvidia won't respond ether to my post here: http://www.nvnews.net/vbulletin/showthread.php?t=152528 or in irc
Vorgus is offline   Reply With Quote
Old 07-07-10, 12:41 AM   #5
SamSamSam
Registered User
 
Join Date: May 2010
Posts: 7
Default Re: application crashes starting with Nvidia driver > 180

Yes I'm running on x64. I have not tested Debian yet but so far I did not have any problems with xorg.
Unfortunately I also did not get any helpful hint until now but still hoping

br,
Armin
SamSamSam is offline   Reply With Quote
Old 07-26-10, 02:51 PM   #6
aritger
NVIDIA Corporation
 
aritger's Avatar
 
Join Date: Oct 2002
Posts: 53
Default Re: application crashes starting with Nvidia driver > 180

Hello, Armin. Can you please provide a test case that reproduces this? Thanks.
__________________
Andy Ritger
NVIDIA Linux Graphics Driver Engineer
aritger is offline   Reply With Quote
Old 07-27-10, 08:59 AM   #7
SamSamSam
Registered User
 
Join Date: May 2010
Posts: 7
Default Re: application crashes starting with Nvidia driver > 180

Hello Andy,

At the time I can only reproduce this problem with our own application.
Of course I can provide you a version of this application (+ license) but this might get a little complicated so I will try to generate a package containing just the essential pieces.

Do you have some area where I can upload all relevant data or shall I provide a download link for you?

br,
Armin
SamSamSam is offline   Reply With Quote
Old 07-27-10, 10:30 AM   #8
aritger
NVIDIA Corporation
 
aritger's Avatar
 
Join Date: Oct 2002
Posts: 53
Default Re: application crashes starting with Nvidia driver > 180

Hi Armin,

You can upload files to the same place people upload video clips for VDPAU testing:

* sftp/scp to partners.ftp.nvidia.com
* ftps to partners.ftp.nvidia.com (port 21 for explicit AUTH TLS, port 990 for implicit FTP over SSL)
* https://partners.ftp.nvidia.com (requires in-browser Java support)

In all cases, user ID is vdpau with no password (i.e. empty/blank). Simply upload files to whatever directory the system places you into. You will be able to upload files, and possibly list files, but not download files.
__________________
Andy Ritger
NVIDIA Linux Graphics Driver Engineer
aritger is offline   Reply With Quote

Old 07-29-10, 06:20 AM   #9
SamSamSam
Registered User
 
Join Date: May 2010
Posts: 7
Default Re: application crashes starting with Nvidia driver > 180

Hi Andy,

I just wanted to inform you that I have uploaded an tar.gz archive (firewm_nvtest.tar.gz) containing the mentioned program together with some test data which should hopefully let you reproduce my problem.

In case of any problems or questions do not hesitate to contact me.

Thanks for your help,
br
Armin
SamSamSam is offline   Reply With Quote
Old 08-12-10, 06:37 AM   #10
SamSamSam
Registered User
 
Join Date: May 2010
Posts: 7
Default Re: application crashes starting with Nvidia driver > 180

Hi Andy,

Did you already have any success?
Please let me know if you need further information or if I can help somehow.

br,
Armin
SamSamSam is offline   Reply With Quote
Old 08-13-10, 03:38 PM   #11
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: application crashes starting with Nvidia driver > 180

Hi Armin,

Thanks for the sample app. We were able to reproduce the crash internally, and are currently investigating it. In the meantime please continue to use the workaround we suggested.
danix is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:58 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.