Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-27-10, 11:24 AM   #1
carlos
In the fetal position
 
carlos's Avatar
 
Join Date: May 2004
Location: Orlando, FL
Posts: 153
Default Error Installing 256.35 (Debian)

I am installing the latest drivers (256.35) on my Debian Testing system and got an error:

Quote:
ERROR: Unable to load the kernel module 'nvidia.ko'. This happens most
frequently when this kernel module was built against the wrong or
improperly configured kernel sources, with a version of gcc that differs
from the one used to build the target kernel, or if a driver such as
rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
obtaining ownership of the NVIDIA graphics device(s), or NVIDIA GPU
installed in this system is not supported by this NVIDIA Linux graphics
driver release.
I have a nVidia GeForce 9600GT card I am trying to load drivers for and never seen this before. I have attached the logs so if anyone knows what is causing this, please let me know.

Thanks!
Attached Files
File Type: log nvidia-installer.log (21.8 KB, 84 views)
__________________
It said install Windows 98 or better so I installed Linux...
Debian Linux
carlos is offline   Reply With Quote
Old 07-27-10, 11:57 AM   #2
zander
NVIDIA Corporation
 
zander's Avatar
 
Join Date: Aug 2002
Posts: 3,740
Default Re: Error Installing 256.35 (Debian)

You need to disable the nouveau driver:

(...)
[ 13.494581] [drm] nouveau 0000:02:00.0: Allocating FIFO number 2
[ 13.498059] [drm] nouveau 0000:02:00.0: nouveau_channel_alloc: initialised FIFO 2
(...)
[80081.353605] [drm] nouveau 0000:02:00.0: nouveau_channel_free: freeing fifo 2
(...)
zander is offline   Reply With Quote
Old 07-27-10, 10:00 PM   #3
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Error Installing 256.35 (Debian)

Disabling the nouveau driver is done by adding to the /etc/modprobe.d/blacklist.conf file:

blacklist nouveau

in a new line. Save the file and reboot then try to install the driver. Make sure you have the appropiate kernel headers installed.

Other than that zander said, make sure you use the same gcc version as the the one that was used to compile the kernel.

The default in Testing is gcc-4.4, you need 4.3 - install gcc-4.3 then remove the /usr/bin/gcc symlink and replace it with one that points to /usr/bin/gcc-4.3:

rm /usr/bin/gcc
ln -s /usr/bin/gcc-4.3 /usr/bin/gcc
gradinaruvasile is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:24 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.