Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-29-10, 09:55 AM   #1
utkanos
Registered User
 
Join Date: Jul 2010
Posts: 2
Default Quadro NVS 450 on Ubuntu 10.04 crashes X / no screens

Hello,

I am attempting to get this card to come up in Ubuntu, however it fails in a most interesting way. When gdm or startx are invoked, it kills all input devices and the screen. I have to basically hard reboot or ssh into it from another host to reboot it as the keyboard is dead.

I have tried the following already:

1) Ubuntu specific drivers, all of them.. all succeed but present same situation as above
2) Disabled/removed nouveau
3) Nvidia specific driver (256) compiles successfully
4) Run nvidia-xconfig as well as try to build my own xorg.conf with a known good profile for said monitor.

I can only get into failsafeX with low res graphics.. attempting to start X in any other way causes a crash.

Included is my bugreport. It basically says that there are screens found but none have a usable configuration, which is interesting since I can use this same X config with other nvidia cards and the same monitor without fail.

I cannot run nvidia-settings because it says I do not have an nvidia driver installed/in use because I'm in failsafe mode. Any suggestions would be helpful.
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.5 KB, 92 views)
utkanos is offline   Reply With Quote
Old 07-30-10, 03:19 PM   #2
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: Quadro NVS 450 on Ubuntu 10.04 crashes X / no screens

The Quadro NVS 450 actually has two GPUs on one board. What's most likely happening is that the X server is probing a GPU that doesn't have any displays connected to it.

Try either of the following:

1) Explicitly set a PCI Bus ID in your X configuration; for example, your X log shows that it's trying the GPU at 4:0:0, while your lspci output shows a GPU at 3:0:0 and another at 4:0:0. You can try adding the following line to /etc/X11/xorg.conf:

Code:
BusID "PCI:3:0:0"'
2) Try other ports on the board.
danix is offline   Reply With Quote
Old 08-02-10, 02:42 PM   #3
utkanos
Registered User
 
Join Date: Jul 2010
Posts: 2
Default Re: Quadro NVS 450 on Ubuntu 10.04 crashes X / no screens

Thanks, danix, good catch. I'll give this a go and let you know.
utkanos is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:46 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.