Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-02-10, 04:26 AM   #1
Melanie78
Registered User
 
Join Date: May 2010
Posts: 12
Default 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Hi all!

I have some troubles with my 3D acceleration of my Nvidia Card GeForce GTS 250.

My system is fedora 12 x86_64 (Kernel 2.6.32.11-99.fc12.x86_64) and I installed the Nvidia driver (driver version 195.36.15) like described in fedoraforum.org via rpmfusion.

After a fresh install of Fedora I installed wine and startet WoW. The game starts but I have massive graphical corruptions (so I cant see a thing on the display) and my screen flickers every few seconds. I also tried to activate Compiz, but my screen is flickering, my mouse is very slow and I canīt move the windows. My 3rd "test" was the game Glaxium, but the game crashed every time i started it.

I installed these nvidia packages:

nvidia-settings-1.0-3.4.fc12.x86_64
akmod-nvidia-195.36.15-1.fc12.x86_64
nvidia-xconfig-1.0-2.fc12.x86_64
xorg-x11-drv-nvidia-libs-195.36.15-1.fc12.i686
kmod-nvidia-2.6.32.11-99.fc12.x86_64-195.36.15-1.fc12.2.x86_64
xorg-x11-drv-nvidia-libs-195.36.15-1.fc12.x86_64

glxinfo | grep rendering says "direct rendering: yes"

[root@Melanie ~]# glxinfo
name of display: :0.0
display: :0 screen: 0
direct rendering: Yes
server glx vendor string: NVIDIA Corporation
server glx version string: 1.4
server glx extensions:

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce GTS 250/PCI/SSE2
OpenGL version string: 3.2.0 NVIDIA 195.36.15
OpenGL shading language version string: 1.50 NVIDIA via Cg compiler

So everything looks fine for me. Nouveau driver is blacklisted in /etc/modprode.d/blacklist.conf and also in /etc/grub.conf with rdblacklist=nouveau.

I know glxgears isnīt a benchmark, but the output is really very bad:

27 frames in 5.8 seconds = 22.000 FPS
132 frames in 5.0 seconds = 26.174 FPS
59 frames in 6.3 seconds = 9.335 FPS
106 frames in 6.2 seconds = 16.969 FPS
45 frames in 5.9 seconds = 7.665 FPS
45 frames in 5.4 seconds = 8.371 FPS
41 frames in 5.0 seconds = 8.120 FPS

Do you have any ideas for me why I have these problems with 3D acceleration.

Thank you for your help.

Melanie
Melanie78 is offline   Reply With Quote
Old 05-03-10, 12:45 AM   #2
Dizzle7677
Registered User
 
Dizzle7677's Avatar
 
Join Date: May 2008
Location: Relativity
Posts: 194
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Quote:
I installed wine and startet WoW
So why are you posting this here.
Try http:/www.winehq.org.
__________________
Elephants can fly but they have no reason to.
------------------------------------------
Phenom II X3 720 @ 3.5Ghz | Asus M4A785-M | 2 Gig Crucial DDR2 @ 960 Mhz | GeForce GT 440 1024 MB | Linux 3.6.1 / Ubuntu 12.04 / W.I.N.E v1.5.14
Dizzle7677 is offline   Reply With Quote
Old 05-03-10, 04:24 AM   #3
Melanie78
Registered User
 
Join Date: May 2010
Posts: 12
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Hi Dizzle7677!

As you can read in my post, I have problems with 3D acceleration also with Compiz and simple linux native games (Glaxium). I am not able to use Compiz because my screen is flickering every few seconds. So this is not a problem of wine.

Melanie
Melanie78 is offline   Reply With Quote
Old 05-03-10, 05:28 AM   #4
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Quote:
Originally Posted by Melanie78 View Post
Hi Dizzle7677!

As you can read in my post, I have problems with 3D acceleration also with Compiz and simple linux native games (Glaxium). I am not able to use Compiz because my screen is flickering every few seconds. So this is not a problem of wine.

Melanie
Generate and attach a nvidia-bug-report.log file, this makes it easier to see what is going on.

(Run nvidia-bug-report.sh as root).
Dragoran is offline   Reply With Quote
Old 05-03-10, 10:03 AM   #5
Melanie78
Registered User
 
Join Date: May 2010
Posts: 12
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Hi Dragoran!

Enclosed please finde the nvidia-bug-report.log file

Thanks for your help.

Best regards,
Melanie
Attached Files
File Type: gz nvidia-bug-report.log.gz (34.9 KB, 80 views)
Melanie78 is offline   Reply With Quote
Old 05-03-10, 10:30 AM   #6
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Quote:
Originally Posted by Melanie78 View Post
Hi Dragoran!

Enclosed please finde the nvidia-bug-report.log file

Thanks for your help.

Best regards,
Melanie
Hmm ... I can't see anything obviously wrong in your log.

Can you try

Code:
yum --enablerepo=rpmfusion-nonfree-updates-testing update kmod-nvidia xorg-x11-drv-nvidia-libs xorg-x11-drv-nvidia-libs.i686
This should pull in the 195.36.24 driver.
Dragoran is offline   Reply With Quote
Old 05-03-10, 11:06 AM   #7
Melanie78
Registered User
 
Join Date: May 2010
Posts: 12
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Hi Dragoran!

I updated the driver.

After reboot the output of glxgears was fine. Then I activated Compiz to test, if 3D acceleration is ok. But Compiz crashed. After reboot I have the same problems as before.

Enclosed please find the new bug-report file.

Melanie
Attached Files
File Type: gz nvidia-bug-report.log.gz (35.7 KB, 81 views)
Melanie78 is offline   Reply With Quote
Old 05-03-10, 11:20 AM   #8
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Code:
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x49ef28]
1: /usr/bin/Xorg (mieqEnqueue+0x1f4) [0x49e8f4]
2: /usr/bin/Xorg (xf86PostMotionEventP+0xce) [0x47944e]
3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f5a66cb4000+0x516f) [0x7f5a66cb916f]
4: /usr/bin/Xorg (0x400000+0x6c337) [0x46c337]
5: /usr/bin/Xorg (0x400000+0x117703) [0x517703]
6: /lib64/libpthread.so.0 (0x3324800000+0xf0f0) [0x332480f0f0]
7: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f5a67533000+0x78140) [0x7f5a675ab140]
8: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f5a67533000+0x7997d) [0x7f5a675ac97d]
9: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f5a67533000+0xd73df) [0x7f5a6760a3df]
10: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f5a67533000+0x34226a) [0x7f5a6787526a]
11: /usr/bin/Xorg (0x400000+0x1554ea) [0x5554ea]
12: /usr/bin/Xorg (0x400000+0x155e28) [0x555e28]
13: /usr/bin/Xorg (miWideLine+0x148) [0x5577c8]
14: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f5a67533000+0x3344bc) [0x7f5a678674bc]
15: /usr/bin/Xorg (miPolySegment+0x42) [0x5509a2]
16: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f5a67533000+0x334b9d) [0x7f5a67867b9d]
17: /usr/bin/Xorg (0x400000+0xd3d1b) [0x4d3d1b]
18: /usr/bin/Xorg (0x400000+0x2ac84) [0x42ac84]
19: /usr/bin/Xorg (0x400000+0x2c93c) [0x42c93c]
20: /usr/bin/Xorg (0x400000+0x21f1a) [0x421f1a]
21: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x332441eb1d]
22: /usr/bin/Xorg (0x400000+0x21ad9) [0x421ad9]
So compiz did not crash but X, can you reproduce that?
I.e does starting compiz always cause X to crash for you?

Does disabling compiz fix your other problems?
Dragoran is offline   Reply With Quote

Old 05-03-10, 11:26 AM   #9
Melanie78
Registered User
 
Join Date: May 2010
Posts: 12
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

No, I think I canīt reproduce this. When I active Compiz now my screen is flickering and after a few seconds I get the message if I would like to stay with this setting, or if I would like to go back to standard setting.

Unfortunately my problems persist, even with deactivated compiz.

Thanks a lot for your help.
Melanie78 is offline   Reply With Quote
Old 05-04-10, 05:56 PM   #10
kgow
Registered User
 
Join Date: Jul 2006
Posts: 3
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Have you tried disabling the composite extension in your xorg.conf?

I remember disabling composite explicitly when I started using VDPAU.

I don't use Compiz or wine, but am running Fedora 12 x86_64 with manually installed 195.36.24 driver and all seems fine.
kgow is offline   Reply With Quote
Old 05-08-10, 03:47 PM   #11
Melanie78
Registered User
 
Join Date: May 2010
Posts: 12
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Hi kgow!

Thanks for your help. I disabled the composite extension, but with no luck. Still the same problems.

In the meantime I made a fresh install of Fedora 12. I only installed Opera and the nvidia drivers with rpmfusion.

I really have no idea, why I have these problems.

Melanie
Melanie78 is offline   Reply With Quote
Old 05-08-10, 04:22 PM   #12
Dragoran
Registered User
 
Join Date: May 2004
Posts: 711
Default Re: 3D acceleration problems with GTS 250 on Fedora 12 x86_64

Quote:
Originally Posted by Melanie78 View Post
I really have no idea, why I have these problems.
Well there is nothing that looks obviously wrong a few things you can try:

1. Pass iommu=soft to the kernel (should be fine on AMD systems though).
2. Try
Code:
echo >> options nvidia NVreg_EnableMSI=1 > /etc/modprobe.d/nvidia.conf
(and reboot)
3. Try disabling cool n quite in the BIOS.
Dragoran is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 07:21 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright Đ1998 - 2014, nV News.