Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-08-10, 08:33 PM   #1
konst
Registered User
 
Join Date: May 2006
Posts: 57
Default How to fix 2D slowness in KDE 4.x

The following seems to have fix many problems of slow 2D in KDE 4.x ( at lest without opengl enabled, I don't use Nvidia's opengl in their driver):

This was suggested by mick232 in this post http://www.nvnews.net/vbulletin/show...2&postcount=22

Type in a console "nvidia-settings -a PixmapCache=1"
That controls whether pixmaps are allocated in a cache.

Then type in a console "nvidia-settings -a PixmapCacheRoundSizeKB=(some size in KB for how large you want the pixmap cache to be, e.g. 16000)"
That controls the number of kilobytes to add to the pixmap cache when there is not enough room.


Also mick232 suggests:
Quote:
I also have a cron-job in place that flushes the pixmap cache every 20 minutes (by turningit off and on again):

nvidia-settings -a PixmapCache=0
nvidia-settings -a PixmapCache=1

It seems the cache got fragmented or thrashed after a while which might have caused the sluggishness.

If you want to get a list of all your card settings type the following ion a console:

nvidia-settings -e all
konst is offline   Reply With Quote
Old 08-09-10, 08:40 AM   #2
mick232
Registered User
 
Join Date: Oct 2008
Posts: 21
Default Re: How to fix 2D slowness in KDE 4.x

I should have stated that this fixed my 2D problems in KDE4 with Desktop Effects OFF, but you clarified this. The fix works with drivers 195.36 and 256.35 (possibly others as well).
mick232 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:00 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.