Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 05-12-10, 03:32 PM   #1
kwvtk
Registered User
 
Join Date: Oct 2008
Posts: 17
Default Ubuntu 10.04: 195.36.15 does not work with BuGLe

Hello,

I'm using BuGLe to debug OpenGL programs under Linux:
http://www.opengl.org/sdk/tools/BuGLe/

So far it was working great with Ubuntu 9.10 (coming with nVidia driver 185.18.36). After an upgrade to Ubuntu 10.04 (coming with nVidia driver 195.36.15), I have the following wrong behavior:

When the OpenGL calls are intercepted by BuGLe, the driver runs in indirect rendering mode and falls back to OpenGL 1.4. With Ubuntu 9.10, the driver used to properly run in direct rendering mode with OpenGL 3.0.

$ gldb-gui glxinfo &> output.txt

direct rendering: No (If you want to find out why, try setting
LIBGL_DEBUG=verbose)
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro FX 3600M/PCI/SSE2
OpenGL version string: 1.4 (2.1.2 NVIDIA 195.36.15)

[the complete output is in the attached file output_gbdb-gui_20100508_glxinfo.txt]

In addition there is a symbol resolution issue:
glxinfo: symbol lookup error: /usr/lib/libdirac_encoder.so.0:
undefined symbol: _ZdaPv, version GLIBCXX_3.4

c++filt _ZdaPv gives:
operator delete[](void*)

Not using gldb-gui, I get what I expect from glxinfo:
$ glxinfo

direct rendering: Yes
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro FX 3600M/PCI/SSE2
OpenGL version string: 3.2.0 NVIDIA 195.36.15
OpenGL shading language version string: 1.50 NVIDIA via Cg compiler

[the complete output is in the attached file output_glxinfo.txt]

At this point, I don't know if this is a bug in the nVidia driver or in BuGLe. I would appreciate any advise to solve this issue (I sent a similar message to the BuGLe user mailing list).

It was working with BuGLe 20091026 under Ubuntu 9.10. It does not work with BuGLe 20091026 or the new release 20100508.

Regards,

PS: here are the straightforward steps I use to install BuGLe:
$ export CFLAGS=-U_FORTIFY_SOURCE (required under Ubuntu)
$ tar xjvf bugle-0.0.20100508.tar.bz2
$ mkdir bugle-build
$ cd bugle-build
$ ../bugle-0.0.20100508/configure
$ make -j3
$ make install

--
François Bertel, PhD | Kitware Inc. Suite 204
1 (518) 371 3971 x113 | 28 Corporate Drive
| Clifton Park NY 12065, USA
Attached Files
File Type: gz nvidia-bug-report.log.gz (44.3 KB, 50 views)
File Type: txt output_gbdb-gui_20100508_glxinfo.txt (40.1 KB, 70 views)
File Type: txt glxinfo_output.txt (44.6 KB, 64 views)
kwvtk is offline   Reply With Quote
Old 05-13-10, 10:45 AM   #2
kwvtk
Registered User
 
Join Date: Oct 2008
Posts: 17
Default Re: Ubuntu 10.04: 195.36.15 does not work with BuGLe

For reference, here is the message I sent to the BuGLe users list:
http://sourceforge.net/mailarchive/f...me=bugle-users
kwvtk is offline   Reply With Quote
Old 05-19-10, 05:32 PM   #3
danix
NVIDIA Corporation
 
danix's Avatar
 
Join Date: Feb 2010
Location: Santa Clara, CA
Posts: 237
Default Re: Ubuntu 10.04: 195.36.15 does not work with BuGLe

Hi François,

It seems this is a problem with distribution repackaging of the driver. I tried versions 195.36.15 and 195.36.24 on Ubuntu 10.04, and glxinfo run through BuGLe reported direct rendering capability. This was with drivers installed through NVIDIA's installer, as available on the website at http://www.nvidia.com/object/unix.html

When I uninstalled the driver and reinstalled the Ubuntu packaged version, I saw the same problem that you did: glxinfo run through BuGLe reported indirect rendering.

The Ubuntu packaged version has many files relocated; it's possible this is causing BuGLe to be unable to use direct rendering.
danix is offline   Reply With Quote
Old 05-21-10, 12:06 PM   #4
kwvtk
Registered User
 
Join Date: Oct 2008
Posts: 17
Default Re: Ubuntu 10.04: 195.36.15 does not work with BuGLe

Thanks a lot! I'm gonna make the developers of BuGLe and the Ubuntu packagers aware of that.
kwvtk is offline   Reply With Quote
Old 05-21-10, 01:03 PM   #5
kwvtk
Registered User
 
Join Date: Oct 2008
Posts: 17
Default Re: Ubuntu 10.04: 195.36.15 does not work with BuGLe

For reference, I filed a bug report (583932) to Ubuntu:
https://bugs.launchpad.net/ubuntu/+s...rs/+bug/583932
kwvtk is offline   Reply With Quote
Old 08-07-10, 04:46 PM   #6
kwvtk
Registered User
 
Join Date: Oct 2008
Posts: 17
Default Re: Ubuntu 10.04: 195.36.15 does not work with BuGLe

The issue was in bugle. And it is fixed in revision 0.0.20100718.

For reference, here is the message on the bugle mailing list with the proof that it is fixed:
http://sourceforge.net/mailarchive/m...mail.gmail.com
kwvtk is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:23 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.