Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-15-10, 07:37 PM   #13
dura91
Registered User
 
Join Date: Aug 2009
Location: Near Paris France
Posts: 40
Default Re: VDPAU hangs/freezes even with 256.52

Quote:
Originally Posted by Lysius View Post
Still seems to be present in 260.19.06
I confirm this with a GT240. No problem with 195.36.24.
dura91 is offline   Reply With Quote
Old 10-16-10, 02:15 PM   #14
terau
Registered User
 
Join Date: Aug 2010
Posts: 19
Default Re: VDPAU hangs/freezes even with 256.52

Problem still there after the new stable 260s.

What is going on with this bug? Whatever driver I have tried, vdpau always creates hangs/freezes. I have never seen my GTX460 with non-freezing vdpau.

People with GTX470 and GTX480 say that 195.36.24 was the last version without this problem (>=195.36.31 has the problem). But 195.36.24 doesn't work with the gtx460 (Unrecognized Hardware, 2d/3d somewhat works, but vdpau library can't even initialize with mplayer).

Why is this taking so long?
terau is offline   Reply With Quote
Old 10-18-10, 02:45 PM   #15
marsark
Registered User
 
Join Date: Sep 2010
Posts: 10
Default Re: VDPAU hangs/freezes even with 256.52

VDPAU problem crashes with 260.19.12 driver. I am able to play videos via VDPAU only when composite desktop is disabled.
marsark is offline   Reply With Quote
Old 10-18-10, 08:29 PM   #16
one_and_only
Registered User
 
Join Date: Mar 2007
Posts: 47
Default Re: VDPAU hangs/freezes even with 256.52

Got the same issue, but only with TwinView.
Config: Gentoo 64, 2.6.35-zen3+, xorg-server-1.9.0.902, nvidia-drivers-260.19.12.

With TwinView, everytime I turn off full screen (mplayer - pressing 'f' button) screen is black for few more seconds, pressing f multiple times make mplayer (or sometimes system) hang. Other scenario which causes problems is to use volume up/down keys on my keyboard, which make KDE osd sound level status appear (composite and efects enabled) and sometimes hang the mplayer or crash X in some strange way - I may use the system, but whole screen has little moving dots (screenshot: http://yfrog.com/2h20101019022306j)
one_and_only is offline   Reply With Quote
Old 10-18-10, 08:30 PM   #17
one_and_only
Registered User
 
Join Date: Mar 2007
Posts: 47
Default Re: VDPAU hangs/freezes even with 256.52

Second scenario is hard to reproduce, but I got that error couple of times. Even restarting xorg and re-instering nvidia module don't help - the only way solution is restart. I found something strange in dmesg:
Code:
Oct 19 02:18:27 localhost kernel: [26809.079435] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00000fd4 00000000 00000040
Oct 19 02:18:36 localhost kernel: [26818.048562] NVRM: Xid (0001:00): 13, 0003 00000000 00008297 00001520 00000000 00000040
one_and_only is offline   Reply With Quote
Old 10-23-10, 12:15 PM   #18
philipl
Registered User
 
Join Date: May 2003
Location: Sunnyvale, CA
Posts: 116
Default Re: VDPAU hangs/freezes even with 256.52

I'm running a GTX460 these days and I'm seeing the periodic X freeze problem as originally reported. It's not 100% reproducible but generally, it is proportional to the complexity of the video being decoded - I've also noted that it doesn't matter if compositing is being used or not.

I do not need any extra stuff in dmesg - just the really long pauses - and I believe that CPU utilization is spiking during the pauses based on my CPU fan spinning up.

I'm attaching my nvidia-bug-report.

Running ubuntu 10.10 with 260.19.12
Attached Files
File Type: gz nvidia-bug-report.log.gz (82.0 KB, 74 views)
__________________
--phil
philipl is offline   Reply With Quote
Old 10-23-10, 06:38 PM   #19
spitfire
Registered User
 
Join Date: Sep 2005
Posts: 8
Default Re: VDPAU hangs/freezes even with 256.52

I'll add in my report for whatever it's worth. Running a GTX 460. Very bad hangs with vdpau in both mplayer and mythtv. In addition, I see checkerboard patterns from time to time. Most consistently with MythTV in CPU++ renderering, but also when scrolling in Firefox at times. Checkerboard pattern could possibly be related to the fact that I'm running a development version of xorg-server. As always, thanks for your fine work NVidia devs!

Zotac GTX 460
Nvidia Drivers 260.19.12
Xorg-server-1.9.0.902
Gentoo
Attached Files
File Type: gz nvidia-bug-report.log.gz (36.6 KB, 79 views)
spitfire is offline   Reply With Quote
Old 10-25-10, 06:59 AM   #20
kokoko3k
Registered User
 
Join Date: Jan 2007
Posts: 120
Default Re: VDPAU hangs/freezes even with 256.52

I have noticed something similar on 720p movies too (mouse keep moving, but xorg is totally freezed) on an asrock ion 330 motherboard using vdpau and mplayer under compiz.
The issue happens in window mode as well in gui (xt7-player, smplayer and similar)

nvidia driver version is 260.19.12
xorg server version 1.9.0
kernel 2.6.35
kokoko3k is offline   Reply With Quote

Old 10-25-10, 08:52 AM   #21
Hilinus
Registered User
 
Join Date: Oct 2010
Posts: 1
Default Re: VDPAU hangs/freezes even with 256.52

I have a similar problem with mplayer and VDPAU: when I play a video, mplayer memory usage quickly increases up to 800mb - 1gb of used RAM. At this point the video stutters and subs, if any, become unreadable This does not occour if I don't use VDPAU.

PS. Video card is 8800GTS 512MB (G92)
Attached Files
File Type: gz nvidia-bug-report.log.gz (37.8 KB, 78 views)
Hilinus is offline   Reply With Quote
Old 10-25-10, 02:44 PM   #22
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU hangs/freezes even with 256.52

Hilinus,

Your issue is something else. We believe we have fixed this already. The fix isn't yet released, but will be included in a future driver.
Stephen Warren is offline   Reply With Quote
Old 10-25-10, 02:44 PM   #23
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU hangs/freezes even with 256.52

Hilinus,

Your issue is something else. We believe we have fixed this already. The fix isn't yet released, but will be included in a future driver.
Stephen Warren is offline   Reply With Quote
Old 10-25-10, 02:47 PM   #24
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU hangs/freezes even with 256.52

kokoko3k,

Your issue might be something else. Take a look at http://www.nvnews.net/vbulletin/show...=150725&page=6. In particular, if you add "pci=nomsi" to your kernel command line when you reboot, is your issue solved?
Stephen Warren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:28 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.