Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-18-09, 06:32 AM   #1
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default VDPAU Error: DISPLAY PRE-EMPTED

This error seems to be a (the?) major issue to resolve for NZ H264 and mpeg files.

I get it with vdpau / mythtv infrequently on a PCIe 8500GT and 180.60 mythbuntu 9.04 / JYA mythtv 21583 between 30 mins and some hours.

and much much more frequently with a PCI 9400GT / 190.25 / mythbuntu 8.10 / JYA mythtv 21583 (Within a minute of playing an mpeg file)

Where is the problem(s) and how long is it going to take to resolve?

NVIDIA comment would be much appreciated please.
Dragorep is offline   Reply With Quote
Old 09-18-09, 11:12 AM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

Does the display recover after that? I believe the driver can indicate that the display was preempted for pretty much any reason whenever it wants, and the application is supposed to recreate the VDPAU objects. If MythTV simply reports it as an error and exits, then it needs to be fixed.

That said, are the display preemptions accompanied by NVRM Xid messages in the syslog?
AaronP is offline   Reply With Quote
Old 09-18-09, 04:25 PM   #3
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

Does this always happen at the same place in specific video streams? If so, please upload the file to our file drop (see the VDPAU sticky), and provide the other details requested there. Thanks.
Stephen Warren is offline   Reply With Quote
Old 09-18-09, 05:21 PM   #4
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

On the PCI 9400GT / 190.25 / mythbuntu 8.10 / JYA mythtv 21583 machine playing a mpeg the problem hardly ever recurs at the same place(!).

Playing the MPEG in mplayer gives the attached error.txt file.

Makes me wonder if its some tangential issue like a borderline power supply issue (430W) however a driver issue seems more likely to me.

What is a pre-empted error exactly, other than a fatal error that ceases playback (Clarifying for AaronP - in my cases anyway. I agree it does need to be fixed as playback does stop!)?

I'm looking for a smallish mpeg to put up but it seems almost any mpeg does it so not sure the value of putting one up for you in these circumstances?
Attached Files
File Type: txt Error.txt (12.4 KB, 398 views)
File Type: gz nvidia-bug-report.log.PCI.9400GT.gz (27.9 KB, 121 views)
Dragorep is offline   Reply With Quote
Old 09-18-09, 05:40 PM   #5
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

Hopefully the error log attached here from the

"I get it with vdpau / mythtv infrequently on a PCIe 8500GT and 180.60 mythbuntu 9.04 / JYA mythtv 21583 between 30 mins and some hours."

will also help you?

the frontend log is also attached where three instances of pre-emption are recorded along with zillions of errors that may or may not be related....but probably are....
Attached Files
File Type: gz nvidia-bug-report.log.PCIe.8500GT.gz (27.7 KB, 119 views)
File Type: zip 8500GT.H264.mythtv.mythfrontend.zip (27.2 KB, 125 views)
Dragorep is offline   Reply With Quote
Old 09-18-09, 05:42 PM   #6
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

Quote:
Originally Posted by Stephen Warren View Post
Does this always happen at the same place in specific video streams? If so, ...
However in the case of "If not" please Stephen?

I hope the earlier replies assist the "if not" case? If I can assist further?

Last edited by Dragorep; 09-18-09 at 05:43 PM. Reason: Offer to assist also
Dragorep is offline   Reply With Quote
Old 09-18-09, 07:39 PM   #7
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

Quote:
PCI 9400GT / 190.25 / mythbuntu 8.10 / JYA mythtv 21583
NVIDIA log attached on the above kit, debug enabled, and playing 1080i H264 file, this time livetv on Mythtv Frontend, file not saved. Could save a brief file, as it will almost certainly reproduce fault, if wanted.
Attached Files
File Type: gz nvidia-bug-report.log.PCI.9400.mythtv.debug3.set.gz (27.9 KB, 116 views)
Dragorep is offline   Reply With Quote
Old 09-19-09, 12:02 AM   #8
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

There are some XIDs in your logs:

Code:
[  136.779739] NVRM: Xid (0002:00): 6, PE0003 
[  150.690877] NVRM: Xid (0002:00): 6, PE0001 
[  333.730543] NVRM: Xid (0002:00): 13, 0001 00000000 0000502d 000008c4 f7eef822 00000004
[  333.732653] NVRM: Xid (0002:00): 13, 0001 00000000 0000502d 000008c4 f7eef822 00000004
[  430.696771] NVRM: Xid (0002:00): 6, PE0003 
[  432.524399] NVRM: Xid (0002:00): 13, 0001 00000000 00005097 00001414 05ab05d7 0000000c
[  434.488196] NVRM: Xid (0002:00): 13, 0001 00000000 00005097 000015e0 41000000 0000000c
Given the varied nature of the XID messages, and the fact that the problem doesn't reproduce at any particular spot in any particular clip, my first inclination is some kind of general system instability. If you run heavy OpenGL applications, do you see additional XID messages in your logs (dmesg)? OpenGL can recover from some of these errors, so you might not notice simply by watching the application's rendering.

Finally, VDPAU can experience "display preemption" for a variety of reasons, such as the GPU experiencing certain kinds of errors when processing commands (which is what appears to be happening for you), VT-switches, and X mode (resolution etc.) switches, or certain internal inconsistent state in the VDPAU driver or similar errors.
Stephen Warren is offline   Reply With Quote

Old 09-19-09, 06:09 PM   #9
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

Thank you for replying Stephen.
Was that reply for the 9400, the 8500, or indeed for both?
I suggest can we focus for now on the 8500, as that one does not seem to have any question about its "general system instability". (I am not so sure about the 9400 and its box although I know its not the card as its been swapped to achieve same result)
Dragorep is offline   Reply With Quote
Old 09-19-09, 08:10 PM   #10
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

I added support for recovering from display preemption to MPlayer (along with other VDPAU-related improvements, and I intend to add some more later). If you can test how the recovery works on a machine where display preemption occurs "by itself" I'd be interested to hear the results. You can get the version with preemption-recovery support with
git clone git://repo.or.cz/mplayer-build.git
uau is offline   Reply With Quote
Old 09-19-09, 08:16 PM   #11
Dragorep
Registered User
 
Join Date: Apr 2009
Posts: 98
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

Hey Kewl
The 9400 generally does it within a minute including using mplayer on its own, so sounds good to test your code with. Can you give me some link or direction on installing using git?
Dragorep is offline   Reply With Quote
Old 09-19-09, 08:38 PM   #12
uau
Registered User
 
Join Date: Sep 2009
Posts: 45
Default Re: VDPAU Error: DISPLAY PRE-EMPTED

If you have the git version control tool installed then the command I already gave should work to clone the mplayer-build repo into a directory named mplayer-build. After that follow the instructions given in the README file in that directory.
uau is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:33 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.