Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-09-10, 09:47 AM   #1
dimm0k
Registered User
 
Join Date: Mar 2004
Posts: 5
Default X/KDE hangs, but machine still accessible

I have Lenovo W510 notebook with the Quadro FX 880M GPU under Slackware64 13.1 and the latest 256 drivers. System had been up for a couple of days when it froze last night right after exiting a movie played with mplayer. Nothing was responding, keyboard, mouse, display all resembled that of a frozen/crashed machine. I had my torrent client seeding the Slackware ISOs, so the USB HDD was still actively being used meaning the system was still responsive. I remotely connected to my notebook from another computer and was able to login and kill X, which was utilizing 100% of CPU according to 'top'. While that closed X and brought my notebook's display back on instead of the externally connected monitor via HDMI, the system itself was still unresponsive if I were to attempt to use the notebook directly. I issued the the 'shutdown' command and after booting up the system was fine again. I was able to grab a bit of info from /var/log/ for X and this bit was interesting:

Code:
(II) ThinkPad Extra Buttons: Device reopened after 1 attempts.
(II) AT Translated Set 2 keyboard: Device reopened after 1 attempts.
(II) Integrated Camera: Device reopened after 1 attempts.
(II) USBPS2: Device reopened after 1 attempts.
(II) USBPS2: Device reopened after 1 attempts.
(II) Microsoft Microsoft 5-Button Mouse with IntelliEye(TM): Device reopened after 1 attempts.
(II) Sleep Button: Device reopened after 1 attempts.
(II) Video Bus: Device reopened after 1 attempts.
(II) Power Button: Device reopened after 1 attempts.
(WW) Sep 09 00:01:39 NVIDIA(0): WAIT (2, 6, 0x8000, 0x00009af0, 0x0000b5c8)
(WW) Sep 09 00:01:46 NVIDIA(0): WAIT (1, 6, 0x8000, 0x00009af0, 0x0000b5c8)
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x28) [0x4661c8]
1: /usr/bin/X (mieqEnqueue+0x1f4) [0x45ef24]
2: /usr/bin/X (xf86PostMotionEventP+0xc4) [0x470fc4]
3: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7ff11a53b000+0x523f) [0x7ff11a54023f]
4: /usr/bin/X (0x400000+0x79237) [0x479237]
5: /usr/bin/X (0x400000+0x117033) [0x517033]
6: /lib64/libpthread.so.0 (0x7ff11f89c000+0xf770) [0x7ff11f8ab770]
7: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7ff11afdd000+0x68d5d) [0x7ff11b045d5d]
8: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7ff11afdd000+0x6a5e1) [0x7ff11b0475e1]
9: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7ff11afdd000+0xc5802) [0x7ff11b0a2802]
10: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7ff11afdd000+0xc5c11) [0x7ff11b0a2c11]
11: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7ff11afdd000+0x914c9) [0x7ff11b06e4c9]
12: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7ff11afdd000+0xb7414) [0x7ff11b094414]
13: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7ff11afdd000+0x321557) [0x7ff11b2fe557]
14: /usr/bin/X (0x400000+0xd6fbe) [0x4d6fbe]
15: /usr/bin/X (0x400000+0xcc3de) [0x4cc3de]
16: /usr/bin/X (0x400000+0x338f4) [0x4338f4]
17: /usr/bin/X (0x400000+0x2279c) [0x42279c]
18: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7ff11e6dbb6d]
19: /usr/bin/X (0x400000+0x22359) [0x422359]
Any suggestions?
dimm0k is offline   Reply With Quote
Old 09-09-10, 10:52 AM   #2
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: X/KDE hangs, but machine still accessible

read this first: http://www.nvnews.net/vbulletin/showthread.php?t=46678 and provide the log
Licaon is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 02:03 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.