Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-04-10, 07:55 AM   #1
sveller
Registered User
 
Join Date: Sep 2010
Posts: 4
Default ge force 4 mx integrated gpu, resolution problem

I can't set correct resolution on a ubuntu 10.04 with driver version 96.43.17
I can chose only 320x240 or 640x480.
please help.

edit: no bug report
sveller is offline   Reply With Quote
Old 09-07-10, 07:50 AM   #2
sveller
Registered User
 
Join Date: Sep 2010
Posts: 4
Default Re: ge force 4 mx integrated gpu, resolution problem

someone can help me please? =)
sveller is offline   Reply With Quote
Old 09-07-10, 08:16 AM   #3
Fackamato
User
 
Join Date: Mar 2005
Posts: 366
Default Re: ge force 4 mx integrated gpu, resolution problem

Where is the bug report?

Did you read the README?
Fackamato is offline   Reply With Quote
Old 09-07-10, 09:09 AM   #4
sveller
Registered User
 
Join Date: Sep 2010
Posts: 4
Default Re: ge force 4 mx integrated gpu, resolution problem

sorry..
here it is...
Attached Files
File Type: gz nvidia-bug-report.log.gz (47.5 KB, 67 views)
sveller is offline   Reply With Quote
Old 09-07-10, 02:03 PM   #5
poltsy
Registered User
 
Join Date: Jan 2010
Posts: 26
Default Re: ge force 4 mx integrated gpu, resolution problem

It looks like your xorg.conf forces 640x480 and you're complaining it does just that?
poltsy is offline   Reply With Quote
Old 09-08-10, 04:28 AM   #6
sveller
Registered User
 
Join Date: Sep 2010
Posts: 4
Default Re: ge force 4 mx integrated gpu, resolution problem

my xorg.conf is completely empty...I think that in new version of ubuntu xorg.conf is not necessary to run x server...

now I create a new xorg conf with
Code:
nvidia-xconfig
but I don't know hot to edit it..
Code:
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Thu Apr 15 05:52:31 PDT 2010

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"

    # HorizSync source: builtin, VertRefresh source: builtin
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "CRT-0"
    HorizSync       28.0 - 33.0
    VertRefresh     43.0 - 72.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce4 MX Integrated GPU"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "0"
    Option         "TwinViewXineramaInfoOrder" "CRT-0"
    Option         "metamodes" "640x480 +0+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection
sveller is offline   Reply With Quote
Old 09-08-10, 06:02 AM   #7
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: ge force 4 mx integrated gpu, resolution problem

Quote:
Originally Posted by sveller View Post
but I don't know hot to edit it..
can you remove this line?
Code:
    Option         "metamodes" "640x480 +0+0"
Licaon is offline   Reply With Quote
Old 09-10-10, 08:14 PM   #8
Vic Main
Registered User
 
Join Date: Sep 2010
Location: B.C. eh?
Posts: 3
Default Re: ge force 4 mx integrated gpu, resolution problem

I just had exactly the same problem, and joined the Ubuntu users forum to get help.

With their help, I got my system going correctly.

the first thing was to go and install and activate the driver.

Then..

$ sudo apt-get install nvidia-settings
[it may already be installed, but if not - install it]


$ sudo nvidia-xconfig

then run..

$ sudo gedit /etc/X11/xorg.conf

Check that the vertical sync (refresh) rate and horizontal sync rate settings match your monitor specifications, and edit them accordingly. If you're not sure, make the maximum vertical rate to be 60.

Now reboot

You then can go to the monitor settings using the nvidia interface and refine the various settings there.

This worked for me

Vic
Vic Main is offline   Reply With Quote

Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:53 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.