Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-13-10, 04:44 PM   #1
Surmoka
Registered User
 
Join Date: Jan 2006
Posts: 11
Default Stubborn VBLANK with vdpau (fullscreen?)

Hi,

I can't exactly trace down the cause of what I'm experiencing, but:
* Fedora 9, kernel 2.6.32.2
* NVIDIA driver version: 256.53
* Video card: GeForce 8600 GT
* mplayer SVN-r32049-snapshot-4.3.0 (few days old svn)
* Compiz (but "unredirect fullscreen windows" is enabled)
* monitor refresh rate: 60 Hz

and when playing back any video with VDPAU in fullscreen, nothing can go above my monitor refresh rate. No matter how high of an FPS is specified for mplayer, it is capped at 60 (and I really mean it, the video's time is elapsing at 60 fps only). This makes me think that sync to vblank is enabled. Is there any way to disable it for VDPAU? Sync for vblank is not set, neither for Xv nor for GL.
As I live in Europe, this 60Hz vsync is causing stuttering for my 50Hz TV broadcasts because 60 is not a multiple of 50.

This is only half of the things. If not VDPAU (or not fullscreen), the effect seems similar, except that fps is not capped at 60 but refresh still never seems to happen anywhere mid-screen and stuttering is present with all mplayer video outputs, which means refresh is still synced to vblank, apparently at a more generic level.

Could someone help me out on what vsync setting may still be active and how to disable it?
As this post is not really a bug report or the like, I'm not attaching debug infos - I've scanned through them and they don't seem to provide relevant information for this case.
My Xorg log is here anyway.

Thanks in advance.
Attached Files
File Type: txt Xorg.0.log.txt (19.0 KB, 78 views)
Surmoka is offline   Reply With Quote
Old 09-13-10, 08:15 PM   #2
AaronP
NVIDIA Corporation
 
AaronP's Avatar
 
Join Date: Mar 2005
Posts: 2,487
Default Re: Stubborn VBLANK with vdpau (fullscreen?)

VDPAU's presentation queue will display each frame for at least one vblank. It's up to the application to query the presentation queue, find out when the frame was presented, and compare that to the requested timestamp. If it detects too much drift, it should drop frames to compensate. It sounds like that algorithm is not working in mplayer. As far as I know, there is no way to disable sync-to-vblank in VDPAU.
AaronP is offline   Reply With Quote
Old 09-13-10, 09:24 PM   #3
BitJam
Registered User
 
Join Date: Apr 2006
Posts: 47
Default Re: Stubborn VBLANK with vdpau (fullscreen?)

Quote:
Originally Posted by AaronP View Post
As far as I know, there is no way to disable sync-to-vblank in VDPAU.
I don't seem to have any problem disabling it. :-) I'd like to figure out how to enable it.
BitJam is offline   Reply With Quote
Old 09-14-10, 02:20 AM   #4
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: Stubborn VBLANK with vdpau (fullscreen?)

Try disabling compiz and the composite extension (the latter is done in xorg.conf and requires x restart).
All my vdpau related problems (tearing etc) were gone since i did this (i dont have compiz installed, but i did have tearing until i disabled the composite extension).
This of course means that compiz cannot be enabled.
gradinaruvasile is offline   Reply With Quote
Old 09-14-10, 01:49 PM   #5
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Stubborn VBLANK with vdpau (fullscreen?)

There is no way to disable sync-to-vblank in VDPAU. (This is orthogonal to whether it always works correctly in all cases).
Stephen Warren is offline   Reply With Quote
Old 09-15-10, 08:07 AM   #6
Surmoka
Registered User
 
Join Date: Jan 2006
Posts: 11
Default Re: Stubborn VBLANK with vdpau (fullscreen?)

Thanks for the replies. Would it be technically possible to add for example an environment variable to the driver that controls sync-to-vblank for vdpau?
Surmoka is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:01 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.