Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-14-10, 08:29 PM   #1
Silvano
Registered User
 
Join Date: Nov 2010
Posts: 4
Default X does not start

Hi

Recently I buyed a Sony Vaio F12. I have Kubuntu 10.10 installed and the noveau drivers work well but they have a very bad 3D aceleration.

I have tryed the drivers 256, 260.19.12 and 260.19.21, but when it starts the X it freezes. The log stops without any important warning after:
[ 28.806] (**) NVIDIA(0): Enabling RENDER acceleration
[ 28.806] (**) NVIDIA(0): ConnectedMonitor string: "DFP-0"
[ 28.806] (II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
[ 28.806] (II) NVIDIA(0): enabled.

I have also talked about the installation of ubuntu and its drivers in spanish in my blog.

Thanks.
Attached Files
File Type: gz nvidia-bug-report.log.nouveau.gz (48.6 KB, 75 views)
File Type: gz nvidia-bug-report.log.nvidia.gz (48.6 KB, 77 views)
Silvano is offline   Reply With Quote
Old 11-15-10, 04:48 AM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 713
Default Re: X does not start

You still have NOUVEAU activated in your system, thus NVIDIA driver cannot get access to your hardware.

Code:
(==) Matched nouveau as autoconfigured driver 0
(==) Matched nv as autoconfigured driver 1
(==) Matched vesa as autoconfigured driver 2
(==) Matched fbdev as autoconfigured driver 3

(II) NOUVEAU(0): NVLeaveVT is called.
(II) NOUVEAU(0): Closed GPU channel 3

(II) [drm] nouveau interface version: 0.0.15

Kernel modules: nvidia, nouveau, nvidiafb
Please, remove this driver (removing kernel module will suffice) from your system (don't forget about initrd), otherwise you won't be able to use NVIDIA.
artem is offline   Reply With Quote
Old 11-15-10, 07:51 AM   #3
Silvano
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: X does not start

Hi

Quote:
Originally Posted by artem View Post
You still have NOUVEAU activated in your system, thus NVIDIA driver cannot get access to your hardware.
It is removed and block in a /etc/modprobe.d file, what you are reading is the old log Xorg.0.log.old not the recent Xorg.0.log.
Silvano is offline   Reply With Quote
Old 11-17-10, 05:17 AM   #4
pete4nv
Registered User
 
Join Date: Jul 2003
Posts: 27
Send a message via ICQ to pete4nv Send a message via AIM to pete4nv Send a message via Yahoo to pete4nv
Default Re: X does not start 260.19.12/21 - Sony Vaio F12

I have previously reported the same problem with no NV drivers. When X is started, even before the nvidia logo is displayed, the screen goes black and the system requires a big red switch reset. The last version I can run is 253.53 x86_64.

My graphics controller is the 310M with 512MB ram.

lshw report attached.
working nvidia bug report log attached

$ uname -a
Linux tommyiii 2.6.36-1ph #6 SMP Sun Nov 14 17:44:43 EST 2010 x86_64 Intel(R) Core(TM) i7 CPU Q 740 @ 1.73GHz GenuineIntel GNU/Linux
Attached Files
File Type: gz sonyvaioF12.txt.gz (4.2 KB, 69 views)
File Type: gz nvidia-bug-report.log.gz (37.6 KB, 81 views)
pete4nv is offline   Reply With Quote
Old 11-21-10, 02:00 PM   #5
Silvano
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: X does not start

I add the message file
Attached Files
File Type: txt messages.txt (64.9 KB, 143 views)
Silvano is offline   Reply With Quote
Old 11-23-10, 02:30 AM   #6
YogiBare
Registered User
 
Join Date: Nov 2010
Posts: 6
Default Re: X does not start

Hi,

This is starting to look like a common issue. I am having this same problem with my system
Fedora 13 running a 2.6.36-1 kernel
330M 1gb
Sony VPCF1190X
Nvidia 260.19.21.

I've posted and asked for help on one other thread here
And one other forum here

Fingers crossed for divine intervention :-D. and of course lots and lots of testing on my part ;-)
YogiBare is offline   Reply With Quote
Old 12-27-10, 07:42 PM   #7
Silvano
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Its fixed!

I have installed the 260.19.26 driver and the problem is fixed.
No problem
Silvano is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.