Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 09-22-10, 10:21 AM   #1
GBar
Registered User
 
Join Date: Sep 2010
Posts: 5
Default QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

Random but frequent X freeezes happen related to PowerMizer adaptive performance level switch.
Workaround is to manually set maximum performance via nvidia-settings for the current session or modify xorg.conf to force performance level.

Card is an FX3800M with 256.53 drivers on a Dell M6500 Precision with Gentoo 2.6.35.4 kernel, but this is happening also on Lucid (Ubuntu 10.04 LTS) so it appears a nVidia driver problem.

No specific graphic settings (WM, Compiz) influence the issue.
Attached Files
File Type: gz nvidia-bug-report.log.gz (53.0 KB, 91 views)
GBar is offline   Reply With Quote
Old 09-23-10, 10:58 AM   #2
GBar
Registered User
 
Join Date: Sep 2010
Posts: 5
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

Am I the only one suffering this problem ? Or does anybody have any suggestion I could try out ?

Thanks
GBar is offline   Reply With Quote
Old 09-24-10, 03:13 AM   #3
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

Quote:
Originally Posted by GBar View Post
Am I the only one suffering this problem ? Or does anybody have any suggestion I could try out ?

Thanks
260.19.06 too?
Licaon is offline   Reply With Quote
Old 09-24-10, 04:09 AM   #4
GBar
Registered User
 
Join Date: Sep 2010
Posts: 5
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

with 260.19.06 I experienced frequent X locks too; that's why I downgraded to 256.53.....with 260.19.06 I did not try the workaround of forcing the highest (or lowest) level of Powermizer via xorg.conf. I'll give it a try.....
GBar is offline   Reply With Quote
Old 09-24-10, 05:01 AM   #5
MeisterP
Registered User
 
Join Date: Jun 2010
Posts: 6
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

Quote:
Originally Posted by GBar View Post
Am I the only one suffering this problem ?
I have the same problem after updating from Fedora 13 to Fedora 14. Maybe it's related to the xorg-server update from 1.8.0 to 1.9.0.
My card is an FX880M with 256.53 drivers on a HP EliteBook 8540w.
Attached Files
File Type: gz nvidia-bug-report.log.gz (48.1 KB, 73 views)
MeisterP is offline   Reply With Quote
Old 09-25-10, 06:07 PM   #6
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

Quote:
Originally Posted by MeisterP View Post
Maybe it's related to the xorg-server update from 1.8.0 to 1.9.0.
the 1.9.0 support is too young
Licaon is offline   Reply With Quote
Old 09-29-10, 04:33 PM   #7
GBar
Registered User
 
Join Date: Sep 2010
Posts: 5
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

Well, here is the complete story:
random X locks happening (PowerMizer in adaptive mode) with:
- xorg 1.8.2 and 256.53
- xorg 1.9.0 and 256.53
- xorg 1.8.2 and 260.19.04
- xorg 1.9.0 and 260.19.04
Had a good time with xorg 1.9.0 and 260.19.06 (many days of work in adaptive mode with no locks)
Locks are back again (two today) after upgrade to xorg 1.9.0-r2.

Forcing maximal performance solves problem under all scenarios.

Downgrading now to 1.8.2 with 260.19.06. I'll report results.
GBar is offline   Reply With Quote
Old 12-31-10, 09:01 AM   #8
Chris M
Registered User
 
Join Date: Dec 2010
Posts: 16
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

This sounds like a solution to my prolbem:

DELL Precision M6500 with a nVidia Quadro FX 2800M that regularily hangs under Kubuntu 10.10 (cf. https://bugs.launchpad.net/nvidia-dr...tu/+bug/694611):
  • First driver version was: 260.19.06 (I guess. The splash screen also showed "Beta Driver" although it's the normal 10.10 driver)
  • Then it was: 173.14.28-0ubuntu1 (no locks during the few days I tested it! System was a bit slow though)
  • Now I'm using "nvidia-current" in version 260.19.29-0ubuntu1~xup~maverick3
Now I'll change the power setting and watch for a change.
Chris M is offline   Reply With Quote

Old 01-06-11, 09:35 AM   #9
giangiva
Registered User
 
Join Date: Jan 2011
Posts: 1
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

I have the same problem. Almost.
I'm using Ubuntu 10.10 64bit with the nvidia driver 260.19.06-0ubuntu1 on a Dell Precision M6400 with a Quadro FX 2700M.
If I don't set any specific powermizer option it defaults to adaptive mode.
In adaptive mode, as soon as the gpu clock goes to the minimum level, random green spots appear on the screen.
After a while, things get worse until X hangs completely.
In this situation, I noticed that the audio card has problems too (even if I don't understand the relationship).
If I set the powermizer to maximum performance, then I have no problems (beside the higher battery consumption).
giangiva is offline   Reply With Quote
Old 01-09-11, 06:20 AM   #10
Chris M
Registered User
 
Join Date: Dec 2010
Posts: 16
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

Quote:
Originally Posted by Chris M View Post
Now I'll change the power setting and watch for a change.
Setting the powermizer in the "NVIDIA X Server settings" tool to maximum power seemed to be better but it still crashed sometimes - as I guess it didn't store thst setting (or it was reseting it when I started that tool again to check it...)

So I did it the hard way and changed my xorg.conf to allways use the least power. This was even more stable - but the system was quite slow and it once locked up (I guess it was too slow so it got into a deadlock).
Using the second slowest option it is now working fine all the time. I.e. my xorg.conf looks now like:
Code:
Section "Device"                                                                                                                                                                        
[...]
        Option  "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x2; PowerMizerDefault=0x2; PowerMizerDefaultAC=0x2"
EndSection
So now I've got the biggest problem solved (the unstable system) - but one issue remains:
I've bought the full power from nVidia - and that isn't working.

What's the best way to go on from here? Wait till a nVidia developer finds this thread? Or should I write a mail @nvidia?
Chris M is offline   Reply With Quote
Old 01-17-11, 02:53 PM   #11
GBar
Registered User
 
Join Date: Sep 2010
Posts: 5
Default Re: QuadroFX3800M with 256.53 - PowerMizer adaptive switches cause X locks

To solve the problem I need to set the PowerMizer to the highest performance level. This is done either every time you start X by changing the default Adaptive mode to "Prefer Maximum Performance" or by changing you Xorg.conf.

To have the default maximum performance level this is how my Device section looks like:

Section "Device"
Option "Coolbits" "1"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerLevel=0x1; PowerMizerDefault=0x1; PowerMizerDefaultAC=0x1"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "Quadro FX 3800M"
Option "NoLogo" "True"
EndSection

More battery consumption and probably shorter card life is the price to pay.
Without this workaround I am still having frequent locks with kernel 2.6.37, Xorg-server 1.8.2 and 260.19.29
GBar is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:05 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.