Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 07-15-11, 03:05 AM   #73
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: vdpau slowness with 260.19.06

yes 256 should be ok if I remember correctly but I doubt it will work if you've a recent ubuntu due to kernel/x.org issues.
weltall is offline   Reply With Quote
Old 08-24-11, 03:03 AM   #74
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: vdpau slowness with 260.19.06

and we got to 285.03 and nothing changed.
Quote:
qvdpautest 0.5.1
Intel(R) Core(TM)2 Duo CPU T7300 @ 2.00GHz
NVIDIA GPU GeForce 8600M GT (G84) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 285.03 Mon Aug 15 02:56:09 PDT 2011

SURFACE GET BITS: 741.824 M/s
SURFACE PUT BITS: 706.377 M/s

MPEG DECODING (1920x1080): 34 frames/s
MPEG DECODING (1280x720): 72 frames/s
H264 DECODING (1920x1080): 15 frames/s
H264 DECODING (1280x720): 33 frames/s
VC1 DECODING (1440x1080): 41 frames/s

MIXER WEAVE (1920x1080): 518 frames/s
MIXER BOB (1920x1080): 874 fields/s
MIXER TEMPORAL (1920x1080): 201 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 133 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 272 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 69 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 57 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 77 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 266 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 38 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 171 fields/s
Attached Files
File Type: gz nvidia-bug-report.log.gz (66.3 KB, 65 views)
weltall is offline   Reply With Quote
Old 09-04-11, 11:53 AM   #75
ggar
Registered User
 
Join Date: Aug 2011
Posts: 1
Default Re: vdpau slowness with 260.19.06

Hi all,

First message here.

Long time without any news from the nv team.
Same problem as Weltall here with a Sony AR61M laptop, one GeForce 8400M GT, Ubuntu 10.10 Maverick Meerkat (AMD64) and the 260.19.06 driver.
Like per the others, the only way to recover a fonctional VDPAU is to downgrade to the 256.53 driver.
Any news of a fix?
Best regards,
ggar
ggar is offline   Reply With Quote
Old 09-19-11, 07:28 AM   #76
ezteban
Registered User
 
Join Date: May 2005
Posts: 7
Default Re: vdpau slowness with 260.19.06

Hello,

I have the same Problem with my Zotac 9800 GT Eco.

I had to downgrade Xorg and patch the 256.53 driver to get it working in Ubuntu Natty.
But now i have Problems with slow font rendering.

Is there a new driver that fixes the vdpau problem in sight?
ezteban is offline   Reply With Quote
Old 09-19-11, 07:54 AM   #77
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: vdpau slowness with 260.19.06

as of the latest beta driver no changes. Seems this problem is being ignored.
weltall is offline   Reply With Quote
Old 10-04-11, 02:20 AM   #78
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: vdpau slowness with 260.19.06

285.05.09
I think it's superfluous adding my comments on the changes here...
Code:
qvdpautest 0.5.1
Intel(R) Core(TM)2 Duo CPU     T7300  @ 2.00GHz
NVIDIA GPU GeForce 8600M GT (G84) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  285.05.09  Fri Sep 23 17:55:14 PDT 2011

SURFACE GET BITS: 741.38 M/s
SURFACE PUT BITS: 666.95 M/s

MPEG DECODING (1920x1080): 34 frames/s
MPEG DECODING (1280x720): 72 frames/s
H264 DECODING (1920x1080): 15 frames/s
H264 DECODING (1280x720): 33 frames/s
VC1 DECODING (1440x1080): 42 frames/s

MIXER WEAVE (1920x1080): 515 frames/s
MIXER BOB (1920x1080): 869 fields/s
MIXER TEMPORAL (1920x1080): 199 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 133 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 271 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 69 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 57 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 77 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 265 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 37 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 170 fields/s
weltall is offline   Reply With Quote
Old 10-04-11, 07:20 AM   #79
ezteban
Registered User
 
Join Date: May 2005
Posts: 7
Default Re: vdpau slowness with 260.19.06

256.53 gives these results:

Code:
qvdpautest 0.5.1
AMD Phenom(tm) II X4 905e Processor
NVIDIA GPU GeForce 9800 GT (G92) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  256.53  Fri Aug 27 21:32:59 PDT 2010

SURFACE GET BITS: 438.135 M/s
SURFACE PUT BITS: 171.239 M/s

MPEG DECODING (1920x1080): 70 frames/s
MPEG DECODING (1280x720): 140 frames/s
H264 DECODING (1920x1080): 45 frames/s
H264 DECODING (1280x720): 97 frames/s
VC1 DECODING (1440x1080): 115 frames/s
Profile unsupported.

MIXER WEAVE (1920x1080): 1192 frames/s
MIXER BOB (1920x1080): 1637 fields/s
MIXER TEMPORAL (1920x1080): 401 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 258 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 664 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 226 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 171 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 245 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 446 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 69 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 314 fields/s
Every driver after 256.53 gives the same slow vdpau results that weltall posted above. So there must be a change in the vdpau part of the 260.x driver that causes the slowness.
Is it possible to release a driver with the vdpau part of 256.53 and everything else from the newest driver?
Or is there a way to make 256.53 driver compatible with the latest Xorg api?
Many thanks in advance.
ezteban is offline   Reply With Quote
Old 10-16-11, 11:00 AM   #80
Blackkitten
Registered User
 
Join Date: Jul 2011
Posts: 6
Default Re: vdpau slowness with 260.19.06

Back here again, guys...

I have one question and one suggestion. Let's begin with the question.
Maybe we're doing something wrong and there isn't any problem with driver itself ? I've tried to search in google about our problem and found nothing exept this thread.

And if we are sure ( of cause it is, but I'm getting paranoic already ) maybe we should pay attention to our problem? Start a new thread and submit a new bug report...
Blackkitten is offline   Reply With Quote

Old 10-16-11, 12:04 PM   #81
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: vdpau slowness with 260.19.06

I don't know but could also be that people don't use much vdpau on this series of hardware anymore. It's starting to get old and machines which use these video cards usually are able to decode most video with the cpu too.
Some times ago I got similar issues also on windows 7 which leads to think the issue lies in the core part which is shared between operating systems, but I'd need to try it again in order to be sure of it.
weltall is offline   Reply With Quote
Old 10-17-11, 03:41 AM   #82
Blackkitten
Registered User
 
Join Date: Jul 2011
Posts: 6
Default Re: vdpau slowness with 260.19.06

The machines are more powerfull, no doubt. But even then vdpau is a nice addition to raw "horsepower" of PC that leaves CPU free for other tasks while watching HD video. And on older systems it's the only comfort way to watch those videos.

For exampe my laptop when using vdpau stays quiet and cool. But when CPU tries do decode videos it's getting loud and hot. And in worst case scenario the video doesn't decode properly. So for me vdpau is the best choice.

To forum officials: This threas is one year old ! Can we have at least some official explanation of the problem described here?
And a fix would be also great.
Blackkitten is offline   Reply With Quote
Old 10-17-11, 04:03 AM   #83
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: vdpau slowness with 260.19.06

yes I know that's why i'm complaining each time. I was just trying to find reasons why it's being ignored.
Anyway really I'd want some answer from nvidia too on this.
weltall is offline   Reply With Quote
Old 10-17-11, 04:09 AM   #84
weltall
Registered User
 
Join Date: Feb 2007
Posts: 115
Default Re: vdpau slowness with 260.19.06

double post and can't find the delete button
weltall is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:34 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.