Go Back   nV News Forums > Hardware Forums > General Hardware

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-02-10, 12:27 PM   #1
Maverick123w
 
Join Date: Nov 2003
Location: Cincinnati, OH
Posts: 1,841
Send a message via AIM to Maverick123w
Default Had a nasty surge

Woke up this morning and the alarm clock was flashing so I figured we had lost power. When I tried to power my system on this morning the machine wouldn't post but threw out a beep code. Code means hardware component failure.

I tried the ram removing video card etc. etc. but nothing is working. I imagine the board or chip is gone.

Anyone know if renter's insurance would cover something like this? I believe I have $10,000 in coverage but I'm not sure if they would cover a surge or not.

Just wondering if any1 else has tried to submit a claim. Thanks, Will
Maverick123w is offline   Reply With Quote
Old 10-02-10, 01:15 PM   #2
bob saget
 
Join Date: Dec 2006
Location: Vancouver, originally Russia
Posts: 23,133
Send a message via MSN to bob saget Send a message via Yahoo to bob saget
Default Re: Had a nasty surge

wow what a pain in the ass. hopefully you get it sorted out.
bob saget is offline   Reply With Quote
Old 10-02-10, 01:25 PM   #3
bob saget
 
Join Date: Dec 2006
Location: Vancouver, originally Russia
Posts: 23,133
Send a message via MSN to bob saget Send a message via Yahoo to bob saget
Default Re: Had a nasty surge

i am guessing you had a surge protector? I am interested if the company that made it would cover anything....
bob saget is offline   Reply With Quote
Old 10-02-10, 03:04 PM   #4
Maverick123w
 
Join Date: Nov 2003
Location: Cincinnati, OH
Posts: 1,841
Send a message via AIM to Maverick123w
Default Re: Had a nasty surge

Quote:
Originally Posted by bob saget View Post
i am guessing you had a surge protector? I am interested if the company that made it would cover anything....
Yeah it was on a surge protector. I doubt they would cover it but who knows.
Maverick123w is offline   Reply With Quote
Old 10-02-10, 04:16 PM   #5
betterdan
Guest
 
Posts: n/a
Default Re: Had a nasty surge

My insurance through Nationwide paid for the computer when we had a power outage and it ruined the power supply. It was caused by the tree falling outside and hitting the power lines. It's worth a shot to call them and find out. You will of course have to pay any deductible.
  Reply With Quote
Old 10-04-10, 01:02 PM   #6
Maverick123w
 
Join Date: Nov 2003
Location: Cincinnati, OH
Posts: 1,841
Send a message via AIM to Maverick123w
Default Re: Had a nasty surge

Called the insurance company. My deductible is $250. I'm going to try a new power supply first and see if that fixes the problem (this thermaltake is no-where as good as I thought it would be) and if it happens to be more than that I'll just submit a claim and build a whole new system.

I got the system to post without my video card in the machine but it was still acting all kinds of crazy. Installed my video card in a friend's machine and it booted up just fine and ran kombuster for an hour with no issues, so I think my power supply is the culprit here. I wanted to replace it with a unit that had better line noise to begin with so now is a better time than ever.

I was originally going to go with a Corsair non-modular unit as money is a little tight, but I think I'm going to go with the XFX 850Watt black edition psu. The color scheme has always made me overlook it but I read some reviews on johnny guru and hardware secrets and holy crap it's amazing.

My supplier at work has it for $115 and at that price is an unbeatable deal.

Besides the color scheme (which is so ugly) anyone have any personal experiences with this unit that would give me a reason not to buy it?

http://www.newegg.com/Product/Produc...&Tpk=xfx%20850
Maverick123w is offline   Reply With Quote
Old 10-06-10, 12:01 PM   #7
Maverick123w
 
Join Date: Nov 2003
Location: Cincinnati, OH
Posts: 1,841
Send a message via AIM to Maverick123w
Default Re: Had a nasty surge

Power supply came in today. This thing is HEAVY. I'm going to stay late in the shop and install it in my machine. Hopefully I'm back up and running tonight.
Maverick123w is offline   Reply With Quote
Old 10-06-10, 01:08 PM   #8
Yaboze
Registered User
 
Join Date: Oct 2005
Location: United States
Posts: 2,057
Default Re: Had a nasty surge

I hope that does the trick.

I have all of my systems on APC UPS's.
Yaboze is offline   Reply With Quote

Old 10-06-10, 02:31 PM   #9
Maverick123w
 
Join Date: Nov 2003
Location: Cincinnati, OH
Posts: 1,841
Send a message via AIM to Maverick123w
Default Re: Had a nasty surge

Quote:
Originally Posted by Yaboze View Post
I hope that does the trick.

I have all of my systems on APC UPS's.
I need to do the same thing but I've been incredibly lazy about doing it. Think I may just do it now
Maverick123w is offline   Reply With Quote
Old 10-06-10, 05:29 PM   #10
Maverick123w
 
Join Date: Nov 2003
Location: Cincinnati, OH
Posts: 1,841
Send a message via AIM to Maverick123w
Default Re: Had a nasty surge

New supply works Machine booted right up!
Maverick123w is offline   Reply With Quote
Old 10-07-10, 01:44 AM   #11
Muppet
Registered User
 
Muppet's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 3,130
Default Re: Had a nasty surge

Good to hear. The PSU is the most important part of any PC IMO.
__________________
Asus Rampage IV Extreme Black Edition | Intel 4930k | SS Phasechange | 16GB Corsair Platinum DDR3 1866 | Asus GTX680 x2 SLI | Corsair AX1200 Watt PSU | Lian-Li PC-8NWX | Intel 520 120Gb SSD x2 | Samsung S27A950D 27" 120Hz | HP ZR24w 24" S-IPS x3 Nvidia Surround @6000x1200 | Xonar Essence STX
Muppet is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:07 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.