Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-05-10, 03:09 PM   #1
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Blocking artifacts playing Sintel with mplayer and vdpau

I am experiencing blocking artifacts playing the Sintel movie[1] (MP4 Surround 5.1, Full version) with mplayer and vdpau; software decoding, with or without "-vo vdpau" plays nice.

I attach the log of:

mplayer -vo vdpau -vc ffh264vdpau Sintel.2010.2K.SURROUND.x264-VODO.mp4

with vdpau debug enabled and nvidia-bug-report output.

bye,
rob

PS: i noted that -vf screenshot is incompatible with vdpau

[1] http://www.sintel.org/wp-content/content/download.html
Attached Files
File Type: gz mplayer.log.gz (17.8 KB, 67 views)
File Type: gz nvidia-bug-report.log.gz (68.2 KB, 60 views)
resoli is offline   Reply With Quote
Old 10-05-10, 05:52 PM   #2
sl1pkn07
Registered User
 
Join Date: Nov 2006
Location: Spanishtan
Posts: 103
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

i agree this bug

and the theora version make me gray screen (2K version of sintel)
sl1pkn07 is offline   Reply With Quote
Old 10-05-10, 07:56 PM   #3
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

Works fine here on xbmc and smplayer using the 2048 x 872 MP4 Surround 5.1 with vdpau (no artifacts on any systems). Theora version as well works fine. openSUSE 11.3 x86-64, 260.19.06 and 260.24, GTX-460, GTX-275, 8800GT and 8200 IGP.
Deanjo is offline   Reply With Quote
Old 10-05-10, 09:15 PM   #4
Hansvon
Registered User
 
Join Date: Oct 2010
Posts: 1
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

Horizontal resolution of the "large" file is 2048 and does not work with "VDPAU Feature set B" cards: http://en.wikipedia.org/wiki/Nvidia_...U_Feature_Sets

With my NVidia ION, xbmc automatically switched back to software decoding, which is way too slow for the atom... I had to download the "medium" file, which worked perfectly fine with vdpau.
Hansvon is offline   Reply With Quote
Old 10-06-10, 01:02 AM   #5
resoli
Registered User
 
Join Date: Apr 2009
Posts: 33
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

Quote:
Originally Posted by Hansvon View Post
Horizontal resolution of the "large" file is 2048 and does not work with "VDPAU Feature set B" cards: http://en.wikipedia.org/wiki/Nvidia_...U_Feature_Sets
My nVidia Corporation G86 [GeForce 8400 GS] card (see nvidia-bug-report attached) is feature set A ...

Blocking is definitely visible (mainly in the right part of the frame) but the movie plays without any other problem.

rob
resoli is offline   Reply With Quote
Old 10-06-10, 06:23 AM   #6
sl1pkn07
Registered User
 
Join Date: Nov 2006
Location: Spanishtan
Posts: 103
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

http://sl1pkn07.no-ip.com/imagenes/sintel-x264.png
http://sl1pkn07.no-ip.com/imagenes/sintel-theora.png

9800GT archlinux 64 bits
Attached Files
File Type: gz nvidia-bug-report.log.gz (37.1 KB, 50 views)
File Type: gz mplayer-logs.tar.gz (29.4 KB, 52 views)
sl1pkn07 is offline   Reply With Quote
Old 10-06-10, 12:29 PM   #7
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

Both sintel-2048-surround.mp4 (with and without -vc ffh264vdpau on G210) and sintel-2048-stereo.ogv work fine with latest MPlayer svn (r32444), I can't comment on other versions.

Carl Eugen
cehoyos is offline   Reply With Quote
Old 10-06-10, 05:26 PM   #8
Guilo19
Registered User
 
Join Date: May 2008
Posts: 15
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

Quote:
Blocking is definitely visible (mainly in the right part of the frame) but the movie plays without any other problem.
Exact same here with 8400M but I think it could be related to the very large resolution...
Guilo19 is offline   Reply With Quote

Old 10-07-10, 12:11 AM   #9
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

Quote:
Originally Posted by Hansvon View Post
Horizontal resolution of the "large" file is 2048 and does not work with "VDPAU Feature set B" cards: http://en.wikipedia.org/wiki/Nvidia_...U_Feature_Sets
Something is amiss as the 8200 IGP on my M3N78vm has no issue playing it with zero artifacts. Now it has 512 Meg allocated to it so I wonder if that has anything to do with it.

EDIT: I stand corrected, it seems that XBMC on the 8200 based system just gracefully falls back to standard rendering when encountering a file of that width when a feature set B card is detected.
Deanjo is offline   Reply With Quote
Old 10-08-10, 05:57 PM   #10
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

I have repro'd this issue and filed a bug.
Stephen Warren is offline   Reply With Quote
Old 11-27-11, 11:31 AM   #11
sl1pkn07
Registered User
 
Join Date: Nov 2006
Location: Spanishtan
Posts: 103
Default Re: Blocking artifacts playing Sintel with mplayer and vdpau

Quote:
Originally Posted by Stephen Warren View Post
I have repro'd this issue and filed a bug.
yea, is a necromancy post. but in 290.10 still this issue :S

my graphic card is GTX285 and the player is mplayer2 from git
sl1pkn07 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:33 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.