Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-11-10, 11:23 AM   #1
pauljohn
Registered User
 
Join Date: Jul 2005
Posts: 28
Default ubuntu 10.10 compiz background "fix" is turn up refresh rate

I expect others will see this problem with Ubuntu 10.10

I use compiz as the window manager and wallpaper manager. After a distribution upgrade from Ubuntu 10.04 to 10.10, I had the problem that compiz would no longer draw the wallpaper. I had a black screen, the background would not re-draw at all. Any time I opened a window and closed it, that window's image would remain drawn on the background. If I would drag a window, the small re-draws of the window frame would remain on the screen, like a sequence of "blurs" moving across the screen.

My hardware is old. 4 year old Dell Precision 670 with Nvidia Quadro FX 540

I hacked around quite a while, and eventually found a fix/workaround. In nvidia-settings, I have dual monitors running in Twinview and in the past I have always left the refresh rate set to "auto". Now, with Nvidia 260.19.06, it is necessary for me to manually specify 75mhz.

After that, compiz (suddenly!) starts drawing backgrounds as it is supposed to. I've re-started several times, and found each time that changing refresh from "Auto" to 75 is the magic bullet.
Attached Files
File Type: gz nvidia-bug-report.log.gz (57.9 KB, 86 views)
pauljohn is offline   Reply With Quote
Old 10-11-10, 04:49 PM   #2
pauljohn
Registered User
 
Join Date: Jul 2005
Posts: 28
Default Re: ubuntu 10.10 compiz background "fix" is turn up refresh rate

Sorry to follow own post. I have clarifying information.

First, I learned in the compiz forum that at least one other person had noticed problem, and his workaround was to go to virtual terminal 1 and then back to 7. You know...

Alt-Ctl-F1
Alt-Ctl-F7

That fixes the problem too.

The other thing I've learned from another user. My claim that the fix was to increase refresh is wrong. Instead, it is necessary only to set the refresh rate, to change from Auto to 60 or to 75, and then hit nvidia-settings "apply" button. That causes the backgrounds to draw again.

So Alt-Ctl-F7 causes the X server to kick itself back into shape, same as "apply" in nvidia-settings. I downgraded Nvidia server from version 260 to 256 and had same trouble. I used debs so as to get a quick easy install:

http://ppa.launchpad.net/xorg-edgers...phics-drivers/
pauljohn is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:20 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.