Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-06-03, 10:25 PM   #61
thebeen
Registered User
 
Join Date: Nov 2003
Posts: 15
Default

hey bt, if you figure it out for grub ( I am running RH 9 on grub) plllleeeease let me know. This problem is so stupid and annoying!!! i don't like rebooting my box
thebeen is offline   Reply With Quote
Old 08-17-04, 07:05 PM   #62
dfinn
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: problems escaping from X

Any updates on this?
dfinn is offline   Reply With Quote
Old 08-17-04, 07:23 PM   #63
bms20
Registered User
 
Join Date: Mar 2003
Posts: 46
Default Re: problems escaping from X

I think this is the same problem I'm seeing on the 6800U with 6111 drivers and bios version 05.40.02.15.06 (which incidentally clears up much of the crashing and errant graphics updates). If I try to exit X while in run level 5 the system crashes - hardlocking. This occurs whenever I attempt to exit X through killing the X server.

(Ctrl-Alt-F1, root login -> killall X hardlocks.)

HOWEVER, if I'm in runlevel 3 (where I start X through the startx command) I can safely exit X through the Mandrake logout operation, then shut the computer down using the shutdown command.

Machine: Athlon XP 2700, Epox 8rda+ motherboard, 1gb TwinMos cas2.5 DDR3200
Gfx: POV 6800U, 400/1100MHz, driver v6111 bios 05.40.02.15.06,
OS: Mandrake 10 using kernel 2.6.3-7

-Brett
bms20 is offline   Reply With Quote
Old 08-17-04, 07:39 PM   #64
dfinn
Registered User
 
Join Date: Aug 2004
Posts: 3
Default Re: problems escaping from X

You are better off than me. I cannot shut down X no matter what. When I do it leaves the system completely hung and un-responsive. I am able to reproduce this error running both FreeBSD 5.2.1 and Debian Testing on a Dell Inspiron 2650.
dfinn is offline   Reply With Quote
Old 08-18-04, 06:52 AM   #65
tomate
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: problems escaping from X

Hello,

I have the same stupid problem. I think that is not a crash, because i can give the system any command (like : $ ls > test.log, and at the next restart the test.log exsists). Aditional, the LED of my monitor turn to blink yellow -> the monitor have no signal from grafik card. Where is this signal? Is it completely away or is it just on other out (DVI, TV-OUT) ? I will try to find out tonight.
I'll try to find out, whether the X-Server do this to the GC or that's a driver bug.
tomate is offline   Reply With Quote
Old 08-19-04, 02:06 AM   #66
tomate
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: problems escaping from X

OK, i think i have the solution. I've had a hint from another forum. I've set

Option "DPMS" "false" (last time i've just set a # befor it)

and it works.
tomate is offline   Reply With Quote
Old 08-25-04, 08:43 AM   #67
gvaley
Registered User
 
Join Date: Aug 2004
Posts: 2
Default Re: problems escaping from X

Not only DPMS "false" doesn's work, but I get lockups WIHTOUT my TV-cable plugged. Otherwise, the same problem with the hard lock (only hard reset.) But it doesn't happen all the time. I get 2 or 3 clean log-outs before it crashes.


Using:
Fedora Core 2 with no updates or new kernels.
nVidia driver 6111
Asus GeForce FX 5200 w/ TV-OUT.
Intel platform.

Previously, on the same machine, I tryed kernel 2.6.6 and the previous release nVidia drivers, with or without TV-OUT configured. The problem persists.
gvaley is offline   Reply With Quote
Old 09-07-04, 05:13 AM   #68
fiath
Registered User
 
Join Date: Sep 2004
Posts: 1
Default Re: problems escaping from X

Same problem here, I get a garbled/corrupted F1 screen, and blank/black for all the other login screens. I can go back to X and everything is fine, I can also execute commands on the login screens (I just can't see what I am typing).

Config:
Athlon 2800
GForce 2 Ti
Suse 9.1 /w Kernel 2.6.5
nVidia driver 5336 and also the latest 6111

I have not tried unplugging the TV out, but I will certainly try that tonight! Actually, I thought this problem was "random", but it could have been working when the power to my TV was off! Well done to the guy that figured this out.
fiath is offline   Reply With Quote

Old 09-07-04, 08:28 AM   #69
comag
Registered User
 
comag's Avatar
 
Join Date: Sep 2004
Posts: 54
Default Re: problems escaping from X

i hope this problem will fixed in the next version.
Since my tv-out addons to the xorg.conf i can't shutdown my system cause it completley hangs after X shutdown.
I tried also to unplug the the SVIDEO cable but this helps nothing.

i think i have to set "twinview" "false" if i dont use the tvout feature.
comag is offline   Reply With Quote
Old 09-07-04, 04:43 PM   #70
kgroombr
Using Linux Since 1995
 
Join Date: Sep 2002
Posts: 130
Default Re: problems escaping from X

I never had this problem with my Ti 500, Ti 4200, Ti 4600, but I just installed a BFG 6800U OC, and I have these lockups big time. Nothing changed on my system other than swapping the Ti 4600 for the 6800U OC.

Tried many of fixes with no good results.

I also have other strange problems with this card posted in this thread:

http://www.nvnews.net/vbulletin/showthread.php?t=36216

Ken
__________________
Kenton A. Groombridge
kgroombr@comcast.net
http://home.comcast.net/~kgroombr/
kgroombr is offline   Reply With Quote
Old 09-11-04, 12:07 PM   #71
cyco
GF4 Ti4200 | nforce2 chip
 
Join Date: Sep 2004
Posts: 17
Default Re: problems escaping from X

Hey there, same problem here.

* Abit NF7 v2.0 mainboard w/ nforce2 chipset
* GeForce4 TI 4200 graphics card
* Athlon XP-M 2500+
* Fedora Core 2
* Kernel 2.6.8-1.521.stk16 (recompiled and removed agpgart)
* Option "NvAGP" is set to "1"
* Tv cable NOT plugged in

When logging out of my desktop environment, the system freezes.
It seems that this problem occurs right after X is being restarted by [x|k|g]dm.

I'll try setting Options "ConnectedMonitor" "CRT" and "IgnoreDisplayDevices" "TV" this afternoon, maybe that solves the problem.
cyco is offline   Reply With Quote
Old 09-11-04, 12:32 PM   #72
cyco
GF4 Ti4200 | nforce2 chip
 
Join Date: Sep 2004
Posts: 17
Default Re: problems escaping from X

Okay, that might be quite interesting.

I did those changes to xorg.conf and here's the result:

The monitor got no signal, but gdm and kde loaded (I've auto-login enabled, so kde is loaded right after gdm startup) and I was able to switch to a console and back to X (strg-f7).
So I went back to X and tried to kill it via ctrl-alt-backspace. I was immediately brought to console 1 where I saw the following message; at this moment, the system froze:
Code:
kernel/sched.c:2411: spin_lock(kernel/printk.c:c0385080) already locked by kernel/sched.c/2239
[... repeating for about 10 lines]
kernel/sched.c:270: spin_lock(kernel/printk.c:c044dda0) already locked by kernel/sched.c/2239
[... repeating for about 10 lines]
double fault, tss at c0432000
eip = c032a9e0 , esp = d635ffc4
eax = d35bac90 , ebx = deff99a0 ,  ecx = d35bac90 , edx = d35ba680
esi = d350a680 , edi = d35ba680
cyco is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
problems with drivers after 295.40 (OpenSuSE 12.1, GeFroce 7900 GS, Phenom II X4) alawa NVIDIA Linux 0 06-09-12 07:37 PM
If you are having problems w/your 9700 please take a look 5150 Joker Other Desktop Graphics Cards 3 10-05-02 06:01 PM
Nvidia Problems in Slackware 8.1 xtreme NVIDIA Linux 3 10-01-02 01:03 PM
F1 2002 problems with driver 40.41 arutten NVIDIA Windows Graphics Drivers 6 10-01-02 08:07 AM
DirectX 8 problems with GeForce4 Derwin NVIDIA GeForce 7, 8, And 9 Series 19 08-20-02 02:23 AM

All times are GMT -5. The time now is 10:02 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.