Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-17-10, 05:59 PM   #1
mjanusz
Registered User
 
Join Date: Nov 2010
Posts: 4
Default [fixed] 256.53: suspend to RAM broken on 2.6.36+ (GF 330M)

I'm using the 256.53 NVIDIA drivers for my GF 330 on a SONY Vaio F11 laptop (the 260.* line causes a kernel oops). Without the NVIDIA drivers, suspend-to-ram (via the hibernate-ram script) partially works with any recent kernel (2.6.34, 2.6.35, 2.6.26, 2.6.37-rc1) -- the machine is completely responsive over ssh after resuming, but the screen remains blank.

With 256.53 on 2.6.34, this problem is fixed and the display is properly restored after resume. Starting with 2.6.35, resuming no longer works. The machine suspends successfully, but as soon as any button is pressed, it reboots instead of resuming.

Please let me know if there is anything I can do to help debug this problem.
Attached Files
File Type: gz nvidia-bug-report.log.gz (50.4 KB, 61 views)
mjanusz is offline   Reply With Quote
Old 11-18-10, 06:48 AM   #2
XjCook
Registered User
 
Join Date: Oct 2010
Posts: 28
Default Re: 256.53: suspend to RAM broken on 2.6.36+ (GF 330M)

I had similar problem, but when I added acpi_sleep=nonvs to grub, suspend is working right
XjCook is offline   Reply With Quote
Old 11-18-10, 08:37 AM   #3
oyvind
Registered User
 
Join Date: May 2004
Location: Norway
Posts: 117
Default Re: 256.53: suspend to RAM broken on 2.6.36+ (GF 330M)

Quote:
Originally Posted by XjCook View Post
I had similar problem, but when I added acpi_sleep=nonvs to grub, suspend is working right
True, I need to use this option with kernel 2.6.35. But IIRC 2.6.36+ should not need it any more because of built in black-list (for instance, I don't need this option to suspend/resume correctly with 2.6.37).
oyvind is offline   Reply With Quote
Old 11-18-10, 05:35 PM   #4
mjanusz
Registered User
 
Join Date: Nov 2010
Posts: 4
Default Re: 256.53: suspend to RAM broken on 2.6.36+ (GF 330M)

Quote:
Originally Posted by XjCook View Post
I had similar problem, but when I added acpi_sleep=nonvs to grub, suspend is working right
It seems that this fixes the problem for me as well -- thanks for the hint!
mjanusz is offline   Reply With Quote
Old 11-30-10, 12:45 PM   #5
alessandro_ufms
Registered User
 
Join Date: Jan 2009
Posts: 23
Default Re: 256.53: suspend to RAM broken on 2.6.36+ (GF 330M)

Wow, I had the same card and the same problem. The hint works here, on kernel 2.6.36.1 and nvidia 260.12.26. Thanks.

Will nvidia resolve this issue? It's seems the problem starts with 2.6.35 kernel that introduced the suspend to NVS area saving: http://www.spinics.net/lists/linux-acpi/msg29521.html
alessandro_ufms is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 12:44 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.