Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-19-10, 11:41 PM   #1
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

I have two systems. One is a amd64 desktop running Gentoo Linux with a XFX GeForce GTS 250 graphics card. The other is a x86 laptop running Gentoo Linux with a Nvidia GeForce Go 7900 GS graphics card.

KDE 4.5.3's magic lamp effect looks beautiful on my desktop when maximizing and minimizing windows, as do all of its other effects, but on my laptop, the magic lamp maximize animation is so choppy that it is difficult to see it being animated. All other effects are sluggish as well.

I had some issues with KDE's compositing that I fixed recently by wiping some configuration files, so I was unable to detect these issues when they first occurred. I recall things being better with older versions of the driver and I tried downgrading to version 190.53, which is the version that seems to have worked best on my laptop, but unfortunately, that version is not compatible with xorg-server 1.9.x, so I am somewhat stuck.

Out of curiousity; does Nvidia still test its newer drivers on hardware like the GeForce Go 7900 GS?
ShiningArcanine is offline   Reply With Quote
Old 11-20-10, 06:30 AM   #2
ppurka
Registered User
 
Join Date: May 2005
Posts: 39
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

You should probably check whether powermizer is on or not. You can automate turning on or off the powermizer depending on whether your laptop is connected to A/C or not. The commands are:
Code:
# Disable powermizer
nvidia-settings -a "$(hostname):0[gpu:0]/GPUPowerMizerMode=1"
# Enable powermizer
nvidia-settings -a "$(hostname):0[gpu:0]/GPUPowerMizerMode=0"
ppurka is offline   Reply With Quote
Old 11-20-10, 11:12 AM   #3
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

nvidia-settings claims that it cannot open the display. I also do not understand why powermizer would allow the the minimize animation to be smooth, but not the the maximize animation.
ShiningArcanine is offline   Reply With Quote
Old 11-20-10, 08:28 PM   #4
ppurka
Registered User
 
Join Date: May 2005
Posts: 39
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

Quote:
Originally Posted by ShiningArcanine View Post
nvidia-settings claims that it cannot open the display. I also do not understand why powermizer would allow the the minimize animation to be smooth, but not the the maximize animation.
1. Can you check if you have a "Powermizer" tab in nvidia-settings?
2. You can also try the commands without the "$(hostname)" bit. That is, simply run the commands as for example:
Code:
nvidia-settings -a ":0[gpu:0]/GPUPowerMizerMode=0"
ppurka is offline   Reply With Quote
Old 11-21-10, 11:15 AM   #5
gqman69
Registered User
 
Join Date: Aug 2008
Posts: 35
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

Did you check if opengl is handled by nvidia?

eselect opengl list


I know it's a dumb question but it happened to me once...
gqman69 is offline   Reply With Quote
Old 11-26-10, 04:27 PM   #6
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

Quote:
Originally Posted by ppurka View Post
1. Can you check if you have a "Powermizer" tab in nvidia-settings?
2. You can also try the commands without the "$(hostname)" bit. That is, simply run the commands as for example:
Code:
nvidia-settings -a ":0[gpu:0]/GPUPowerMizerMode=0"
The powermizer tab says that Adaptive Clocking is enabled. Interestingly, while it was at performance level 1, the maximize animation looked sluggish. When it went to performance level 2, the maximize animation behaved like I reported earlier.

That command does not appear to have any effect on powermizer, although it executes without a complaint from nvidia-settings. I do not believe that Powermizer can be controlled from the commandline or xorg-server settings. A while back, I tried modifying it so that it would always be on to save battery life, but nvidia-settings reported that my attempt failed and there was no improvement in battery life, so I removed my attempt at forcing it on from xorg.conf.

Quote:
Originally Posted by gqman69 View Post
Did you check if opengl is handled by nvidia?

eselect opengl list


I know it's a dumb question but it happened to me once...
It is handled by nvidia.
ShiningArcanine is offline   Reply With Quote
Old 11-27-10, 10:38 AM   #7
ppurka
Registered User
 
Join Date: May 2005
Posts: 39
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

Quote:
Originally Posted by ShiningArcanine View Post
I do not believe that Powermizer can be controlled from the commandline or xorg-server settings.
That command does work on my laptop's graphics card (nvidia NVS140M). It means that it doesn't work for your graphics card. Probably the level of functionality of the drivers is lower in the 7900 series.
ppurka is offline   Reply With Quote
Old 11-28-10, 06:54 AM   #8
marsark
Registered User
 
Join Date: Sep 2010
Posts: 10
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

I have a same problem. Composite effects performance on my GeForce 460 is very poor with KDE and nvidia drivers 260.19.21.
marsark is offline   Reply With Quote

Old 11-28-10, 04:38 PM   #9
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

If it is of any help, the issues are most prominent when maximizing Konsole. Everything else looks a little choppy, but some kind of transition is visible. Maximizing Konsole with the Magic Lamp effect only displays 1 intermediate frame before the window is maximized.
ShiningArcanine is offline   Reply With Quote
Old 12-20-10, 04:24 PM   #10
marsark
Registered User
 
Join Date: Sep 2010
Posts: 10
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

I have noticed performance improvement with nvidia-drivers version 260.19.29.
marsark is offline   Reply With Quote
Old 12-20-10, 05:49 PM   #11
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

I noticed an improvement on my desktop after enabling MTRR Sanitizer, as I mentioned in another thread:

http://www.nvnews.net/vbulletin/show...8&postcount=39

I also recently discovered that KDE's Blur effect has a memory leak, which was fixed in KDE 4.6.

https://bugs.kde.org/show_bug.cgi?id=242457

I disabled Blur, which seemed to help, although there seem to be multiple issues that interact in strange ways on my system and reproducing them to verify whether a change has a positive effect, a negative effect or any effect at all is difficult.
ShiningArcanine is offline   Reply With Quote
Old 12-25-10, 03:23 PM   #12
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: Slow KDE 4.5.3 desktop effects with nvidia driver 256.19.21

I noticed that my previous post made no sense in the context of the original post. My desktop had some issues too, but they did not involve effects.

Anyway, I think I found the discrepancy between my desktop and my laptop. My laptop did not have agpgart, so it was using nvagp, which Nvidia does not recommend for its chipset. I switched to agpgart, but that did not appear to have any effect on the minimize animation.
ShiningArcanine is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:12 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.