Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-20-10, 08:46 PM   #1
apataki1
Registered User
 
Join Date: Nov 2010
Posts: 2
Default Blank screen & X server does not start with GeForce GTX-480 after driver upgrade

Using the latest nvidia Linux drivers, the X server crashes with my GeForce GTX-480 card.
I've tried various driver versions and here is what I've found:
* 195.36.24: works well
* 195.36.31: works well - this is the LAST version that works on my card
* 256.53: freezes the kernel computer completely, even remote sessions are frozen, nothing is displayed
* 260.19.12: when the X server is started, the screen blanks but doesn't show a picture, error messages are logged to /var/log/messages and /var/log/Xorg.0.log
* 260.19.21: same as with 260.19.12

More details about the 260.19.12 crash:
In /var/log/messages, the following shows up:
Nov 20 19:47:26 sedna kernel: NVRM: os_schedule: Attempted to yield the CPU while in atomic or interrupt context
Nov 20 19:47:49 sedna kernel: NVRM: Xid (0006:00): 16, Head 00000000 Count 00000002
Nov 20 19:47:57 sedna kernel: NVRM: Xid (0006:00): 16, Head 00000000 Count 00000003
Nov 20 19:48:05 sedna kernel: NVRM: Xid (0006:00): 16, Head 00000000 Count 00000004
Nov 20 19:48:13 sedna kernel: NVRM: Xid (0006:00): 16, Head 00000000 Count 00000005
Nov 20 19:48:21 sedna kernel: NVRM: Xid (0006:00): 16, Head 00000000 Count 00000006

In /var/log/Xorg.0.log ends with:
...
[ 123.138] (--) Depth 24 pixmap format is 32 bpp
[ 123.138] (II) NVIDIA: Using 3069.00 MB of virtual memory for indirect memory
[ 123.138] (II) NVIDIA: access.
[ 123.146] (II) NVIDIA(0): Initialized GPU GART.
[ 123.152] (II) NVIDIA(0): Setting mode "nvidia-auto-select"
[ 131.196] (II) Loading extension NV-GLX
[ 135.196] (EE) NVIDIA(0): WAIT: (E, 0, 0x857d, 0)

remote sessions are usable, but the console is completely frozen.

The machine is a Dual socket AMD Opteron system (TYAN Thunder K8HM S3892 motherboard), with a single GeForce GTX-480 board installed. It runs Fedora 13 using the Linux 2.6.34.7 x86_64 kernel (and Fedora 14 has the same crash as well).

Attached is the nvidia-bug-report.log.gz file

Any hints/help would be appreciated, thanks!

Andras
Attached Files
File Type: gz nvidia-bug-report.log.gz (28.0 KB, 70 views)
apataki1 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:58 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.