Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-24-10, 12:54 AM   #1
skwid
Registered User
 
skwid's Avatar
 
Join Date: May 2005
Posts: 13
Default 260.19.21 + golang = segfault

golang issue 1262

6.out[10121]: segfault at 0 ip 00002b06387fa653 sp 00007fffdaa311e8 error 4 in libGL.so.260.19.21[2b0638766000+b7000]

Any test program that simply links -lGL will fail on init prior to entering main.
Instead of -lGL, if dlopen() is used, the program will not crash.
Also, if running through gdb/strace/ltrace the program will not crash.
After reverting to version 256, there is no problem.

It is my guess that there is a function in libGL.so during init that is failing, but instead of catching and reporting the error, it continues to failure.
Attached Files
File Type: gz nvidia-bug-report.log.gz (44.8 KB, 39 views)
skwid is offline   Reply With Quote
Old 11-24-10, 10:43 AM   #2
naib
Registered User
 
Join Date: Nov 2004
Posts: 8
Default Re: 260.19.21 + golang = segfault

Yup this has been reported quite a few times, but NV still havn't managed to fix it

http://bugs.gentoo.org/show_bug.cgi?id=336837

especially http://bugs.gentoo.org/show_bug.cgi?id=336837#c44
naib is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:42 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.