Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 11-26-10, 09:44 AM   #1
vsespb2
Registered User
 
Join Date: Nov 2010
Posts: 9
Question How to disable monitor power save ?

hi.

I have ubuntu 10.04 64bit (same issue in kubuntu 9.04) + nvidia 9400 GT + 173.14.22 (same issue in 195.xx)

i've stopped/killed/uninstalled all power related stuff
like powernow, powerd, upowerd, acpid, gnome powermanager

also turned off APM and ACPI support in bios.

and after that I still have a problem:

my display's backlight turned off after a long period of inactivity and there is no way turn it on.
(sometimes kill of Xorg helps, sometimes alt-ctrl-f1/atl-control-f7 however I need about half hour to get my backligh back)

question is what I missing ? - how to check I indeed removed all power related stuff.

Also

1. This night i tried the following:

"xset -dpms" + make sure "xset q" prints DPMS disabled.

with that disabled DPMS it slept again !

2. seems series of commands over ssh like

xset +dpms
xset dpms force off
xset dpms force on

woke it up

any ideas ?
vsespb2 is offline   Reply With Quote
Old 11-26-10, 02:34 PM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: How to disable monitor power save ?

Try this in xorg.conf (from man xorg.conf)
Code:
Section "ServerFlags"
        Option  "dpms" "false"
EndSection
whig is offline   Reply With Quote
Old 11-26-10, 04:06 PM   #3
vsespb2
Registered User
 
Join Date: Nov 2010
Posts: 9
Default Re: How to disable monitor power save ?

Thanks. I will try.
hope it differs from what I tried already
"xset -dpms" + check that xset q" prints DPMS is disabled.
vsespb2 is offline   Reply With Quote
Old 11-27-10, 02:53 AM   #4
vsespb2
Registered User
 
Join Date: Nov 2010
Posts: 9
Default Re: How to disable monitor power save ?

It did not help =(
vsespb2 is offline   Reply With Quote
Old 11-27-10, 03:34 AM   #5
Gusar
Registered User
 
Join Date: Apr 2006
Posts: 277
Default Re: How to disable monitor power save ?

Are you sure it was DPMS and not the screensaver? Turn that one off as well:
Code:
xset s off
Gusar is offline   Reply With Quote
Old 11-27-10, 04:46 AM   #6
vsespb2
Registered User
 
Join Date: Nov 2010
Posts: 9
Default Re: How to disable monitor power save ?

Quote:
Originally Posted by Gusar View Post
Are you sure it was DPMS and not the screensaver? Turn that one off as well:
Code:
xset s off
Probably sure. I am sure this was backlight. When I switch Ctlr-Alt-F1/Ctlr-Alt-F7 i see my screen to one second. Then it become dark again. And even when it's dark I can see some very very dark shapes.

But I will try this night !
vsespb2 is offline   Reply With Quote
Old 11-28-10, 05:22 AM   #7
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: How to disable monitor power save ?

You should use the latest driver (which is the 256 series) for your card.
I personally never had any issues with this.
But i left the screensaver and power manager processes running. I use gnome btw (and this worked well on xfce or the standard x screensaver). Both in Ubuntu and Debian Squeeze.
I just unticked the check boxes in gnome/xfce power preferences and in gnome/x screensaver without any xorg.conf modifications. All settings worked as expected (on quadro nvs 285, gf 7600gs, igp 8200 cards).

Maybe removing the acpi/power management features makes your problem worse, because resuming may also need acpi support too.
gradinaruvasile is offline   Reply With Quote
Old 11-29-10, 06:19 AM   #8
vsespb2
Registered User
 
Join Date: Nov 2010
Posts: 9
Default Re: How to disable monitor power save ?

Quote:
Originally Posted by gradinaruvasile View Post
You should use the latest driver (which is the 256 series) for your card.
I personally never had any issues with this.
it worked fine for me too. but one day it become broken. (after playing with power saveing options after upgrading ubuntu 9.04 -> 10.04)
same issue in 19x drivers. and 256 failed to install in both 9.04 and 10.04.

Quote:
Originally Posted by gradinaruvasile View Post
But i left the screensaver and power manager processes running. I use gnome btw (and this worked well on xfce or the standard x screensaver). Both in Ubuntu and Debian Squeeze.
I just unticked the check boxes in gnome/xfce power preferences and in gnome/x screensaver without any xorg.conf modifications. All settings worked as expected (on quadro nvs 285, gf 7600gs, igp 8200 cards).

Maybe removing the acpi/power management features makes your problem worse, because resuming may also need acpi support too.
initially acpi was not disabled. i disabled it trying to fix the issue. now i enabled acpi again.

seems it's easier to buy new video card or reinstall linux from scratch etc. but i want to fix it without doing that.

seems my task is simple - not to fix powersave modes but just find _what_ let my screen sleep. i was trying to disable everything! and it still sleep.
vsespb2 is offline   Reply With Quote

Old 11-29-10, 06:30 AM   #9
gradinaruvasile
Registered User
 
gradinaruvasile's Avatar
 
Join Date: May 2008
Posts: 199
Default Re: How to disable monitor power save ?

If 256 failed to install you have other issues aswell.
Upgrading Ubuntu does not work 100 % most times (some residual config still remains and causes random headaches). Especially 9.04 - 9.10/10.04 (too many kernel level changes and stuff).
I know this because i and others experienced it (dropped Ubuntu afterwards in favor of debian).
So my advice is to do a clean install or be ready for stuff like this.
gradinaruvasile is offline   Reply With Quote
Old 12-01-10, 04:21 AM   #10
vsespb2
Registered User
 
Join Date: Nov 2010
Posts: 9
Default Re: How to disable monitor power save ?

update:

it helps if i plug monitor off.
so maybe hardware monitor problem - it cannot wake up normally.

so is there a solution (like i specified in 1st post) to disable monitor sleep.
i.e. i don't want to buy new monitor, i just want setup linux to never turn my monitor off ?

is there a complete list of components which turn it off ? i want to read manual for each.
vsespb2 is offline   Reply With Quote
Old 12-01-10, 08:16 AM   #11
luk1don
Registered User
 
luk1don's Avatar
 
Join Date: Nov 2008
Posts: 55
Default Re: How to disable monitor power save ?

Disable DPMS and prevent screen from turning off in X:
Code:
xset -dpms;xset s off
Prevent screen from turning off in console:
Code:
setterm -blank 0 -powerdown 0
luk1don is offline   Reply With Quote
Old 12-07-10, 05:00 AM   #12
vsespb2
Registered User
 
Join Date: Nov 2010
Posts: 9
Default Re: How to disable monitor power save ?

setterm -blank 0 -powerdown 0
xset -dpms;xset s off

doesnt help

Section "ServerFlags"
Option "dpms" "false"
Option "blank time" "0"
Option "standby time" "0"
Option "suspend time" "0"
Option "off time" "0"
EndSection

doesnt help too

driver upgrade to to 260.19.26 doesnt help too

plug on/off monitor dosent always help wake up.

what is helping wake up is commands over ssh:

xset -d :0 dpms force standby
xset -d :0 dpms force on
vsespb2 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:27 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.