Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 08-01-03, 10:16 AM   #1
anakin
Registered User
 
Join Date: Aug 2003
Posts: 8
Unhappy suspend with APM

I have a Toshiba Satellite 2410-603 with a nvidia geforce4 420 go with a Debian Woody installed.

With the previouse release (4363) of the nvidia drivers the suspend works great (with AGP disabled).
With the lastest driver (4496) the suspend don't work (with AGP and without AGP). The apm reject the suspend process.
I also tried to enable in kernel the interrupt during apm calls.

What's happened?!

Thanks for your help!

Anakin
anakin is offline   Reply With Quote
Old 08-05-03, 05:20 PM   #2
wolfi
Registered User
 
Join Date: Aug 2003
Posts: 3
Default Re: suspend with APM

Hi anakin!

Is apm-support by any chance compiled as a module in your kernel? When you do "apm -s", do you get that the event was vetoed by a kernel driver?
Today I tested Version 1.0-4496 of the NVidia drivers on a Toshiba Satellite 2410-404 Laptop. The System is debian Woody with kernel 2.4.21. Support for apm is compiled as a module. This lead to difficulties, since the driver does not expect this. It only supports compiled-in support. After applying the attached patch it "mostly" works. I don't really know if sending patches to this list is convenient, but perhaps nVidia can use it.
"Mostly" means that there are two annoying things: I have to boot with vga=791. If I set vga=normal, after resume there is only something like a blinking cursor shown on the left border of the screen. "Mostly" also means that I can't properly use the "Suspend..."-entry in the gdm
menu. I use gdm for login and if I suspend from its menu all seems to be ok. If I now resume, the login screen does not appear. Instead a text cursor is blinking in the upper left corner just as if I had stopped gdm. The six text consoles work as expected. I can login as root and restart gdm using "/etc/init.d/gdm start".
However, if I am already logged in, working under gnome, I can do an "apm -s" and suspend and resume work as expected. So this is perhaps an issue of gdm.

Best regards,

Wolfi
Attached Files
File Type: txt nvidia.diff.txt (445 Bytes, 154 views)
wolfi is offline   Reply With Quote
Old 08-06-03, 02:40 AM   #3
anakin
Registered User
 
Join Date: Aug 2003
Posts: 8
Default Re: Re: suspend with APM

Quote:
Originally posted by wolfi
Hi anakin!

Is apm-support by any chance compiled as a module in your kernel? When you do "apm -s", do you get that the event was vetoed by a kernel driver?
Yes, I have the apm-supporto compiled as module (I have apm and acpi compiled together, and I use the kernel option 'acpi=off' to switch).
The kernel driver vetoed the suspend event.

I will try your patch and if there are problems then I will compile the apm-support built-in.

Thanks for your help!!!
anakin is offline   Reply With Quote
Old 08-06-03, 03:04 AM   #4
anakin
Registered User
 
Join Date: Aug 2003
Posts: 8
Default Re: Re: suspend with APM

Quote:
your patch
-#if defined(CONFIG_APM)
+#if defined(CONFIG_APM) || defined(CONFIG_APM_MODULE)
This is your patch, but in my config the CONFIG_APM is defined (as 'm') and I don't have the CONFIG_APM_MODULE define!? 8|

This is my config:
CONFIG_PM=y
CONFIG_APM=m
# CONFIG_APM_IGNORE_USER_SUSPEND is not set
CONFIG_APM_DO_ENABLE=y
# CONFIG_APM_CPU_IDLE is not set
# CONFIG_APM_DISPLAY_BLANK is not set
# CONFIG_APM_RTC_IS_GMT is not set
# CONFIG_APM_ALLOW_INTS is not set
# CONFIG_APM_REAL_MODE_POWER_OFF is not set

At the moment I didn't apply your patch but I will do!

bye
Mario
anakin is offline   Reply With Quote
Old 08-06-03, 08:32 AM   #5
Rapsys|Phoenix
Registered User
 
Rapsys|Phoenix's Avatar
 
Join Date: May 2003
Location: France, Villeurbanne
Posts: 61
Default

It's because a bug in the BIOS of the toshiba laptop!!!

if you have compiled your kernel you would have see it in the "general setup/ACPI/Toshiba Laptop Extras" option help
it enable,module or disable the CONFIG_ACPI_TOSHIBA option.
try it!!
__________________
**** off M$ and his ****ing software
Rapsys|Phoenix is offline   Reply With Quote
Old 08-06-03, 10:40 AM   #6
wolfi
Registered User
 
Join Date: Aug 2003
Posts: 3
Default Re: Re: Re: suspend with APM

Quote:
Originally posted by anakin
Yes, I have the apm-supporto compiled as module (I have apm and acpi compiled together, and I use the kernel option 'acpi=off' to switch).
The kernel driver vetoed the suspend event.

Hi anakin!

Well, this option can't be found in the config-file. The config-file (.config) is generated by "make menuconfig" etc., but then it is parsed and the configuring options are translated into makros for the C-preprocessor. This is done directly by "make menuconfig" or by debian's make-kpkg. You can find the makros in kernel-source-dir/include/linux/autoconf.h. If apm is configured as a module you will find the two lines

#undef CONFIG_APM
#define CONFIG_APM_MODULE 1

in there.

I hope this helps,

Wolfi
wolfi is offline   Reply With Quote
Old 08-17-03, 04:04 AM   #7
anakin
Registered User
 
Join Date: Aug 2003
Posts: 8
Wink

Ok, I applied the patch and now the suspend works great!!! Also with AGP enabled!

Thanks for the help!
Anakin
anakin is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


Similar Threads
Thread Thread Starter Forum Replies Last Post
302.07 no resume from suspend stecklum NVIDIA Linux 85 12-07-12 02:27 PM
AMD Has No Plans To Suspend Catalyst For Linux News Archived News Items 0 06-19-12 10:30 PM
APM (nonsuspend) hard-lockups - I READ THE FAQ idangazit NVIDIA Linux 9 12-27-02 08:43 AM
Hard lockups - AGP not guilty milo NVIDIA Linux 11 11-12-02 10:20 AM
Can fan on GeForce2 GTS be turned off with APM? nurey NVIDIA Linux 3 07-29-02 12:11 PM

All times are GMT -5. The time now is 04:15 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.