Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-12-10, 03:57 AM   #1
Wise Ferret
Registered User
 
Join Date: May 2010
Posts: 8
Default Powermizer works poorly with compiz and cannot be set from xorg.conf

I use geforce 9400M G on ubuntu 10.10 64 bit. My driver version is 260.19.26.

Up until recently I could set the powermizer mode to "Maximum performance" using xorg.conf. However, this does not work any more. My system starts with powermizer mode set to "adaptive", and I have to change it manually back.

This wouldn't be a problem if adaptive mode would work properly, but it doesn't. When I play 3d games while using compiz, like lugaru (or any other), in adaptive mode, the game starts fine but then I experience severe drops in the frame rate. It is as if the powermizer does not know a 3d app is running. This happens regardless whether the laptop runs on AC power or battery.

So my questions are:

1. Can adaptive mode be made to work when compiz runs, so it is actually adapts the clock speed to the system demands?

2. If it cannot, can the powermizer be set automatically so I do not have to open nvidia-settings and change it manually after reboot? the xorg.conf line stopped working after upgrading the drivers.

3. Can I supply more useful information in order to solve the problem(s)?

My xorg.conf is:

Code:
Section "ServerFlags"
	Option		"IgnoreABI" "True"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	DefaultDepth	24
EndSection

Section "Device"
	Identifier	"Default Device"
	Driver	"nvidia"
	Option  "FlatPanelProperties"  "Scaling = Aspect-Scaled"
	Option  "OnDemandVBlankInterrupts" "true"
	Option	"NoLogo"	"True"
	Option  "coolbits" "1"
	Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
EndSection

Section "InputClass"
        Identifier "enable synaptics SHMConfig"
        MatchIsTouchpad "on"
        MatchDevicePath "/dev/input/event*"
        Option "SHMConfig" "on"
EndSection
Wise Ferret is offline   Reply With Quote
Old 12-12-10, 07:05 AM   #2
NvFuchs
Registered Fox
 
NvFuchs's Avatar
 
Join Date: Oct 2007
Location: Confoederatio Helvetica
Posts: 530
Default Re: Powermizer works poorly with compiz and cannot be set from xorg.conf

You can always use

nvidia-settings -a [gpu:0]/GPUPowerMizerMode=0

on the commandline, therefore you can also script it, bind it to compiz startup or other conditions such as ACPI events (battery / AC state, etc.)

Fuchs

(0 would be adaptive state, 1 would be maximum performance)
NvFuchs is offline   Reply With Quote
Old 12-12-10, 07:19 AM   #3
Wise Ferret
Registered User
 
Join Date: May 2010
Posts: 8
Default Re: Powermizer works poorly with compiz and cannot be set from xorg.conf

Quote:
Originally Posted by NvFuchs View Post
You can always use

nvidia-settings -a [gpu:0]/GPUPowerMizerMode=0

on the commandline, therefore you can also script it, bind it to compiz startup or other conditions such as ACPI events (battery / AC state, etc.)

Fuchs

(0 would be adaptive state, 1 would be maximum performance)
Thanks for the tip, I will use it.

It would be better though if my settings were just kept after I set them in the gui tool - it's not too much to ask for. The best would be, of course, that adaptive mode wouldn't stop functioning in the presence of compiz.
Wise Ferret is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 08:30 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.