Go Back   nV News Forums > Linux Support Forums > NVIDIA FreeBSD

Newegg Daily Deals

Reply
 
Thread Tools
Old 04-17-11, 09:51 PM   #1
blahblah1981
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Random system freezes since upgrading to KDE 4.6.2.

Hello,

Firstly let me say thank you for NVIDIA for providing native FreeBSD drivers. This was the decision that ultimately swayed me in favor of purchasing an NVIDIA card over other ones.

I am running amd64, stable 8.2. When the FreeBSD driver first came out I was having stability problems and random crashes like many others in the forums, but these eventually stopped. I have been running stable with no issues for quite some time now.

Recently, I upgraded KDE to 4.6.2 and since that upgrade I have been experiencing random crashes again. I was using the NVIDIA driver from the ports, 256.53_1, with no issues, but since upgrading KDE things are quite unstable.

I have received crashes (complete system freezes) while doing the following:

1. Browsing in Firefox or Opera. Specifically when opening images.

2. Crashes with KDE and also with TWM. I have since stopped using KDE and have been running simply TWM to see if it was only KDE related.

3. Random crashes when viewing video with mplayer. The same video that I was playing when the system crashed plays fine on the next reboot. It seems to be very random.


What I have done to try and resolve this issue:

A. Re-synced the "RELENG_8" sources and rebuilt my system.

B. Rebuilt all ports.

C. Switched from the ports NVIDIA driver, 256.53_1, to the newest one, 270.41.03.

D. Tried to catch a kernel dump, but have been unsuccessful.


None of the above has helped and I am still "freezing". I am torn at the moment between trying to roll my ports tree back to a previous point in time where I was stable and moving on up to 9_CURRENT. Any ideas of what I could try to bring back a stable system?

Quick system specs:

Motherboard: MSI X58 Pro-E
CPU: Intel Core i7 920 2.66GHz
Memory: 6GB
Graphics: Elsa Gladiac 796 GT SS (Nvidia GeForce 9600 GT)
FreeBSD Stable 8.2, AMD64

I have generated a bug report and attached it. Please note that I have not been able to do this while the system was "frozen", but it was made while the system is running normally.

Best Regards.
Attached Files
File Type: gz nvidia-bug-report.log.gz (22.7 KB, 167 views)
blahblah1981 is offline   Reply With Quote
Old 04-24-11, 02:21 AM   #2
blahblah1981
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Re: Random system freezes since upgrading to KDE 4.6.2.

Bump.

Does anyone have any suggestions? Anything that I could try?

My system is still crashing and I still am unable to grab a kernel dump. I am attaching another bug report, but this was also made by root after the reboot following a crash.

Today's crash occurred while using TWM, with Opera, and a single xterm running. I was playing videos with mplayer. These are videos that I have taken with my camera and are HD. I was able to play about 10 - 15 back without problems before the crash. The video that I was playing when the system crashed played fine after rebooting.

One thing that I have noticed is that with all the crashes that I have had, while using Opera, Firefox, or mplayer; they all seem to occur just as the graphics system gets involved. What I mean is that the video buffers completely in mplayer, but at the moment that it is going to display on the screen it crashes. With Opera and Firefox, the webpage that I was viewing partially displayed, but it failed when it was about to display a picture. No dumps to confirm this.

Regards.
Attached Files
File Type: gz nvidia-bug-report.log.gz (22.8 KB, 167 views)
blahblah1981 is offline   Reply With Quote
Old 04-24-11, 12:06 PM   #3
rnejdl
Registered User
 
Join Date: Nov 2007
Location: Dallas, TX
Posts: 96
Default Re: Random system freezes since upgrading to KDE 4.6.2.

The only thing I have found is that there appears to be an issue with the NVIDIA driver, linux emulation, and sound on FreeBSD. I have had freezes playing flash videos(less rarely) and with skype (very rarely). Using GNASH solves the crashes in flash but comes with its own issues.

Sorry, but as far as KDE, I am just not aware of anything in there that would cause your system to crash and reboot. Suggestions would be to try a different nvidia card if you have one or try the NV driver (which will most likely not crash at all but kill your CPU cycles).

The only things I can think of would be how non-standard you are. What is in your /etc/make.conf? Which compiler are you using - CLANG or GCC ? What ports do you have installed? Which non-standard options did you use in your ports?

Rusty Nejdl
http://networking.ringofsaturn.com
rnejdl is offline   Reply With Quote
Old 04-25-11, 03:38 AM   #4
blahblah1981
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Re: Random system freezes since upgrading to KDE 4.6.2.

Thanks for your reply, Rusty. Your other posts to this forum have been very helpful.

I agree with you, I don't believe that KDE has anything to do with the issues that I am having, but after upgrading KDE to 4.6.2 my system has become unstable. This is really the only major change that I've made recently and since upgrading KDE stability has gone down the drain.

I'm not running anything too non-standard. This is my server/desktop so I do have a lot of ports installed and I am running linux emulation and sound which is probably where my problems are coming from, as you pointed out. I do not use ZFS, only UFS with gmirror.

My make.conf (in it's entirety):

Code:
CPUTYPE=native
KERNCONF=MYKERNEL8INCLUDES
WITH_NVIDIA_GL=YES
WITH_NVIDIA=YES
WITHOUT_NOUVEAU=YES
PERL_VERSION=5.12.3
I am using the base GCC to compile the system and ports. I am running RELENG_8, 8.2-STABLE.

If I had a second NVIDIA card I would test it, but this is the only one that I have. I would really hate to see GPU acceleration go, but I will probably do as you suggest and go to the NV driver soon (fsck after crash is killing me).

I really wish I could get a kernel dump, but even with dumpdev configured, I can't grab anything. When the system crashes it crashes hard and is quite simply dead; even the Num Lock key becomes unresponsive.

Thanks,
Richard
blahblah1981 is offline   Reply With Quote
Old 05-29-11, 09:07 PM   #5
blahblah1981
Registered User
 
Join Date: Apr 2011
Posts: 4
Default Re: Random system freezes since upgrading to KDE 4.6.2.

Just wanted to post a reply back to this thread that my issues seem to have gone away with 270.41.06. After running 270.41.06 without any issues for a few days, I have since upgraded to 270.41.19 and have had no problems. Thanks.
blahblah1981 is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:52 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.