Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-19-10, 12:28 PM   #1
nlamarra
Registered User
 
Join Date: Dec 2010
Posts: 13
Default HDMI audio not working on 10.10 x86_64 260.19.29

I'm detaching this from another which is focused on video issues, because I don't believe mine is video-related.

My i7-950 machine (Intel X58M motherboard) dual-boots either Windows7 or Ubuntu 10.10 and under Windows7, there is sufficient configuration within the nVidia tool to allow proper selection between many digital audio modes (and speakers if you care). Thus, proper 5.1 digital audio travels alongside the 1080p video on the HDMI cable and works great through my Sony receiver to my Sharp Aquos TV.

However, under 10.10, the video works fine but there is no audio. The configuration tool in System->Preferences->Sound is much more limited -- it apparently recognizes there is digital audio connected via HDMI, but it thinks it is only "stereo" and there is no actual output. Moreover, the nVidia-settings tool only appears to be interested in the video setup for the X-server, and does not address the audio configuration.

I presume the ALSA configuration can be modified to know about the audio capabilities of the GT240 via HDMI, but I have no idea where to start.

Suggestions appreciated.
nlamarra is offline   Reply With Quote
Old 12-20-10, 01:11 AM   #2
whig
550Ti
 
Join Date: Jan 2004
Location: New Zealand
Posts: 854
Default Re: HDMI audio not working on 10.10 x86_64 260.19.29

Search this forum, a bit has been said. This one for starters.
whig is offline   Reply With Quote
Old 12-22-10, 08:06 AM   #3
nlamarra
Registered User
 
Join Date: Dec 2010
Posts: 13
Default Re: HDMI audio not working on 10.10 x86_64 260.19.29

Quote:
Originally Posted by whig View Post
Search this forum, a bit has been said. This one for starters.
After some messing around, including some good (and bad) advice from nVidia support, including the following link, I was able to get 5.1-ch sound in some circumstances:

http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240

the trick for my setup was to add the following line to /etc/modprobe.d/sound.conf:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

and then use the device:

plughw:0,7

So now I can get 5.1-sound using:

speaker-test -D plughw:0,7 -c6

and I can even get other output sample rates (e.g., 48, 96, 192KHz) like:

speaker-test -D plughw:0,7 -c6 -p 1000000 -t sine -r 192000 -f 1000

However, System->Preferences->Sound still shows the only available device as "HDMI stereo", and I only get 2-channel audio from rhythmbox, even with multi-channel .flac files.

And I also still get absolutely no sound from mplayer or xine.

Sorry for my ignorance, but how do I get these other applications to understand the equivalent of plughw:0,7, or set the default sound hardware device to this?

Thanks
nlamarra is offline   Reply With Quote
Old 12-22-10, 11:46 AM   #4
nlamarra
Registered User
 
Join Date: Dec 2010
Posts: 13
Default Re: HDMI audio not working on 10.10 x86_64 260.19.29

Quote:
Originally Posted by nlamarra View Post
After some messing around, including some good (and bad) advice from nVidia support, including the following link, I was able to get 5.1-ch sound in some circumstances:

http://wiki.xbmc.org/?title=HOW-TO_s...20%2C_or_GT240

the trick for my setup was to add the following line to /etc/modprobe.d/sound.conf:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

and then use the device:

plughw:0,7

So now I can get 5.1-sound using:

speaker-test -D plughw:0,7 -c6

and I can even get other output sample rates (e.g., 48, 96, 192KHz) like:

speaker-test -D plughw:0,7 -c6 -p 1000000 -t sine -r 192000 -f 1000

However, System->Preferences->Sound still shows the only available device as "HDMI stereo", and I only get 2-channel audio from rhythmbox, even with multi-channel .flac files.

And I also still get absolutely no sound from mplayer or xine.

Sorry for my ignorance, but how do I get these other applications to understand the equivalent of plughw:0,7, or set the default sound hardware device to this?

Thanks
Correction: I've just discovered that mplayer does produce 2-ch sound from a .TS file (at 1920x1080), but the audio should be 5.1 LPCM 48KHz. I've tried:

mplayer -ao alsa:device=plughw=0.7 file.TS

but this still produced 2-ch 44.1KHz sound.

Any suggestions on how to change the alsa device System-wide so every application knows it's capable of 5.1ch?
nlamarra is offline   Reply With Quote
Old 12-22-10, 02:16 PM   #5
nlamarra
Registered User
 
Join Date: Dec 2010
Posts: 13
Default Re: HDMI audio finally working on 10.10 x86_64 260.19.29

Quote:
Originally Posted by nlamarra View Post
Correction: I've just discovered that mplayer does produce 2-ch sound from a .TS file (at 1920x1080), but the audio should be 5.1 LPCM 48KHz. I've tried:

mplayer -ao alsa:device=plughw=0.7 file.TS

but this still produced 2-ch 44.1KHz sound.

Any suggestions on how to change the alsa device System-wide so every application knows it's capable of 5.1ch?
More experimentation and searching has produced success! Here are the additional things that helped. First, adding the following to /etc/asound.conf allowed me to set the default device to plughw:0,7 as follows:

pcm.!default {
type plug
slave.pcm {
type hw
card 0
device 7
}
}


This enabled rhythmbox to produce 2-ch audio LPCM 48KHz by default.

To enable it to play AVCHD files in 1920x1080 @ 5.1-ch audio for mplayer, I used:

mplayer -ao alsa:device=plughw=0.7 -channels 6 file.TS

and finally, for DVDs:

xine -A alsa

I still haven't figured out how to get 5.1audio from xine, because when I enter the audio control panel to select "speaker selection", the control hangs, so it won't let me scroll down to 5.1 surround. However, 2-ch output occurs via HDMI. There's probably a way to configure this in a config file using --config<file> but I haven't figured this out yet.

Just for completeness in this post, the other settings I had to make were in /etc/pulse/default.pa:

load-module module-alsa-sink device=plughw:0,7


and in /etc/modprobe.d/sound.conf:

options snd-hda-intel enable_msi=0 probe_mask=0xffff,0xfff2

and I figured out the card 0 and device 7 from running

aplay -l

which produced the following output:

**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 3: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 7: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 8: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 9: NVIDIA HDMI [NVIDIA HDMI]
Subdevices: 1/1
Subdevice #0: subdevice #0


and trying device 3, 7, 8, 9 in turn led me to discover that 7 was needed for 5.1-ch audio.

Final test:

speaker-test -c6

now works without my having to add the option "-D plughw:0,7", meaning that my default audio device is correctly set to plughw:0,7 by the above.

Thanks for all the suggestions and I hope this experience is helpful to other newbies.
nlamarra is offline   Reply With Quote
Old 12-22-10, 04:24 PM   #6
cehoyos
FFmpeg developer
 
Join Date: Jan 2009
Location: Vienna, Austria
Posts: 467
Default Re: HDMI audio not working on 10.10 x86_64 260.19.29

Quote:
Originally Posted by nlamarra View Post
Correction: I've just discovered that mplayer does produce 2-ch sound from a .TS file (at 1920x1080), but the audio should be 5.1 LPCM 48KHz. I've tried:

mplayer -ao alsa:device=plughw=0.7 file.TS

but this still produced 2-ch 44.1KHz sound.
-channels 6 or 8 (you can put this into ~/.mplayer/config)

Carl Eugen
cehoyos is offline   Reply With Quote
Old 01-03-11, 12:11 PM   #7
Stephen Warren
Moderator
 
Stephen Warren's Avatar
 
Join Date: Aug 2005
Posts: 1,327
Default Re: HDMI audio not working on 10.10 x86_64 260.19.29

Just as an FYI, editing /etc/asound.conf like that completely bypasses pulseaudio, so the standard Ubuntu audio tools won't work any more, so the instructions I sent you to configure your default audio output will no longer work, since that file overrides them.
Stephen Warren is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:44 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.