Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 12-30-10, 07:33 AM   #1
dae
Registered User
 
Join Date: Jul 2004
Location: Sweden
Posts: 40
Default Webpage rendering slow in kde/qt apps

Rendering webpages in kde/qt apps is really slow if -graphicssystem=native is used. Using raster improves the situation *a lot*. This is true for at least both konqueror and rekonq, using either khtml or webkit as backend (but note that rekonq up to, and including 0.6.1 programmatically switches to raster - latest git version doesn't, due to rendering issues with raster on some hw/driver configs).

I know that it is a pretty well known fact that raster is faster than native. But raster is also buggy (for me, and many others as well it would seem). Furthermore, web rendering is the only thing I'm aware of where the performance diff is actually an issue. The rest of my kde4 desktop is "flying" and has no noticable performance issues at all.

Anyone else seeing this? Is nvidia working on a fix? Anyone know of any workarounds, except switching browser?
dae is offline   Reply With Quote
Old 12-30-10, 11:28 AM   #2
dae
Registered User
 
Join Date: Jul 2004
Location: Sweden
Posts: 40
Default Re: Webpage rendering slow in kde/qt apps

*sigh* appears to be the old anti-aliasing issue again; turning on anti-aliasing improves performance considerably.

I *really* hope this will be fixed someday.
dae is offline   Reply With Quote
Old 12-30-10, 11:45 AM   #3
dae
Registered User
 
Join Date: Jul 2004
Location: Sweden
Posts: 40
Default Re: Webpage rendering slow in kde/qt apps

One more data point; performance with "native" (anti-aliasing off) is actually pretty good in konqueror - until you open up a second tab. As soon as you have more than one page open, performance drops noticeably.

Rekonq always uses tabs, even though you have only one page open. And I don't see any difference in performance with one or more tabs.

So perhaps the problem isn't really that trivial? Anyone know what qt does differently when tabs are used?
dae is offline   Reply With Quote
Old 12-30-10, 02:49 PM   #4
dae
Registered User
 
Join Date: Jul 2004
Location: Sweden
Posts: 40
Default Re: Webpage rendering slow in kde/qt apps

Now this is very interresting... I was playing around with various theme/style settings, and noticed that changing the QT style from oxygen to plastique caused performance to jump up drastically.

I tried a number of other styles as well, and oxygen seems to be the only one suffering from slow rendering.

So, looks like bad interaction between oxygen and the nvidia drivers. Guess I'll head over to bugs.kde.org and file a bug report against oxygen.
dae is offline   Reply With Quote
Old 12-30-10, 03:27 PM   #5
dae
Registered User
 
Join Date: Jul 2004
Location: Sweden
Posts: 40
Default Re: Webpage rendering slow in kde/qt apps

For the record: https://bugs.kde.org/show_bug.cgi?id=261658
dae is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:41 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.