Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-06-11, 06:46 AM   #1
manchette
Registered User
 
Join Date: Sep 2008
Posts: 11
Question Floating point exception with 260.19.21.run version

Hi

Could you please help me understand why nvidia drivers are not ok anymore for me since a few versions ? Is this harware, kde, X, driver, kernel ?

After upgrade with version 260.19.29 i have a floating point exception when booting (i'm always using nvidia file, x86 last .run, and install it from init 3 ).

This problem for me is since 256.53 version of nvidia driver , i keep on installing new driver, install seems ok but after reboot (shutdown -r now) i have a floating point exception with a black screen and an error message that i can't close, so i need to close session and go back to ctrl/alt/F1 console and then to init 3 to reinstall my "old" version (256.53 .run) ; which i kept handy in a secret place

Thanks

(btw i've been told it's a known issue since kde 4.5 and ok with kde 4.4.4 (??) and also that kde 4.6 rc1 works ok ... )

i'm using
opensuse 11.3
Qt: 4.7.1
KDE Development Platform: 4.5.90 (4.6 RC1)
Core 2 Duo E8400 @ 3ghz (this is x86 and 32 bits)
Geforce 7900 GS
Asrock motherboard
uname -a is :
Linux linux-alzh 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 i686 i686 i386 GNU/Linux
manchette is offline   Reply With Quote
Old 01-06-11, 09:47 AM   #2
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: Floating point exception with 260.19.21.run version

Logs would be kind of important to offer any kind of diagnosis.
Deanjo is offline   Reply With Quote
Old 01-06-11, 10:06 AM   #3
manchette
Registered User
 
Join Date: Sep 2008
Posts: 11
Question Re: Floating point exception with 260.19.21.run version

Which ones would be interesting ?
manchette is offline   Reply With Quote
Old 01-06-11, 02:46 PM   #4
VLJ
Registered User
 
Join Date: Dec 2006
Posts: 16
Default Re: Floating point exception with 260.19.21.run version

I had the same issue.
KDE 4.5/4.6RC does not run on driver > 256.53 when using a too old kernel (or xorg...don't know which component is responsible).

However KDE > 4.4 run fines with a 2.6.35+ kernel and 1.9 xorg-server ; such a configuration is provided by openSUSE Factory (I'm running milestone 5 with KDE 4.6 beta and 2.6.37rc kernel and xorg 1.9.x), but it can be unstable.
You may ask tumbleweed to ship a newer kernel/xorg server (or wait 2 extra month before opensuse 11.4 ship); with current configuration, openSUSE 11.3 won't be able to run KDE 4.5 with nvidia drivers.

Notice that Gnome 3 has performance issue on xorg server 1.8 with nvidia drivers, solved with 1.9 xorg server.
VLJ is offline   Reply With Quote
Old 01-06-11, 04:19 PM   #5
manchette
Registered User
 
Join Date: Sep 2008
Posts: 11
Default Re: Floating point exception with 260.19.21.run version

"a 2.6.35+ kernel and 1.9 xorg-server"

Very interesting, thanks
manchette is offline   Reply With Quote
Old 01-07-11, 09:00 AM   #6
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: Floating point exception with 260.19.21.run version

Quote:
Originally Posted by manchette View Post
Which ones would be interesting ?
you did not follow the sticky procedure:
To make sure this log file includes as much relevant information as possible, please start the X server with `startx -- -logverbose 6` and run `nvidia-bug-report.sh` after the problem has occurred. from If you have a problem, PLEASE read this first
Licaon is offline   Reply With Quote
Old 01-07-11, 08:54 PM   #7
Deanjo
Registered User
 
Join Date: Aug 2004
Posts: 301
Default Re: Floating point exception with 260.19.21.run version

Well just a note: I'm also running opensuse 11.3 64-bit on quite a few systems and none have ever had a floating point exception. Some are running KDE 4.5.4 and 4.6 RC. All of them are running various generations of cards (7300GS, 8200 IGP, 8800GT, GTX-275, GTX-580) all running the 260.19.29 and all of them are running fine with the 2.6.34.7-0.7.1-desktop kernel.

I'm not sure why you are running 32-bit on your system but it might be worth to give it a shot. For what it is worth all the systems that I'm running them on are AMD processors with nvidia nforce chipsets.
Deanjo is offline   Reply With Quote
Old 02-09-11, 03:27 AM   #8
rabauke
Registered User
 
Join Date: Feb 2009
Posts: 2
Default Re: Floating point exception with 260.19.21.run version

This bug only affects 32bit systems and only for driver versions > 256.53 and KDE > 4.4. Kernel .34 and .36.

KDE 4.6.0 is also affected.

Downstream bug reports are:

https://bugzilla.novell.com/show_bug.cgi?id=648718
https://bugs.kde.org/show_bug.cgi?id=251719
http://forums.opensuse.org/english/g...19-issues.html
rabauke is offline   Reply With Quote

Old 02-09-11, 03:57 AM   #9
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: Floating point exception with 260.19.21.run version

Quote:
Originally Posted by rabauke View Post
This bug only affects 32bit systems and only for driver versions > 256.53 and KDE > 4.4. Kernel .34 and .36.

KDE 4.6.0 is also affected.
driver 270.18 too?
Licaon is offline   Reply With Quote
Old 02-09-11, 05:17 AM   #10
Lowrider39
Registered User
 
Join Date: Feb 2011
Posts: 1
Default Re: Floating point exception with 260.19.21.run version

Perhaps the attached files are helpfull. If not, tell me what can be helpfull. Sorry I am a pure user.
Attached Files
File Type: gz nvidia-bug-report.log.gz (48.0 KB, 74 views)
File Type: txt Amarok-crash.txt (21.3 KB, 75 views)
Lowrider39 is offline   Reply With Quote
Old 02-10-11, 01:36 AM   #11
Licaon
Registered User
 
Licaon's Avatar
 
Join Date: Nov 2004
Location: Between the keyboard and the chair.
Posts: 490
Default Re: Floating point exception with 260.19.21.run version

Quote:
Originally Posted by Lowrider39 View Post
Perhaps the attached files are helpfull. If not, tell me what can be helpfull. Sorry I am a pure user.
can you read http://www.nvnews.net/vbulletin/showthread.php?t=46678 and generate a good report with the debug ( -logverbose 6 ) info as instructed after the issue appears ?
Licaon is offline   Reply With Quote
Old 02-27-11, 05:36 PM   #12
briohewi
Registered User
 
Join Date: Apr 2007
Posts: 8
Default Re: Floating point exception with 260.19.21.run version

Fixed for me by 270.29. Thanks.
briohewi is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 09:13 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.