Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-10-11, 09:01 AM   #13
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: WoW in wine performance issue - chipset issue?

Quote:
Originally Posted by ShiningArcanine View Post
Try booting with "enable_mtrr_cleanup mtrr_spare_reg_nr=1" appended to your friend's system's kernel parameters. On AMD64 systems with 4GB or more of memory, the MTRR is not properly configured on Linux systems by default, so you need to either compile the kernel to force that on or use the boot parameters. You need to make sure that your kernel is compiled with CONFIG_MTRR_SANITIZER in order to be able to set the boot parameters and have it work.

You might want to look at /proc/mtrr before and after you do this to see if there is a difference. If you see a bunch of uncacheable lines change to write-back or write-through, then there is a difference and it should help performance.

Uncacheable lines means that the CPU cache is disabled for certain memory regions. if those regions are system devices, then that is a good thing, but otherwise, having uncacheable lines is a bad thing and it is often a problem on amd64 systems with 4GB of RAM or more.
Would this issue still present itself when only 2Gb is in the machine? Due to running mixed memory, we removed one brand leaving only 2Gb. There was a small improvement (which I assumed was due to the difference in RAM specifications ), but not quite the improvement we're seeking. My mate was going to get 4Gb of new RAM I believe.

Regarding the /proc/mtrr file, mine looks like this:

reg00: base=0x000000000 ( 0MB), size= 4096MB, count=1: write-back
reg01: base=0x0dff00000 ( 3583MB), size= 1MB, count=1: uncachable
reg02: base=0x0e0000000 ( 3584MB), size= 512MB, count=1: uncachable

From what I understand of what you've said, this isn't good on my system. I'm not sure what the fedora and ubuntu kernels are built with, so before I go further down this path with boot options, can this really be this much of a problem for my mate while I don't see any impact?
quadfour is offline   Reply With Quote
Old 01-10-11, 09:34 AM   #14
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: WoW in wine performance issue - chipset issue?

After posting this, I checked out my mates mtrr file. All of his entries in the file were write-back. There were a few more than I have too. I guess the newer ubuntu kernel has the appropriate kernel options enabled by default.
quadfour is offline   Reply With Quote
Old 01-10-11, 10:52 AM   #15
ShiningArcanine
Registered User
 
Join Date: Aug 2006
Posts: 106
Default Re: WoW in wine performance issue - chipset issue?

It could be that you are using AMD instead of Intel. I only use Intel systems. I doubt that the Ubuntu kernel has this enabled by default. A month ago I saw an open bug report asking for this feature to be enabled by default.
ShiningArcanine is offline   Reply With Quote
Old 01-11-11, 02:47 AM   #16
drhirsch
Registered User
 
Join Date: Jul 2005
Posts: 61
Default Re: WoW in wine performance issue - chipset issue?

Well, the 8800 GT was really good :-) But the 460 GTX is faster. But you may want to double check that he isn't accidently running WoW in direct3d mode, which still has massive performance issues (but looks better). Make sure it is started with

wine wow -opengl
drhirsch is offline   Reply With Quote
Old 01-11-11, 03:35 AM   #17
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: WoW in wine performance issue - chipset issue?

Quote:
Originally Posted by drhirsch View Post
Well, the 8800 GT was really good :-) But the 460 GTX is faster. But you may want to double check that he isn't accidently running WoW in direct3d mode, which still has massive performance issues (but looks better). Make sure it is started with

wine wow -opengl
Done this of course

Just thinking about this still, it is a WoW thing, not OS dependent. Since he's copied WoW for Linux from his Windows install, there could be some funky issue there. I'll see about getting a clean copy installed with no mods and see how that goes.

Will post results.
quadfour is offline   Reply With Quote
Old 01-11-11, 04:20 AM   #18
poltsy
Registered User
 
Join Date: Jan 2010
Posts: 26
Default Re: WoW in wine performance issue - chipset issue?

Only funky issues I can think of could be when running it from an ntfs or fat partition, that usually doesn't work very well.

Removing caches and the WTF directory you'll have a 1:1 copy of the game same as clean install. There are no magic required registry keys created at install time.
poltsy is offline   Reply With Quote
Old 01-11-11, 04:34 AM   #19
drhirsch
Registered User
 
Join Date: Jul 2005
Posts: 61
Default Re: WoW in wine performance issue - chipset issue?

I do have a dual boot system and used to run wine from an ntfs partition. I had no problems while starting and running wow, but with ending (saving the state of the addons took ages) and updating. But this seems to be an issue with ntfs-3g. Framerate was always as expected.

(Now I run wine from an ext4 partition rsynced with the ntfs partition without any issues at all)
drhirsch is offline   Reply With Quote
Old 01-11-11, 04:44 AM   #20
drhirsch
Registered User
 
Join Date: Jul 2005
Posts: 61
Default Re: WoW in wine performance issue - chipset issue?

You could start wine with a naked X server, this should rule out any influence from window managers etc.

On my system this would be as root

/etc/init.d/xdm stop (maybe different for you)
X &
(change back to terminal with ctrl-alt-f1)
export DISPLAY=:0

and as user

cd /path/to/wow
wine wow opengl
drhirsch is offline   Reply With Quote

Old 01-11-11, 06:47 AM   #21
quadfour
Registered User
 
Join Date: Mar 2004
Posts: 83
Default Re: WoW in wine performance issue - chipset issue?

Quote:
Originally Posted by drhirsch View Post
You could start wine with a naked X server, this should rule out any influence from window managers etc.

On my system this would be as root

/etc/init.d/xdm stop (maybe different for you)
X &
(change back to terminal with ctrl-alt-f1)
export DISPLAY=:0

and as user

cd /path/to/wow
wine wow opengl
Awesome idea. I'll have a go at this with them.
quadfour is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:00 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.