Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 01-19-11, 02:53 PM   #1
shl
Registered User
 
Join Date: Jan 2011
Posts: 2
Default Many problems with Vaio VPCS11X9R

Hello!

I've got Vaio laptop with videocard GeForce 310M. There are lots of troubles with it under Linux.

While booting up Ubuntu 10.10, it gives blackscreen (EDID problem, the picture goes well to an external monitor).
Adding option 'nomodeset' in grub config works well (Xorg boots and works nearly perfect) but there is no way to change backlight (always 100%).

After installing latest nvidia drivers thrrough 'Additional drivers' and adding EDID information to xorg.conf (as well as edid file itself) it freezes while booting with a purple screen of death (with 'nomodeset' it boots to a command prompt).

With 256.44 driver installed, with or without EDID, it gives a black screen ('nomodeset' option still provides command prompt).

I am attaching the following:
- nvidia-bug-report with 256.44 installed;
- xorg.conf
- edid file itself.
Once again, with these files enabled it gives black screen.

Please help me either with making any nvidia driver work or with letting me configure backlight using default driver and 'nomodeset' option.
Attached Files
File Type: gz nvidia-bug-report.log.gz (59.6 KB, 48 views)
File Type: zip xorg.zip (643 Bytes, 50 views)
File Type: zip edid.zip (232 Bytes, 48 views)
shl is offline   Reply With Quote
Old 01-24-11, 01:15 PM   #2
shl
Registered User
 
Join Date: Jan 2011
Posts: 2
Default Re: Many problems with Vaio VPCS11X9R

I've just installed the latest Nvidia 260.19.36 driver and now with 'nomodeset' enabled and custom EDID provided Xorg starts normally (only this way). I still can't change backlight and it's frustrating
shl is offline   Reply With Quote
Old 01-25-11, 02:33 PM   #3
auxbuss
Registered User
 
Join Date: Oct 2010
Posts: 10
Default Re: Many problems with Vaio VPCS11X9R

Go here to sort many of your problems:

http://code.google.com/p/vaio-f11-linux/
auxbuss is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 11:35 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.