Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 02-26-11, 05:28 PM   #13
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Hello,

Not fixed in 270.29... Powermizer still doesn't kick the GPU into high gear.

Any progress?

Thanks,

Nico
camelreef is offline   Reply With Quote
Old 02-28-11, 07:32 PM   #14
zap
Registered User
 
Join Date: Feb 2003
Location: St. Petersburg, Russia
Posts: 20
Default Re: GF100 VDPAU performance is really not good

I also have this problem. I have one machine with a 9600GT card, which plays video smooth and well (because it doesn't have any PowerMiser settings at all) and my home computer has a GT240, which has this "advanced" feature. I have observed that the performance is bad even on 720P videos, not speaking on full HD - sometimes (quite often) video will gets slower, then suddenly accelerates to let the video overtake the sound.

I ran the qvdpautest on both 9600GT and GT240, and, as expected, the numbers on GT240 are quite low (1.5-2 times slower on video decoding and 4-7 times slower on mixer algorithms), similar to the numbers in the first post. Also, the "Performance Level" in nvidia-settings always stays on 1 (never seen it even at 0), and never gets to 2, here's a screenshot.



I tried both "Adaptive" and "Prefer maximum performance" modes, and I don't see a difference between them - the driver stays on level 1, no matter what I do - nothing, play video or make love, for instance.

The results of qvdpautest:

nVidia Corporation GT215 [GeForce GT 240] (rev a2)

qvdpautest 0.5.1
Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
NVIDIA GPU GeForce GT 240 (GT215) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 260.19.36 Tue Jan 18 17:14:46 PST 2011

SURFACE GET BITS: 604.215 M/s
SURFACE PUT BITS: 657.336 M/s

MPEG DECODING (1920x1080): 53 frames/s
MPEG DECODING (1280x720): 121 frames/s
H264 DECODING (1920x1080): 45 frames/s
H264 DECODING (1280x720): 93 frames/s
VC1 DECODING (1440x1080): 61 frames/s
MPEG4 DECODING (1920x1080): 53 frames/s

MIXER WEAVE (1920x1080): 324 frames/s
MIXER BOB (1920x1080): 534 fields/s
MIXER TEMPORAL (1920x1080): 161 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 100 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 213 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 104 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 73 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 124 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 287 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 241 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 43 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 115 fields/s
zap is offline   Reply With Quote
Old 03-21-11, 08:11 PM   #15
TheSwissKnife
Registered User
 
Join Date: Sep 2010
Posts: 10
Default Re: GF100 VDPAU performance is really not good

I have exactly the same issue with an ION2 (Shuttle XS35GT). I have tried many different driver versions in 260.x and 270.x range and tried lots of RegistryDwords attempts in xorg.log etc but I can not get GPU to go to perf level 2 and the 3D clock frequencies. 195.36.24 drivers do go there, and my H264 playback is much better too.
TheSwissKnife is offline   Reply With Quote
Old 03-22-11, 04:29 AM   #16
zap
Registered User
 
Join Date: Feb 2003
Location: St. Petersburg, Russia
Posts: 20
Default Re: GF100 VDPAU performance is really not good

Perhaps this is the nvidia marketing policy to push out of the market old cards.
zap is offline   Reply With Quote
Old 04-12-11, 01:45 AM   #17
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Come on!

270.41.03 and still Powermizer is not taking the card to full clock speeds!

What's the point in having the latest and greatest hardware when the software drops the ball?

Code:
qvdpautest 0.5.1
Intel(R) Core(TM) i7 CPU       Q 840  @ 1.87GHz
NVIDIA GPU Quadro 5000M (GF100GL) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  270.41.03  Sat Apr  9 00:25:50 PDT 2011

SURFACE GET BITS: 902.368 M/s
SURFACE PUT BITS: 1069.24 M/s

MPEG DECODING (1920x1080): 75 frames/s
MPEG DECODING (1280x720): 173 frames/s
H264 DECODING (1920x1080): 43 frames/s
H264 DECODING (1280x720): 88 frames/s
VC1 DECODING (1440x1080): 61 frames/s
MPEG4 DECODING (1920x1080): 52 frames/s

MIXER WEAVE (1920x1080): 26 frames/s
MIXER BOB (1920x1080): 29 fields/s
MIXER TEMPORAL (1920x1080): 14 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 12 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 19 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 7 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 5 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 8 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 20 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 13 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 17 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 14 fields/
camelreef is offline   Reply With Quote
Old 04-12-11, 01:47 AM   #18
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Quote:
Originally Posted by camelreef View Post
Come on!

270.41.03 and still Powermizer is not taking the card to full clock speeds!

What's the point in having the latest and greatest hardware when the software drops the ball?
Yes, I am getting frustrated...
camelreef is offline   Reply With Quote
Old 05-03-11, 01:27 AM   #19
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

Code:
qvdpautest 0.5.1
Intel(R) Core(TM) i7 CPU       Q 840  @ 1.87GHz
NVIDIA GPU Quadro 5000M (GF100GL) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library  270.41.06  Mon Apr 18 15:13:22 PDT 2011

SURFACE GET BITS: 949.029 M/s
SURFACE PUT BITS: 905.417 M/s

MPEG DECODING (1920x1080): 78 frames/s
MPEG DECODING (1280x720): 174 frames/s
H264 DECODING (1920x1080): 43 frames/s
H264 DECODING (1280x720): 88 frames/s
VC1 DECODING (1440x1080): 61 frames/s
MPEG4 DECODING (1920x1080): 52 frames/s

MIXER WEAVE (1920x1080): 26 frames/s
MIXER BOB (1920x1080): 32 fields/s
MIXER TEMPORAL (1920x1080): 14 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 11 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 20 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 7 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 5 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 7 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 20 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 13 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 22 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 14 fields/s
New driver, still no improvement!
camelreef is offline   Reply With Quote
Old 05-07-11, 09:23 AM   #20
pilouface
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: GF100 VDPAU performance is really not good

Hello,

Same problem for me using an ion2 on a XS35GT... I can't reach performance level 2.
In maximum performance mode, I'm stuck at performance level 1

I thought a moment it was because the ion2 included in XS35GT was carrying only 8 cuda cores instead of 16 ?! Or because ion2 was less efficient when used with an intel atom cpu (only 1 pci line available).
But that should be independant of the clock speed...
pilouface is offline   Reply With Quote

Old 05-15-11, 01:46 PM   #21
pilouface
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: GF100 VDPAU performance is really not good

Same problem found here : http://www.nvnews.net/vbulletin/showthread.php?t=157589
And here : http://ubuntuforums.org/showpost.php...98&postcount=5

Is there a fix coming in the next driver update ?
pilouface is offline   Reply With Quote
Old 05-29-11, 02:44 AM   #22
camelreef
Registered User
 
Join Date: Nov 2006
Posts: 27
Default Re: GF100 VDPAU performance is really not good

270.41.19, same issue, Powermizer still not kicking the high gear!

<sigh>

Would 275.xx.xx help?

Nico
camelreef is offline   Reply With Quote
Old 05-29-11, 07:34 PM   #23
pilouface
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: GF100 VDPAU performance is really not good

I confirm that the bug appeared in 256.x version of the driver. The 195.36.24 can perfectly go to performance level 2 and we can see the difference in the "mixer" tests of qvdpautest...


195.36.24
Quote:
qvdpautest 0.5.1
Intel(R) Atom(TM) CPU D510 @ 1.66GHz
NVIDIA GPU ION (GT218) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 195.36.24 Thu Apr 22 10:39:56 PDT 2010

SURFACE GET BITS: 191.604 M/s
SURFACE PUT BITS: 160 M/s

MPEG DECODING (1920x1080): 54 frames/s
MPEG DECODING (1280x720): 121 frames/s
H264 DECODING (1920x1080): 50 frames/s
H264 DECODING (1280x720): 104 frames/s
VC1 DECODING (1440x1080): 62 frames/s
MPEG4 DECODING (1920x1080): 54 frames/s

MIXER WEAVE (1920x1080): 231 frames/s
MIXER BOB (1920x1080): 297 fields/s
MIXER TEMPORAL (1920x1080): 88 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 58 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 121 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 29 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 23 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 33 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 104 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 54 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 51 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 86 fields/s

256.53
Quote:

qvdpautest 0.5.1
Intel(R) Atom(TM) CPU D510 @ 1.66GHz
NVIDIA GPU ION (GT218) at PCI:1:0:0 (GPU-0)

VDPAU API version : 1
VDPAU implementation : NVIDIA VDPAU Driver Shared Library 256.53 Fri Aug 27 21:32:59 PDT 2010

SURFACE GET BITS: 186.493 M/s
SURFACE PUT BITS: 159.498 M/s

MPEG DECODING (1920x1080): 53 frames/s
MPEG DECODING (1280x720): 121 frames/s
H264 DECODING (1920x1080): 47 frames/s
H264 DECODING (1280x720): 97 frames/s
VC1 DECODING (1440x1080): 59 frames/s
MPEG4 DECODING (1920x1080): 54 frames/s

MIXER WEAVE (1920x1080): 165 frames/s
MIXER BOB (1920x1080): 212 fields/s
MIXER TEMPORAL (1920x1080): 61 fields/s
MIXER TEMPORAL + IVTC (1920x1080): 41 fields/s
MIXER TEMPORAL + SKIP_CHROMA (1920x1080): 85 fields/s
MIXER TEMPORAL_SPATIAL (1920x1080): 22 fields/s
MIXER TEMPORAL_SPATIAL + IVTC (1920x1080): 17 fields/s
MIXER TEMPORAL_SPATIAL + SKIP_CHROMA (1920x1080): 24 fields/s
MIXER TEMPORAL_SPATIAL (720x576 video to 1920x1080 display): 76 fields/s
MIXER TEMPORAL_SPATIAL + HQSCALING (720x576 video to 1920x1080 display): 40 fields/s

MULTITHREADED MPEG DECODING (1920x1080): 51 frames/s
MULTITHREADED MIXER TEMPORAL (1920x1080): 57 fields/s
GLXGEARS is around 4000 fps with the 195.x and around 3000 fps with 256.x and following drivers, which is logical as we are stuck at performance level 1.

Nvidia, please fix this powermizer issue... It has been 1 year now since the regression...
pilouface is offline   Reply With Quote
Old 06-02-11, 02:38 PM   #24
pilouface
Registered User
 
Join Date: Dec 2010
Posts: 6
Default Re: GF100 VDPAU performance is really not good

Someone to answer ?

Last edited by pilouface; 06-03-11 at 04:32 PM.
pilouface is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 06:44 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.