Go Back   nV News Forums > Linux Support Forums > NVIDIA Linux

Newegg Daily Deals

Reply
 
Thread Tools
Old 10-22-10, 01:09 PM   #1
Harkonnen
Registered User
 
Join Date: Sep 2010
Posts: 7
Default GTX460 crashes/hangs Xorg

I got ASUS ENGTX460 a couple of weeks ago and having a stability problem with it on Linux

Xorg segfaults (typical nvidia-bug-report.log.gz attached) or just hangs with 100% CPU load, either way monitor goes "no signal" and system stops responding to keyboard input. I can access system via ssh, but killing/restarting xorg doesnt restore control from console/monitor output. This may happen like 1 hour after boot or 20 hours after boot by itself, but using ctrl-alt-Fx is almost guaranteeing immediate crash. Exact messages in logs varies from crash to crash, but there is always "NVRM: os_pci_init_handle: invalid context!" some time before the crash/hang. I tried every driver from 256.44 onward, the only differences is that with 256.xx it mostly hangs and with 260.xx its mostly segfaults. Problem is 100% within linux gtx460 driver, because swapping gtx460 for my old gt9600 cures all problems, and i can play games in windows on gtx460 without problems too.
Attached Files
File Type: gz nvidia-bug-report.log.gz (81.6 KB, 80 views)
Harkonnen is offline   Reply With Quote
Old 10-22-10, 05:33 PM   #2
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: GTX460 crashes/hangs Xorg

Try updating your BIOS and kernel if that's possible.
artem is offline   Reply With Quote
Old 10-24-10, 04:18 PM   #3
Harkonnen
Registered User
 
Join Date: Sep 2010
Posts: 7
Default Re: GTX460 crashes/hangs Xorg

MB Bios is newest, card is like 2 month old and have no bios updates yet, kernel is the latest available through debian package system.

I was thinking it could be because of ancient Xorg in debian stable, upgraded to testing today, but to no avail

(WW) Oct 24 20:21:41 NVIDIA(0): WAIT (2, 6, 0x8000, 0xf7f1ffff, 0x0000b0f4)
(WW) Oct 24 20:21:48 NVIDIA(0): WAIT (1, 6, 0x8000, 0xf7f1ffff, 0x0000b0f4)
(WW) Oct 24 20:21:51 NVIDIA(0): WAIT (2, 6, 0x8000, 0x0000b040, 0x000071d4)
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: /usr/bin/X (xorg_backtrace+0x3b) [0x80adffb]
1: /usr/bin/X (mieqEnqueue+0x1ab) [0x80a066b]
2: /usr/bin/X (xf86PostMotionEventP+0xd2) [0x80b36b2]
3: /usr/lib/xorg/modules/input/evdev_drv.so (0xb6369000+0x4831) [0xb636d831]
4: /usr/lib/xorg/modules/input/evdev_drv.so (0xb6369000+0x4b26) [0xb636db26]
5: /usr/bin/X (0x8048000+0x69b9f) [0x80b1b9f]
6: /usr/bin/X (0x8048000+0x109444) [0x8151444]
7: (vdso) (__kernel_sigreturn+0x0) [0xb7fe2400]
(WW) Oct 24 20:21:58 NVIDIA(0): WAIT (1, 6, 0x8000, 0x0000b040, 0x000071d4)

and hundreds of "NVRM: os_pci_init_handle: invalid context!" in syslog
Harkonnen is offline   Reply With Quote
Old 10-25-10, 03:51 AM   #4
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: GTX460 crashes/hangs Xorg

"WAIT" errors usually indicate hardware problems OR problems withing NVIDIA driver itself. Most likely your software configuration has nothing to do with this issue.

So, have patience, bump this topic once in a while, so that NVIDIA engineers noticed it and acted upon.
artem is offline   Reply With Quote
Old 10-25-10, 04:51 PM   #5
dgp
Registered User
 
Join Date: Oct 2010
Posts: 7
Unhappy Re: GTX460 crashes/hangs Xorg

Quote:
Originally Posted by Harkonnen View Post
I got ASUS ENGTX460 a couple of weeks ago and having a stability problem with it on Linux

Xorg segfaults (typical nvidia-bug-report.log.gz attached) or just hangs with 100% CPU load, either way monitor goes "no signal" and system stops responding to keyboard input. I can access system via ssh, but killing/restarting xorg doesnt restore control from console/monitor output. This may happen like 1 hour after boot or 20 hours after boot by itself, but using ctrl-alt-Fx is almost guaranteeing immediate crash. Exact messages in logs varies from crash to crash, but there is always "NVRM: os_pci_init_handle: invalid context!" some time before the crash/hang. I tried every driver from 256.44 onward, the only differences is that with 256.xx it mostly hangs and with 260.xx its mostly segfaults. Problem is 100% within linux gtx460 driver, because swapping gtx460 for my old gt9600 cures all problems, and i can play games in windows on gtx460 without problems too.
I have exactly the same behaviour with my Quadro FX 3600M, "fortunately", only with 260.19.12 (with 256.53 this problem is not present). It doesn't matter if I use compositing or not, or KDE/Gnome.

P.S. I removed the thousands of repeating messages because the file was above 140 KB.

I forgot to mention that I have similar behaviour with the same hardware with Windows 7 x64 and 260.89 - I get the login screen and when I login I hear that the windows beeps with an error and the nothing happens. The problem is again not present with 256. Unfortunately, I don't have time to diagnose the problem in windows.
Attached Files
File Type: gz nvidia-bug-report.log.gz (24.8 KB, 81 views)
dgp is offline   Reply With Quote
Old 10-27-10, 05:45 AM   #6
dgp
Registered User
 
Join Date: Oct 2010
Posts: 7
Default Re: GTX460 crashes/hangs Xorg

I tried the following setups and the problem still occurs:
1. Default OpenSUSE 11.3 X.org 1.8 with NVreg_EnableMSI=1
2. X.org 1.9 with NVreg_EnableMSI=1

As said before 256.53 works fine. I hope this helps.
dgp is offline   Reply With Quote
Old 11-05-10, 03:00 AM   #7
dgp
Registered User
 
Join Date: Oct 2010
Posts: 7
Default Re: GTX460 crashes/hangs Xorg

I just want to mention that the problem occurs with kernel 2.6.36 + Xorg 1.9 + nvidia 260.19.12, too. It's seems, however, that no one cares about this problem and this is sad, because 256.53 are not compatible with 2.6.36, which would force me and other users to use even older version of the driver (and I'm not sure if they are compatible with 2.6.36).
dgp is offline   Reply With Quote
Old 11-05-10, 04:28 AM   #8
cleanrock
Registered User
 
Join Date: Feb 2009
Posts: 32
Default Re: GTX460 crashes/hangs Xorg

Just wanna say that my Gigabyte GTX 460 1GB works fine on my archlinux:
- 260.19.12
- 2.6.35
- xorg 1.9.2 (all default, i.e. no xorg.conf)

Perhaps it could be worth the effort to try your hw setup on another distribution to make sure its not a OpenSUSE problem.
cleanrock is offline   Reply With Quote

Old 11-05-10, 06:34 AM   #9
artem
Registered User
 
Join Date: Jun 2006
Posts: 705
Default Re: GTX460 crashes/hangs Xorg

Patch for 256.53 for Linux Kernel 2.6.36.
artem is offline   Reply With Quote
Old 11-07-10, 03:00 PM   #10
dgp
Registered User
 
Join Date: Oct 2010
Posts: 7
Default Re: GTX460 crashes/hangs Xorg

Quote:
Originally Posted by cleanrock View Post
Perhaps it could be worth the effort to try your hw setup on another distribution to make sure its not a OpenSUSE problem.
Yes, it migth be. But I thought that, given nVidia provides repository and packages only for openSUSE, it should be supported.
dgp is offline   Reply With Quote
Old 11-07-10, 03:20 PM   #11
dgp
Registered User
 
Join Date: Oct 2010
Posts: 7
Default Re: GTX460 crashes/hangs Xorg

Thanks for the patch - it works! However, I do hope, that the problem will be fixed with the next 260 release.
dgp is offline   Reply With Quote
Old 11-11-10, 08:52 AM   #12
dgp
Registered User
 
Join Date: Oct 2010
Posts: 7
Red face Re: GTX460 crashes/hangs Xorg

I tested the pre-release 260.19.21 and I still got hundreds of "NVRM: os_pci_init_handle: invalid context!", however, it's good to see that the devs are putting some effort to fix the 260 driver, and not rush into implementing yet another cool feature.
dgp is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 04:50 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.